summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-03-01 03:08:49 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-03-01 03:08:49 +0000
commit26c36463ff3433f263e415082cc3d9cd7eb776b8 (patch)
tree3c57f92de67f9bdb92904689e4f699e77ad62584 /dev-python
parentnew tarball (diff)
downloadgentoo-2-26c36463ff3433f263e415082cc3d9cd7eb776b8.tar.gz
gentoo-2-26c36463ff3433f263e415082cc3d9cd7eb776b8.tar.bz2
gentoo-2-26c36463ff3433f263e415082cc3d9cd7eb776b8.zip
fix for bug #778: gnome-python build issues
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/gnome-python/ChangeLog15
-rw-r--r--dev-python/gnome-python/files/digest-gnome-python-1.4.1-r41
-rw-r--r--dev-python/gnome-python/gnome-python-1.4.1-r4.ebuild57
3 files changed, 64 insertions, 9 deletions
diff --git a/dev-python/gnome-python/ChangeLog b/dev-python/gnome-python/ChangeLog
index 441da0e5d9cf..d82093f638ad 100644
--- a/dev-python/gnome-python/ChangeLog
+++ b/dev-python/gnome-python/ChangeLog
@@ -1,13 +1,10 @@
# ChangeLog for dev-python/gnome-python
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python/ChangeLog,v 1.1 2002/02/01 21:53:28 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python/ChangeLog,v 1.2 2002/03/01 03:08:49 blocke Exp $
-*gnome-python-1.4.1-r3 (1 Feb 2002)
+*gnome-python-1.4.1-r4 (28 Feb 2002)
+
+ 22 Feb 2002; Bruce A. Locke <blocke@shivan.org> gnome-python-1.4.1-r4.ebuild :
+
+ Hopefully fix bug #778 (capplet header issue)
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
diff --git a/dev-python/gnome-python/files/digest-gnome-python-1.4.1-r4 b/dev-python/gnome-python/files/digest-gnome-python-1.4.1-r4
new file mode 100644
index 000000000000..1297e9760a66
--- /dev/null
+++ b/dev-python/gnome-python/files/digest-gnome-python-1.4.1-r4
@@ -0,0 +1 @@
+MD5 52f8b5ef4cbdaba3c00c08e28702be69 gnome-python-1.4.1.tar.gz 627218
diff --git a/dev-python/gnome-python/gnome-python-1.4.1-r4.ebuild b/dev-python/gnome-python/gnome-python-1.4.1-r4.ebuild
new file mode 100644
index 000000000000..29ce7d83e93f
--- /dev/null
+++ b/dev-python/gnome-python/gnome-python-1.4.1-r4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python/gnome-python-1.4.1-r4.ebuild,v 1.1 2002/03/01 03:08:49 blocke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="gnome-python"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/latest/sources/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org"
+
+DEPEND="virtual/python
+ >=x11-libs/gtk+-1.2.10-r4
+ >=media-libs/imlib-1.9.10-r1
+ gnome? ( >=gnome-base/gnome-core-1.4.0.4-r1
+ >=gnome-base/libglade-0.17-r1
+ >=gnome-base/control-center-1.4.0.4 )
+ opengl? ( >=x11-libs/gtkglarea-1.2.2-r1 )"
+
+src_compile() {
+
+ if [ -n "`use gnome`" ]
+ then
+ PYTHON="/usr/bin/python" ./configure --host=${CHOST} \
+ --prefix=/usr \
+ ${myopts} || die
+ make CFLAGS="${CFLAGS} \`gnome-config capplet --cflags\`" || die
+ else
+ cd ${S}/pygtk
+ PYTHON="/usr/bin/python" ./configure --host=${CHOST} \
+ --prefix=/usr \
+ ${myopts} || die
+ make || die
+ fi
+}
+
+src_install() {
+
+ if [ -n "`use gnome`" ]
+ then
+ cd ${S}/pygnome
+ make prefix=${D}/usr install || die
+
+ dodoc AUTHORS COPYING* ChangeLog NEWS MAPPING
+ dodoc README*
+
+ cd ${S}/pygnome
+ docinto pygnome
+ dodoc COPYING
+ fi
+
+ cd ${S}/pygtk
+ make prefix=${D}/usr install || die
+
+ cd ${S}/pygtk
+ docinto pygtk
+ dodoc AUTHORS COPYING ChangeLog NEWS MAPPING README
+}