summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-11-15 14:45:05 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-11-15 14:45:05 +0000
commit2b59aa5c985525a251839cca76adb28e3f785426 (patch)
tree315f4db8f04847869c44a0852a02e7723f38d084 /dev-python
parentRevision bump. Marking stable for all archs for remote vulnerability security... (diff)
downloadgentoo-2-2b59aa5c985525a251839cca76adb28e3f785426.tar.gz
gentoo-2-2b59aa5c985525a251839cca76adb28e3f785426.tar.bz2
gentoo-2-2b59aa5c985525a251839cca76adb28e3f785426.zip
Add pyqwt-5, thanks to Gerard Vermeulen and bug #175657
(Portage version: 2.1.3.16)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyqwt/ChangeLog7
-rw-r--r--dev-python/pyqwt/files/digest-pyqwt-5.0.13
-rw-r--r--dev-python/pyqwt/pyqwt-5.0.1.ebuild49
3 files changed, 58 insertions, 1 deletions
diff --git a/dev-python/pyqwt/ChangeLog b/dev-python/pyqwt/ChangeLog
index 0541ce86e2ae..d37a52ec759d 100644
--- a/dev-python/pyqwt/ChangeLog
+++ b/dev-python/pyqwt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyqwt
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/ChangeLog,v 1.5 2007/03/13 19:17:30 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/ChangeLog,v 1.6 2007/11/15 14:45:04 caleb Exp $
+
+*pyqwt-5.0.1 (15 Nov 2007)
+
+ 15 Nov 2007; Caleb Tennis <caleb@gentoo.org> +pyqwt-5.0.1.ebuild:
+ version bump, thanks to bug #175657 and Gerard Vermeulen
*pyqwt-4.2-r1 (13 Mar 2007)
diff --git a/dev-python/pyqwt/files/digest-pyqwt-5.0.1 b/dev-python/pyqwt/files/digest-pyqwt-5.0.1
new file mode 100644
index 000000000000..8eed24ab1796
--- /dev/null
+++ b/dev-python/pyqwt/files/digest-pyqwt-5.0.1
@@ -0,0 +1,3 @@
+MD5 295dd6d7cd9bc4ca898bad8f774d4106 PyQwt-5.0.1.tar.gz 2180960
+RMD160 c8d8859f26c4fca94c8f43a237bb525469bc408a PyQwt-5.0.1.tar.gz 2180960
+SHA256 13a00e30940e4384c18b6fd785377e2ed415b9a7b452211c840e6aa80236614b PyQwt-5.0.1.tar.gz 2180960
diff --git a/dev-python/pyqwt/pyqwt-5.0.1.ebuild b/dev-python/pyqwt/pyqwt-5.0.1.ebuild
new file mode 100644
index 000000000000..55a852db9699
--- /dev/null
+++ b/dev-python/pyqwt/pyqwt-5.0.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/pyqwt-5.0.1.ebuild,v 1.1 2007/11/15 14:45:04 caleb Exp $
+
+inherit eutils
+
+MY_P=PyQwt-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Python bindings for the Qwt library"
+SRC_URI="mirror://sourceforge/pyqwt/${MY_P}.tar.gz"
+HOMEPAGE="http://pyqwt.sourceforge.net/"
+
+SLOT="5"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE="debug doc examples"
+
+DEPEND="virtual/python
+ =x11-libs/qwt-5*
+ >=dev-python/PyQt4-4.2
+ >=dev-python/sip-4.1.1
+ >=dev-python/numpy-1.0.1"
+
+src_compile() {
+ cd ${S}/sip/qwt5qt4
+ # PyQwt CVS does not need the next 2 sed statements anymore
+ sed -i "s|%Import QtSvg/QtSvgmod.sip||" QwtModule.sip
+ sed -i "s|%Include qwt_plot_svgitem.sip||" QwtModule.sip
+ cd "${S}/configure"
+ local myconf="-I /usr/include/qwt5 -l qwt --disable-numarray --disable-numeric"
+ use debug && myconf="${myconf} --debug"
+ has distcc ${FEATURES} || myconf="${myconf} -j 1"
+ python configure.py ${myconf}
+ emake || die "emake failed"
+}
+
+src_install() {
+ cd "${S}/configure"
+ make DESTDIR="${D}" install || die "make install failed"
+ cd "${S}"
+ dodoc ANNOUNCEMENT-${PV} CHANGES-${PV} COPYING* README
+ use doc && dohtml Doc/html/pyqwt/*
+ if use examples ; then
+ dodir /usr/share/doc/${PF}/examples
+ cp -r qt4examples/ "${D}/usr/share/doc/${PF}/examples"
+ fi
+}
+