summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-03-04 06:15:37 +0000
committerIan Delaney <idella4@gentoo.org>2013-03-04 06:15:37 +0000
commit2ef23d7afc9f4ae6e568b632f9a95c14f5633fec (patch)
tree5036193f52db9a2b2c4b598a1b24f06242d78dc4 /dev-python
parentRemove unnecessary binary striping, wrt bug #460112. Thanks to Agostino Sarub... (diff)
downloadgentoo-2-2ef23d7afc9f4ae6e568b632f9a95c14f5633fec.tar.gz
gentoo-2-2ef23d7afc9f4ae6e568b632f9a95c14f5633fec.tar.bz2
gentoo-2-2ef23d7afc9f4ae6e568b632f9a95c14f5633fec.zip
Patch added wrt Bug #457586 by Ago
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wxpython/ChangeLog6
-rw-r--r--dev-python/wxpython/files/wxpython-2.8.12-drop-categories.patch33
-rw-r--r--dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild3
3 files changed, 40 insertions, 2 deletions
diff --git a/dev-python/wxpython/ChangeLog b/dev-python/wxpython/ChangeLog
index 284b4c6e0375..3252547ffad4 100644
--- a/dev-python/wxpython/ChangeLog
+++ b/dev-python/wxpython/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/wxpython
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.174 2013/02/06 10:46:39 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.175 2013/03/04 06:15:37 idella4 Exp $
+
+ 04 Mar 2013; Ian Delaney <idella4@gentoo.org>
+ +files/wxpython-2.8.12-drop-categories.patch, wxpython-2.8.12.1-r1.ebuild:
+ Patch added wrt Bug #457586 by Ago
*wxpython-2.9.4.1-r1 (06 Feb 2013)
*wxpython-2.8.12.1-r1 (06 Feb 2013)
diff --git a/dev-python/wxpython/files/wxpython-2.8.12-drop-categories.patch b/dev-python/wxpython/files/wxpython-2.8.12-drop-categories.patch
new file mode 100644
index 000000000000..245e2da34573
--- /dev/null
+++ b/dev-python/wxpython/files/wxpython-2.8.12-drop-categories.patch
@@ -0,0 +1,33 @@
+Fix QA issue wrt Bug 457586
+diff -ur wxPython-src-2.8.12.1.orig/wxPython/distrib/PyAlaMode.desktop wxPython-src-2.8.12.1/wxPython/distrib/PyAlaMode.desktop
+--- distrib/PyAlaMode.desktop 2007-07-19 06:33:55.000000000 +0800
++++ distrib/PyAlaMode.desktop 2013-03-04 13:48:51.737419595 +0800
+@@ -5,4 +5,3 @@
+ Icon=PyCrust.png
+ Terminal=false
+ Type=Application
+-Categories=Application;Development;
+diff -ur wxPython-src-2.8.12.1.orig/wxPython/distrib/PyCrust.desktop wxPython-src-2.8.12.1/wxPython/distrib/PyCrust.desktop
+--- distrib/PyCrust.desktop 2007-07-19 06:33:55.000000000 +0800
++++ distrib/PyCrust.desktop 2013-03-04 13:49:12.209418445 +0800
+@@ -5,4 +5,3 @@
+ Icon=PyCrust.png
+ Terminal=false
+ Type=Application
+-Categories=Application;Development;
+diff -ur wxPython-src-2.8.12.1.orig/wxPython/distrib/PyShell.desktop wxPython-src-2.8.12.1/wxPython/distrib/PyShell.desktop
+--- distrib/PyShell.desktop 2007-07-19 06:33:55.000000000 +0800
++++ distrib/PyShell.desktop 2013-03-04 13:49:28.713417518 +0800
+@@ -5,4 +5,3 @@
+ Icon=PyCrust.png
+ Terminal=false
+ Type=Application
+-Categories=Application;Development;
+diff -ur wxPython-src-2.8.12.1.orig/wxPython/distrib/XRCed.desktop wxPython-src-2.8.12.1/wxPython/distrib/XRCed.desktop
+--- distrib/XRCed.desktop 2007-07-19 06:33:55.000000000 +0800
++++ distrib/XRCed.desktop 2013-03-04 13:49:46.345416526 +0800
+@@ -5,4 +5,3 @@
+ Icon=XRCed.png
+ Terminal=false
+ Type=Application
+-Categories=Application;Development;
diff --git a/dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild b/dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild
index 05036160c83d..dc0f71c5a723 100644
--- a/dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild
+++ b/dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild,v 1.1 2013/02/06 10:46:39 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild,v 1.2 2013/03/04 06:15:37 idella4 Exp $
EAPI=5
@@ -64,6 +64,7 @@ python_prepare_all() {
"${FILESDIR}"/${PN}-2.8.9-wxversion-scripts.patch
# drop editra - we have it as a separate package now
"${FILESDIR}"/${PN}-2.8.12-drop-editra.patch
+ "${FILESDIR}"/${PN}-2.8.12-drop-categories.patch
)
distutils-r1_python_prepare_all