summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-06-28 15:12:11 +0000
committerIan Delaney <idella4@gentoo.org>2014-06-28 15:12:11 +0000
commit3034807cc90abb9d67d6f934ffa3b7ada5b7a7ae (patch)
treef32c76e892c7d3844827c5443a21903a0fd0c1ed /dev-python
parentRemove old (diff)
downloadgentoo-2-3034807cc90abb9d67d6f934ffa3b7ada5b7a7ae.tar.gz
gentoo-2-3034807cc90abb9d67d6f934ffa3b7ada5b7a7ae.tar.bz2
gentoo-2-3034807cc90abb9d67d6f934ffa3b7ada5b7a7ae.zip
drop py2.6 py3.2 pypy2_0 add py3.4, add missing dep, patch submitted by fau, fixes bug #515166
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/fudge/ChangeLog6
-rw-r--r--dev-python/fudge/fudge-1.0.3-r2.ebuild7
2 files changed, 9 insertions, 4 deletions
diff --git a/dev-python/fudge/ChangeLog b/dev-python/fudge/ChangeLog
index 3466ce19ad6f..0729cf4d3b66 100644
--- a/dev-python/fudge/ChangeLog
+++ b/dev-python/fudge/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/fudge
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fudge/ChangeLog,v 1.11 2014/03/31 20:53:37 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fudge/ChangeLog,v 1.12 2014/06/28 15:12:11 idella4 Exp $
+
+ 28 Jun 2014; Ian Delaney <idella4@gentoo.org> fudge-1.0.3-r2.ebuild:
+ drop py2.6 py3.2 pypy2_0 add py3.4, add missing dep, patch submitted by fau,
+ fixes bug #515166
31 Mar 2014; Michał Górny <mgorny@gentoo.org> fudge-0.9.6-r1.ebuild,
fudge-1.0.3-r2.ebuild:
diff --git a/dev-python/fudge/fudge-1.0.3-r2.ebuild b/dev-python/fudge/fudge-1.0.3-r2.ebuild
index d320ed098fae..1c87a87ef1a1 100644
--- a/dev-python/fudge/fudge-1.0.3-r2.ebuild
+++ b/dev-python/fudge/fudge-1.0.3-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fudge/fudge-1.0.3-r2.ebuild,v 1.4 2014/03/31 20:53:37 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fudge/fudge-1.0.3-r2.ebuild,v 1.5 2014/06/28 15:12:11 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
inherit distutils-r1
@@ -17,7 +17,8 @@ KEYWORDS="~amd64 ~x86"
IUSE="doc test"
RDEPEND=""
-DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/nose[${PYTHON_USEDEP}] )"
python_prepare_all() {