summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-05-27 20:43:32 +0000
committerPacho Ramos <pacho@gentoo.org>2015-05-27 20:43:32 +0000
commit3ea69a133bdc088c487898ba36a8ea2391c2931c (patch)
tree74000e23bef3c043409691195d84b239cfcedd66 /dev-python
parentNewer vpnc is needed (#549038) (diff)
downloadgentoo-2-3ea69a133bdc088c487898ba36a8ea2391c2931c.tar.gz
gentoo-2-3ea69a133bdc088c487898ba36a8ea2391c2931c.tar.bz2
gentoo-2-3ea69a133bdc088c487898ba36a8ea2391c2931c.zip
Version bump (#549254)
(Portage version: 2.2.19/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pycups/ChangeLog7
-rw-r--r--dev-python/pycups/pycups-1.9.72.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-python/pycups/ChangeLog b/dev-python/pycups/ChangeLog
index cfc2ec0ca188..e8f0efac5990 100644
--- a/dev-python/pycups/ChangeLog
+++ b/dev-python/pycups/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pycups
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycups/ChangeLog,v 1.95 2015/04/08 08:04:58 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycups/ChangeLog,v 1.96 2015/05/27 20:43:32 pacho Exp $
+
+*pycups-1.9.72 (27 May 2015)
+
+ 27 May 2015; Pacho Ramos <pacho@gentoo.org> +pycups-1.9.72.ebuild:
+ Version bump (#549254)
08 Apr 2015; Michał Górny <mgorny@gentoo.org> pycups-1.9.68.ebuild:
Drop old Python implementations
diff --git a/dev-python/pycups/pycups-1.9.72.ebuild b/dev-python/pycups/pycups-1.9.72.ebuild
new file mode 100644
index 000000000000..48419e23fd42
--- /dev/null
+++ b/dev-python/pycups/pycups-1.9.72.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycups/pycups-1.9.72.ebuild,v 1.1 2015/05/27 20:43:32 pacho Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the CUPS API"
+HOMEPAGE="http://cyberelk.net/tim/data/pycups/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+SLOT="0"
+IUSE="doc examples"
+
+RDEPEND="
+ net-print/cups
+"
+DEPEND="${RDEPEND}"
+
+# epydoc kinda sucks and supports python2 only (it's dead too),
+# and since we're dealing with a binary module we need exact version
+# match. therefore, docbuilding *requires* any python2 being enabled.
+
+DEPEND="${RDEPEND}
+ doc? ( dev-python/epydoc[$(python_gen_usedep 'python2*')] )
+"
+
+REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+
+python_compile_all() {
+ if use doc; then
+ # we can't use Makefile since it relies on hardcoded paths
+ epydoc -o html --html cups || die "doc build failed"
+ fi
+}
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( html/ )
+ use examples && local EXAMPLES=( examples/ )
+
+ distutils-r1_python_install_all
+}