summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2005-02-27 02:33:23 +0000
committerBryan Østergaard <kloeri@gentoo.org>2005-02-27 02:33:23 +0000
commit5c86bda8d383092fd8ad0327a82f3334835d8407 (patch)
tree2066c59892d198e539b2a79e19d856e50bfb3a67 /dev-python
parentMultilib fixes. (diff)
downloadgentoo-2-5c86bda8d383092fd8ad0327a82f3334835d8407.tar.gz
gentoo-2-5c86bda8d383092fd8ad0327a82f3334835d8407.tar.bz2
gentoo-2-5c86bda8d383092fd8ad0327a82f3334835d8407.zip
Fix broken configuration.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/mod_python/ChangeLog7
-rw-r--r--dev-python/mod_python/files/16_mod_python-r1.conf40
-rw-r--r--dev-python/mod_python/mod_python-2.7.11.ebuild12
-rw-r--r--dev-python/mod_python/mod_python-3.1.4.ebuild8
4 files changed, 61 insertions, 6 deletions
diff --git a/dev-python/mod_python/ChangeLog b/dev-python/mod_python/ChangeLog
index 02d39a527c0d..28f129210f5f 100644
--- a/dev-python/mod_python/ChangeLog
+++ b/dev-python/mod_python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/mod_python
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/ChangeLog,v 1.29 2005/02/26 12:27:02 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/ChangeLog,v 1.30 2005/02/27 02:33:22 kloeri Exp $
+
+ 27 Feb 2005; Bryan Østergaard <kloeri@gentoo.org>
+ +files/16_mod_python-r1.conf, mod_python-2.7.11.ebuild,
+ mod_python-3.1.4.ebuild:
+ Fix broken configuration.
*mod_python-2.7.11 (26 Feb 2005)
diff --git a/dev-python/mod_python/files/16_mod_python-r1.conf b/dev-python/mod_python/files/16_mod_python-r1.conf
new file mode 100644
index 000000000000..c2df73cf8ff2
--- /dev/null
+++ b/dev-python/mod_python/files/16_mod_python-r1.conf
@@ -0,0 +1,40 @@
+<IfDefine PYTHON>
+ <IfModule !mod_python.c>
+ LoadModule python_module modules/mod_python.so
+ </IfModule>
+</IfDefine>
+
+<IfModule mod_python.c>
+#
+# Mod_python is a module that embeds the Python language interpreter
+# within the server, allowing Apache handlers to be written in Python.
+#
+
+# This will cause files beneath /home/httpd/htdocs with the extension .spam
+# to be handled by the Python script /home/httpd/htdocs/eggs.py
+#
+#<Directory /home/httpd/htdocs>
+# <IfModule mod_mime.c>
+# AddHandler python-program .spam
+# </IfModule>
+# PythonHandler eggs
+#</Directory>
+
+# This will cause all requests to the /python heirachy of your
+# webserver to be handled by the python script /path/to/myhandler.py
+#
+#<Location /python>
+# SetHandler python-program
+# PythonPath "sys.path + ['/path/to']"
+# PythonHandler myhandler
+#</Location>
+
+# This will cause all requests to the /python heirachy of your
+# webserver to be handled by mod_python's Publisher handler
+#
+#<Location /python>
+# SetHandler python-program
+# PythonHandler mod_python.publisher
+#</Location>
+
+</IfModule>
diff --git a/dev-python/mod_python/mod_python-2.7.11.ebuild b/dev-python/mod_python/mod_python-2.7.11.ebuild
index 4452b6868e18..75b628d19212 100644
--- a/dev-python/mod_python/mod_python-2.7.11.ebuild
+++ b/dev-python/mod_python/mod_python-2.7.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/mod_python-2.7.11.ebuild,v 1.1 2005/02/26 12:27:02 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/mod_python-2.7.11.ebuild,v 1.2 2005/02/27 02:33:22 kloeri Exp $
inherit python apache-module
@@ -13,7 +13,7 @@ KEYWORDS="~x86"
SLOT="0"
IUSE=""
-APACHE1_MOD_CONF="${PV}/16_${PN}"
+#APACHE1_MOD_CONF="16_${PN}-r1"
APACHE1_MOD_DEFINE="PYTHON"
DOCFILES="COPYRIGHT CREDITS NEWS README"
@@ -21,11 +21,15 @@ DOCFILES="COPYRIGHT CREDITS NEWS README"
need_apache1
src_compile() {
+ # If we dont add that, ./configure breaks this ebuild
+ # because the last task (make depend) is somehow borked
+ echo 'echo "configure done"' >> configure
+
sed -ie 's:OPT=:OPT=$(OPTFLAGS):' ${S}/src/Makefile.in
sed -ie 's/\(\\"thread\\" in sys.builtin_module_names\)/int(\1)/' ${S}/configure
export OPTFLAGS="`/usr/sbin/apxs -q CFLAGS`"
- econf --with-apxs=${APXS1} || die "econf failed"
+ econf --with-apxs=${APXS1}
sed -ie 's:LIBEXECDIR=:LIBEXECDIR=${D}:' Makefile
sed -ie 's:PY_STD_LIB=:PY_STD_LIB=${D}:' Makefile
@@ -51,4 +55,6 @@ src_install() {
doins doc-html/icons/*
apache-module_src_install
+ insinto ${APACHE1_MODULES_CONFDIR}
+ newins ${FILESDIR}/16_${PN}-r1.conf 16_${PN}.conf
}
diff --git a/dev-python/mod_python/mod_python-3.1.4.ebuild b/dev-python/mod_python/mod_python-3.1.4.ebuild
index 9b61a09b5f10..cbcc7fbac488 100644
--- a/dev-python/mod_python/mod_python-3.1.4.ebuild
+++ b/dev-python/mod_python/mod_python-3.1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/mod_python-3.1.4.ebuild,v 1.1 2005/02/26 12:27:02 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/mod_python-3.1.4.ebuild,v 1.2 2005/02/27 02:33:22 kloeri Exp $
inherit python eutils apache-module
@@ -14,7 +14,7 @@ KEYWORDS="x86 alpha ppc ~sparc ~amd64"
IUSE=""
DEPEND="dev-lang/python"
-APACHE2_MOD_CONF="2.7.11/16_${PN}"
+#APACHE2_MOD_CONF="2.7.11/16_${PN}"
APACHE2_MOD_DEFINE="PYTHON"
DOCFILES="README NEWS CREDITS COPYRIGHT"
@@ -49,6 +49,10 @@ src_install() {
doins doc-html/icons/*
apache-module_src_install
+ einfo ${APACHE2_MODULES_CONFDIR}
+ einfo ${FILESDIR}/16_${PN}-r1.conf
+ insinto ${APACHE2_MODULES_CONFDIR}
+ newins ${FILESDIR}/16_${PN}-r1.conf 16_${PN}.conf
}
pkg_postinst() {