summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-01-07 23:26:20 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-01-07 23:26:20 +0000
commit600e671af54eb72014e8297e9390deed245b6011 (patch)
treeb3c5cc51760a3ae12dc0b90c6051ca37081afc66 /dev-python
parentnew version (diff)
downloadgentoo-2-600e671af54eb72014e8297e9390deed245b6011.tar.gz
gentoo-2-600e671af54eb72014e8297e9390deed245b6011.tar.bz2
gentoo-2-600e671af54eb72014e8297e9390deed245b6011.zip
Moved wxPython to dev-python, added digest for python 2.2
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wxPython/files/digest-wxPython-2.3.2.11
-rw-r--r--dev-python/wxPython/wxPython-2.3.2.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/wxPython/files/digest-wxPython-2.3.2.1 b/dev-python/wxPython/files/digest-wxPython-2.3.2.1
new file mode 100644
index 000000000000..392b709d186c
--- /dev/null
+++ b/dev-python/wxPython/files/digest-wxPython-2.3.2.1
@@ -0,0 +1 @@
+MD5 e57b4d030c4ba43a9030fdaee083011c wxPython-2.3.2.1.tar.gz 2846720
diff --git a/dev-python/wxPython/wxPython-2.3.2.1.ebuild b/dev-python/wxPython/wxPython-2.3.2.1.ebuild
new file mode 100644
index 000000000000..5117f382fb62
--- /dev/null
+++ b/dev-python/wxPython/wxPython-2.3.2.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tod Neidt <tneidt@fidnet.com>
+# $Header $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="A blending of the wxWindows C++ class library with Python."
+
+SRC_URI="http://prdownloads.sourceforge.net/wxpython/${P}.tar.gz"
+
+HOMEPAGE="http://www.wxpython.org/"
+
+DEPEND=">=dev-lang/python-2.1
+ >=dev-libs/glib-1.2.5
+ >=x11-libs/gtk+-1.2.5
+ >=x11-libs/wxGTK-2.3.2"
+ #opengl? ( virtual/opengl )"
+ #really need opengl? ( virtual/opengl dev-python/PyOpenGL )
+ #to get full opengl functionality, i.e. wxGLCanvas.
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+
+ #local myconf
+ #myconf=""
+
+#Other possible configuration variables are BUILD_OGL and BUILD_STC.
+#BUILD_OGL builds the Object Graphics Library extension module.
+#BUILD_STC builds the wxStyledTextCtrl (the Scintilla wrapper) extension
+module.
+#Both these variable are enabled by default. To disable them set equal to
+zero
+#and add to myconf.
+
+ #use opengl || myconf="${myconf} BUILD_GLCANVAS=0"
+ #myconf="${myconf} BUILD_GLCANVAS=0"
+
+
+ python setup.py build ${myconf} || die
+
+}
+
+src_install () {
+
+ python setup.py install --prefix=${D}/usr || die
+
+ dodoc BUILD.unix.txt CHANGES.txt MANIFEST.in PKG-INFO README.txt
+
+}