summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2008-07-31 06:44:06 +0000
committerJesus Rivero <neurogeek@gentoo.org>2008-07-31 06:44:06 +0000
commit6d21235885dbf2af60b0b8f1b935819e20dadb2c (patch)
tree051128799e653712884de018ad634682c28e76d1 /dev-python
parentpatch for building with gcc-4.3 submitted by Jabari R. Roberts via bug #233447 (diff)
downloadgentoo-2-6d21235885dbf2af60b0b8f1b935819e20dadb2c.tar.gz
gentoo-2-6d21235885dbf2af60b0b8f1b935819e20dadb2c.tar.bz2
gentoo-2-6d21235885dbf2af60b0b8f1b935819e20dadb2c.zip
Fixes bugs #233369 and #222435, thanks to Remy Bosch for the patch. Removed old version
(Portage version: 2.2_rc3/cvs/Linux 2.6.18-gentoo-r3 i686)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyQt4/ChangeLog9
-rw-r--r--dev-python/PyQt4/PyQt4-4.4-r1.ebuild (renamed from dev-python/PyQt4/PyQt4-4.4.ebuild)5
-rw-r--r--dev-python/PyQt4/files/PyQt4-4.4_compile.patch21
3 files changed, 33 insertions, 2 deletions
diff --git a/dev-python/PyQt4/ChangeLog b/dev-python/PyQt4/ChangeLog
index 1d9cb1097daf..147f1825aa53 100644
--- a/dev-python/PyQt4/ChangeLog
+++ b/dev-python/PyQt4/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/PyQt4
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.32 2008/05/25 13:05:29 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.33 2008/07/31 06:44:05 neurogeek Exp $
+
+*PyQt4-4.4-r1 (31 Jul 2008)
+
+ 31 Jul 2008; Jesus Rivero <neurogeek@gentoo.org>
+ +files/PyQt4-4.4_compile.patch, -PyQt4-4.4.ebuild, +PyQt4-4.4-r1.ebuild:
+ Fixes bugs #233369 and #222435, thanks to Remy Bosch for the patch.
+ Removed old version
25 May 2008; Ingmar Vanhassel <ingmar@gentoo.org> PyQt4-4.4.2.ebuild:
dev-python/PyQt4-4.4.2 needs Qt-4.4.0, fix dependencies, mask package.
diff --git a/dev-python/PyQt4/PyQt4-4.4.ebuild b/dev-python/PyQt4/PyQt4-4.4-r1.ebuild
index c633b90d255c..f3b932e6354a 100644
--- a/dev-python/PyQt4/PyQt4-4.4.ebuild
+++ b/dev-python/PyQt4/PyQt4-4.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.4.ebuild,v 1.1 2008/05/14 20:16:36 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.4-r1.ebuild,v 1.1 2008/07/31 06:44:05 neurogeek Exp $
inherit distutils qt4
@@ -25,6 +25,7 @@ QT4_BUILT_WITH_USE_CHECK="zlib"
src_unpack() {
unpack ${A}
+ epatch "${FILESDIR}/${P}_compile.patch"
sed -i -e "s:^[ \t]*check_license():# check_license():" "${S}"/configure.py
sed -i -e "s:join(qt_dir, \"mkspecs\":join(\"/usr/share/qt4\", \"mkspecs\":g" "${S}"/configure.py
sed -i -e "s:\"QT_INSTALL_HEADERS\"\: os.path.join(qt_dir, \"include\":\"QT_INSTALL_HEADERS\"\: os.path.join(qt_dir, \"include/qt4\":g" "${S}"/configure.py
@@ -39,6 +40,8 @@ src_compile() {
use debug && myconf="${myconf} -u"
"${python}" configure.py ${myconf}
+
+ sed -i -e 'i #!/bin/bash\n' "${S}"/pyuic/pyuic4 || die "sed failed"
emake || die "emake failed"
}
diff --git a/dev-python/PyQt4/files/PyQt4-4.4_compile.patch b/dev-python/PyQt4/files/PyQt4-4.4_compile.patch
new file mode 100644
index 000000000000..e2479f2b0fa4
--- /dev/null
+++ b/dev-python/PyQt4/files/PyQt4-4.4_compile.patch
@@ -0,0 +1,21 @@
+diff -ru PyQt-x11-gpl-4.4_old/designer/pluginloader.cpp PyQt-x11-gpl-4.4/designer/pluginloader.cpp
+--- PyQt-x11-gpl-4.4_old/designer/pluginloader.cpp 2008-05-20 20:12:41.000000000 +0200
++++ PyQt-x11-gpl-4.4/designer/pluginloader.cpp 2008-05-20 20:13:37.000000000 +0200
+@@ -280,7 +280,7 @@
+ // Return the named attribute object from the named module.
+ PyObject *PyCustomWidgets::getModuleAttr(const char *module, const char *attr)
+ {
+-#if PY_VERSION_HEX >= 0x020500
++#if PY_VERSION_HEX >= 0x02050000
+ PyObject *mod = PyImport_ImportModule(module);
+ #else
+ PyObject *mod = PyImport_ImportModule(const_cast<char *>(module));
+@@ -292,7 +292,7 @@
+ return 0;
+ }
+
+-#if PY_VERSION_HEX >= 0x020500
++#if PY_VERSION_HEX >= 0x02050000
+ PyObject *obj = PyObject_GetAttrString(mod, attr);
+ #else
+ PyObject *obj = PyObject_GetAttrString(mod, const_cast<char *>(attr));