summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2003-10-25 03:31:13 +0000
committerRob Cakebread <pythonhead@gentoo.org>2003-10-25 03:31:13 +0000
commit70864dc9e1f4902f01db334142d2f6eaab2b41fe (patch)
treedf90e88455b7c24eb29f9ea314b4931ea2807058 /dev-python
parentInitial commit (diff)
downloadgentoo-2-70864dc9e1f4902f01db334142d2f6eaab2b41fe.tar.gz
gentoo-2-70864dc9e1f4902f01db334142d2f6eaab2b41fe.tar.bz2
gentoo-2-70864dc9e1f4902f01db334142d2f6eaab2b41fe.zip
Initial commit
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/skunkweb/ChangeLog10
-rw-r--r--dev-python/skunkweb/Manifest4
-rw-r--r--dev-python/skunkweb/files/digest-skunkweb-3.4_beta51
-rw-r--r--dev-python/skunkweb/metadata.xml5
-rw-r--r--dev-python/skunkweb/skunkweb-3.4_beta5.ebuild98
5 files changed, 116 insertions, 2 deletions
diff --git a/dev-python/skunkweb/ChangeLog b/dev-python/skunkweb/ChangeLog
new file mode 100644
index 000000000000..4ee24084cad9
--- /dev/null
+++ b/dev-python/skunkweb/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/skunkweb
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/skunkweb/ChangeLog,v 1.1 2003/10/25 03:31:05 pythonhead Exp $
+
+*skunkweb-3.4_beta5 (24 Oct 2003)
+
+ 24 Oct 2003; Rob Cakebread <pythonhead@gentoo.org> metadata.xml,
+ skunkweb-3.4_beta5.ebuild:
+ Initial commit. Thank you Jacob Smullyan <smulloni@smullyan.org> (Bug #26450)
+
diff --git a/dev-python/skunkweb/Manifest b/dev-python/skunkweb/Manifest
index 09ed3b03da0d..2109bad05949 100644
--- a/dev-python/skunkweb/Manifest
+++ b/dev-python/skunkweb/Manifest
@@ -1,4 +1,4 @@
-MD5 0752e2284256277db0c99f62d3d95e82 skunkweb-3.4_beta5.ebuild 2627
+MD5 dded20c862e29f405969384b55932ed1 skunkweb-3.4_beta5.ebuild 2739
MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
-MD5 6e420e889f678e4a88785b97f8f98a00 ChangeLog 340
+MD5 23f299e4e59633d593650f92ab18e402 ChangeLog 436
MD5 33defac2f69099260dac7f1a043b2643 files/digest-skunkweb-3.4_beta5 67
diff --git a/dev-python/skunkweb/files/digest-skunkweb-3.4_beta5 b/dev-python/skunkweb/files/digest-skunkweb-3.4_beta5
new file mode 100644
index 000000000000..3a7dc4213de5
--- /dev/null
+++ b/dev-python/skunkweb/files/digest-skunkweb-3.4_beta5
@@ -0,0 +1 @@
+MD5 74fc5c98c036d0453ede0c9aaa51f4b0 skunkweb-3.4b5.tar.gz 1952771
diff --git a/dev-python/skunkweb/metadata.xml b/dev-python/skunkweb/metadata.xml
new file mode 100644
index 000000000000..de483c53568f
--- /dev/null
+++ b/dev-python/skunkweb/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/skunkweb/skunkweb-3.4_beta5.ebuild b/dev-python/skunkweb/skunkweb-3.4_beta5.ebuild
new file mode 100644
index 000000000000..900c035d3737
--- /dev/null
+++ b/dev-python/skunkweb/skunkweb-3.4_beta5.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/skunkweb/skunkweb-3.4_beta5.ebuild,v 1.1 2003/10/25 03:31:05 pythonhead Exp $
+
+
+DESCRIPTION="robust Python web application server"
+HOMEPAGE="http://skunkweb.sourceforge.net/"
+NEWP=`echo ${P} | sed -e 's|_beta|b|'`
+S=${WORKDIR}/${NEWP}
+SRC_URI="mirror://sourceforge/skunkweb/${NEWP}.tar.gz"
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="${IUSE} apache1 apache2"
+DEPEND=">=dev-lang/python-2.2
+ >=dev-python/egenix-mx-base-2.0.4
+ apache2? ( >=net-www/apache-2.0.47 ) : ( apache1? ( <=net-www/apache-2 ) )"
+
+
+pkg_setup() {
+ if ! groupmod skunkweb; then
+ groupadd skunkweb || die "problem adding group skunkweb"
+ fi
+ if ! id skunkweb; then
+ useradd -g skunkweb -s /bin/false -d /usr/share/skunkweb -c "SkunkWeb user" skunkweb \
+ || die "problem adding user skunkweb"
+ fi
+}
+
+pkg_postinst() {
+ if [ -z "${INSTALLING}" ]; then
+ einfo "NOTICE!"
+ einfo "User and group 'skunkweb' have been added."
+ fi
+}
+
+pkg_postrm() {
+ if [ -z "${INSTALLING}" ] ; then
+ einfo ">>> removing skunkweb user"
+ userdel skunkweb || die "error removing skunk user"
+ einfo ">>> removing skunkweb group"
+ groupdel skunkweb || die "error removing skunkweb group"
+ else
+ einfo ">>> skunkweb user and group preserved"
+ fi
+}
+
+src_compile() {
+ local myconf
+ if use apache2; then
+ myconf="${myconf} --with-apxs=/usr/sbin/apxs2"
+ else
+ if use apache1; then
+ myconf="${myconf} --with-apxs=/usr/sbin/apxs"
+ else
+ myconf="${myconf} --without-mod_skunkweb"
+ fi
+ fi
+ ./configure \
+ --with-user=skunkweb \
+ --with-group=skunkweb \
+ --localstatedir=/var/lib/skunkweb \
+ --bindir=/usr/bin \
+ --libdir=/usr/lib/skunkweb \
+ --sysconfdir=/etc/skunkweb \
+ --prefix=/usr/share/skunkweb \
+ --with-cache=/var/lib/skunkweb/cache \
+ --with-docdir=/usr/share/doc/${P} \
+ --with-logdir=/var/log/skunkweb \
+ --with-python=/usr/bin/python \
+ ${myconf} || die "configure failed"
+
+ emake || die
+}
+
+src_install() {
+ INSTALLING="yes"
+ make DESTDIR=${D} APXSFLAGS="-c" install || die
+ if use apache2; then
+ exeinto /usr/lib/apache2-extramodules
+ doexe SkunkWeb/mod_skunkweb/.libs/mod_skunkweb.so
+ insinto /etc/apache/conf/addon-modules
+ newins SkunkWeb/mod_skunkweb/http_conf.stub mod_skunkweb.conf
+ else
+ if use apache1; then
+ exeinto /usr/lib/apache-extramodules
+ doexe SkunkWeb/mod_skunkweb/mod_skunkweb.so
+ insinto /etc/apache/conf/addon-modules
+ newins SkunkWeb/mod_skunkweb/http_conf.stub mod_skunkweb.conf
+ fi
+ fi
+ dodoc README ChangeLog NEWS HACKING ACKS INSTALL
+ if use doc; then
+ cd ${S}/doc
+ dodir /usr/share/doc/${PF}
+ cp docs/paper-letter/*.pdf ${D}/usr/share/doc/${PF}
+ fi
+}