summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-10-13 12:09:49 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-10-13 12:09:49 +0000
commit71c96b71b16a9860b44790da1cd28b8601d32738 (patch)
tree4ebdc287bd428aa05547e48896f4a68a42135722 /dev-python
parentKeywording ~amd64 (diff)
downloadgentoo-2-71c96b71b16a9860b44790da1cd28b8601d32738.tar.gz
gentoo-2-71c96b71b16a9860b44790da1cd28b8601d32738.tar.bz2
gentoo-2-71c96b71b16a9860b44790da1cd28b8601d32738.zip
New ebuild for bug 195603.
(Portage version: 2.1.3.12)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyx/ChangeLog10
-rw-r--r--dev-python/pyx/files/digest-pyx-0.103
-rw-r--r--dev-python/pyx/files/pyx-0.10.patch138
-rw-r--r--dev-python/pyx/pyx-0.10.ebuild49
4 files changed, 198 insertions, 2 deletions
diff --git a/dev-python/pyx/ChangeLog b/dev-python/pyx/ChangeLog
index d9134cade260..3c58f21db7ab 100644
--- a/dev-python/pyx/ChangeLog
+++ b/dev-python/pyx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyx
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/ChangeLog,v 1.18 2006/09/24 02:03:36 dberkholz Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/ChangeLog,v 1.19 2007/10/13 12:09:49 genstef Exp $
+
+*pyx-0.10 (13 Oct 2007)
+
+ 12 Oct 2007; Dirkjan Ochtman (djc) <mail@manuzhai.nl> +files/pyx-0.10.patch,
+ +pyx-0.10.ebuild:
+ New ebuild for bug 195603.
*pyx-0.9 (24 Sep 2006)
diff --git a/dev-python/pyx/files/digest-pyx-0.10 b/dev-python/pyx/files/digest-pyx-0.10
new file mode 100644
index 000000000000..ea5e0ed2fa62
--- /dev/null
+++ b/dev-python/pyx/files/digest-pyx-0.10
@@ -0,0 +1,3 @@
+MD5 20a8697a4b37c3ead10348ad5a49ba1a PyX-0.10.tar.gz 373614
+RMD160 47b6bbd732b89ba5df281d0f760af34b6aa7e424 PyX-0.10.tar.gz 373614
+SHA256 dfaa4a7790661d67d95f80b22044fdd8a9922483631950296ff1d7a9f85c8bba PyX-0.10.tar.gz 373614
diff --git a/dev-python/pyx/files/pyx-0.10.patch b/dev-python/pyx/files/pyx-0.10.patch
new file mode 100644
index 000000000000..d7be7ec78b5b
--- /dev/null
+++ b/dev-python/pyx/files/pyx-0.10.patch
@@ -0,0 +1,138 @@
+diff -urN PyX-0.9.orig/pyx/siteconfig.py PyX-0.9/pyx/siteconfig.py
+--- PyX-0.9.orig/pyx/siteconfig.py 2006-09-23 18:35:45.000000000 -0700
++++ PyX-0.9/pyx/siteconfig.py 2006-09-23 18:36:28.000000000 -0700
+@@ -1,35 +1,3 @@
+-# -*- coding: ISO-8859-1 -*-
+-#
+-#
+-# Copyright (C) 2004-2005 André Wobst <wobsta@users.sourceforge.net>
+-#
+-# This file is part of PyX (http://pyx.sourceforge.net/).
+-#
+-# PyX is free software; you can redistribute it and/or modify
+-# it under the terms of the GNU General Public License as published by
+-# the Free Software Foundation; either version 2 of the License, or
+-# (at your option) any later version.
+-#
+-# PyX is distributed in the hope that it will be useful,
+-# but WITHOUT ANY WARRANTY; without even the implied warranty of
+-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-# GNU General Public License for more details.
+-#
+-# You should have received a copy of the GNU General Public License
+-# along with PyX; if not, write to the Free Software
+-# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA
+-
+-# !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
+-# This file configures PyX search paths relative to the current
+-# position, e.g. for local usage. When installing PyX via distutils
+-# the contents of this file is not copied to the PyX installation.
+-# Instead the correct information about the paths from the installation
+-# process are used.
+-# !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
+-
+-import os
+-
+-lfsdir = os.path.join(os.path.dirname(__file__), "lfs")
+-sharedir = os.path.join(os.path.dirname(__file__), "..", "contrib")
+-pyxrcdir = os.path.join(os.path.dirname(__file__), "..")
+-
++lfsdir = "/usr/share/pyx"
++sharedir = "/usr/share/pyx"
++pyxrcdir = "/etc/pyxrc"
+diff -urN PyX-0.9.orig/setup.py PyX-0.9/setup.py
+--- PyX-0.9.orig/setup.py 2006-09-23 18:35:45.000000000 -0700
++++ PyX-0.9/setup.py 2006-09-23 18:37:02.000000000 -0700
+@@ -77,84 +77,6 @@
+ # we put the global pyxrc into the share directory as well.
+ adddatafiles("pyxrcdir", os.name != "nt" and "/etc" or "share/pyx", ["pyxrc"])
+
+-################################################################################
+-# extend install commands to overwrite siteconfig.py during build and install
+-#
+-
+-
+-class pyx_build_py(build_py):
+-
+- def build_module(self, module, module_file, package):
+- if package == "pyx" and module == "siteconfig":
+- # generate path information as the original build_module does it
+- outfile = self.get_module_outfile(self.build_lib, [package], module)
+- outdir = os.path.dirname(outfile)
+- self.mkpath(outdir)
+-
+- if log:
+- log.info("creating proper %s" % outfile)
+-
+- # create the additional relative path parts to be inserted into the
+- # os.path.join methods in the original siteconfig.py
+- indir = os.path.dirname(module_file)
+- addjoinstring = ", ".join(["'..'" for d in outdir.split(os.path.sep)] +
+- ["'%s'" % d for d in indir.split(os.path.sep)])
+-
+- # write a modifed version of siteconfig.py
+- fin = open(module_file, "r")
+- fout = open(outfile, "w")
+- for line in fin.readlines():
+- fout.write(line.replace("os.path.join(os.path.dirname(__file__), ",
+- "os.path.join(os.path.dirname(__file__), %s, " % addjoinstring))
+- fin.close()
+- fout.close()
+- else:
+- return build_py.build_module(self, module, module_file, package)
+-
+-
+-class pyx_install_data(install_data):
+-
+- def run(self):
+- self.siteconfiglines = []
+- for dir, files in self.data_files:
+- # append siteconfiglines by "<siteconfigname> = <dir>"
+-
+- # get the install directory
+- # (the following four lines are copied from within the install_data.run loop)
+- dir = convert_path(dir)
+- if not os.path.isabs(dir):
+- dir = os.path.join(self.install_dir, dir)
+- elif self.root:
+- dir = change_root(self.root, dir)
+-
+- self.siteconfiglines.append("%s = '%s'\n" % (siteconfignames[files], dir))
+-
+- install_data.run(self)
+-
+-
+-class pyx_install_lib(install_lib):
+-
+- def run(self):
+- # siteconfig.py depends on install_data:
+- self.run_command('install_data')
+- install_lib.run(self)
+-
+- def install(self):
+- # first we perform the tree_copy
+- result = install_lib.install(self)
+-
+- # siteconfiglines have been created by install_data
+- siteconfiglines = self.distribution.command_obj["install_data"].siteconfiglines
+-
+- # such that we can easily overwrite siteconfig.py
+- outfile = os.path.join(self.install_dir, "pyx", "siteconfig.py")
+- if log:
+- log.info("creating proper %s" % outfile)
+- f = open(outfile, "w")
+- f.writelines(siteconfiglines)
+- f.close()
+-
+- return result
+
+ ################################################################################
+ # additional package metadata (only available in Python 2.3 and above)
+@@ -193,7 +115,4 @@
+ packages=["pyx", "pyx/graph", "pyx/graph/axis", "pyx/font", "pyx/pykpathsea"],
+ ext_modules=ext_modules,
+ data_files=data_files,
+- cmdclass = {"build_py": pyx_build_py,
+- "install_data": pyx_install_data,
+- "install_lib": pyx_install_lib},
+ **addargs)
diff --git a/dev-python/pyx/pyx-0.10.ebuild b/dev-python/pyx/pyx-0.10.ebuild
new file mode 100644
index 000000000000..80acde5aae99
--- /dev/null
+++ b/dev-python/pyx/pyx-0.10.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyx/pyx-0.10.ebuild,v 1.1 2007/10/13 12:09:49 genstef Exp $
+
+inherit distutils eutils
+
+MY_P=${P/pyx/PyX}
+DESCRIPTION="Python package for the generation of encapsulated PostScript figures"
+HOMEPAGE="http://pyx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pyx/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND="virtual/python
+ virtual/tetex"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS CHANGES INSTALL"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch ${FILESDIR}/${P}.patch
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ cd "${S}/faq"
+ make pdf
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ # The manual is not currently done because it needs mkhowto
+ # that's not currently available on our python ebuild
+ insinto /usr/share/doc/${P}/
+ doins faq/pyxfaq.pdf
+ fi
+}