summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2007-10-09 21:40:11 +0000
committerJim Ramsay <lack@gentoo.org>2007-10-09 21:40:11 +0000
commit76fc98424f61228b2bfbdeca22e011831f797d07 (patch)
tree679cf6254bd99356e2f8ca361115af3dc1551144 /dev-python
parentStable for SPARC (bug #195257). (diff)
downloadgentoo-2-76fc98424f61228b2bfbdeca22e011831f797d07.tar.gz
gentoo-2-76fc98424f61228b2bfbdeca22e011831f797d07.tar.bz2
gentoo-2-76fc98424f61228b2bfbdeca22e011831f797d07.zip
New version - 1.0.8
(Portage version: 2.1.3.9)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/gdata/ChangeLog7
-rw-r--r--dev-python/gdata/files/digest-gdata-1.0.83
-rw-r--r--dev-python/gdata/gdata-1.0.8.ebuild41
3 files changed, 50 insertions, 1 deletions
diff --git a/dev-python/gdata/ChangeLog b/dev-python/gdata/ChangeLog
index c89b15c12bed..093d96877af6 100644
--- a/dev-python/gdata/ChangeLog
+++ b/dev-python/gdata/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/gdata
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/ChangeLog,v 1.4 2007/10/08 17:14:34 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/ChangeLog,v 1.5 2007/10/09 21:40:11 lack Exp $
+
+*gdata-1.0.8 (09 Oct 2007)
+
+ 09 Oct 2007; Jim Ramsay <lack@gentoo.org> +gdata-1.0.8.ebuild:
+ New version - 1.0.8
08 Oct 2007; Donnie Berkholz <dberkholz@gentoo.org>; gdata-1.0.4.ebuild:
Keyword ~ppc.
diff --git a/dev-python/gdata/files/digest-gdata-1.0.8 b/dev-python/gdata/files/digest-gdata-1.0.8
new file mode 100644
index 000000000000..7c8dafd16138
--- /dev/null
+++ b/dev-python/gdata/files/digest-gdata-1.0.8
@@ -0,0 +1,3 @@
+MD5 b6f6aa192446047d8045d3c30345f1ef gdata.py-1.0.8.tar.gz 79022
+RMD160 0bb5e3b583bc74f0299fa3074f7ab2a81c8d1801 gdata.py-1.0.8.tar.gz 79022
+SHA256 18c789f7a792973fed2633981fa35711a3bbefc14d7703d97bb816e9ae5acf24 gdata.py-1.0.8.tar.gz 79022
diff --git a/dev-python/gdata/gdata-1.0.8.ebuild b/dev-python/gdata/gdata-1.0.8.ebuild
new file mode 100644
index 000000000000..0d733ec1fdb3
--- /dev/null
+++ b/dev-python/gdata/gdata-1.0.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/gdata-1.0.8.ebuild,v 1.1 2007/10/09 21:40:11 lack Exp $
+
+inherit distutils
+
+MY_P="gdata.py-${PV}"
+
+DESCRIPTION="Python client library for Google data APIs"
+HOMEPAGE="http://code.google.com/p/gdata-python-client/"
+SRC_URI="http://gdata-python-client.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="|| ( >=dev-lang/python-2.5 dev-python/elementtree )"
+
+PYTHON_MODNAME="atom gdata"
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r samples
+ fi
+}
+
+src_test() {
+ cd tests
+ export PYTHONPATH=../src
+ for x in $(find -name "*.py"); do
+ grep -q raw_input ${x} && continue
+ einfo "Running ${x}..."
+ "${python}" ${x} -v || die "${x} failed"
+ done
+}