summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-03 17:26:13 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-03 17:26:13 +0000
commit791cad7abea309f87a7fdddc22a8305288a82da2 (patch)
tree5967cce9c26f152f19b4cfa6bf528ef49276c092 /dev-python
parentStable on alpha, bug #285693 (diff)
downloadgentoo-2-791cad7abea309f87a7fdddc22a8305288a82da2.tar.gz
gentoo-2-791cad7abea309f87a7fdddc22a8305288a82da2.tar.bz2
gentoo-2-791cad7abea309f87a7fdddc22a8305288a82da2.zip
Add "doc" USE flag.
(Portage version: 14479-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/dbus-python/ChangeLog6
-rw-r--r--dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild33
2 files changed, 26 insertions, 13 deletions
diff --git a/dev-python/dbus-python/ChangeLog b/dev-python/dbus-python/ChangeLog
index 6fd4116a1092..113640248d6b 100644
--- a/dev-python/dbus-python/ChangeLog
+++ b/dev-python/dbus-python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/dbus-python
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.47 2009/08/02 00:45:44 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/ChangeLog,v 1.48 2009/10/03 17:26:13 arfrever Exp $
+
+ 03 Oct 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ dbus-python-0.83.0-r1.ebuild:
+ Add "doc" USE flag.
02 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
dbus-python-0.83.0-r1.ebuild:
diff --git a/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild b/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild
index 3fe201fb020b..be3310ed789f 100644
--- a/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild
+++ b/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild,v 1.5 2009/10/03 05:19:23 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.83.0-r1.ebuild,v 1.6 2009/10/03 17:26:13 arfrever Exp $
EAPI="2"
+PYTHON_DEFINE_DEFAULT_FUNCTIONS="1"
SUPPORT_PYTHON_ABIS="1"
inherit multilib python
@@ -15,42 +16,50 @@ SRC_URI="http://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="MIT"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="examples test"
+IUSE="doc examples test"
RDEPEND=">=dev-lang/python-2.4.4-r5
>=dev-python/pyrex-0.9.3-r2
>=dev-libs/dbus-glib-0.71
>=sys-apps/dbus-1.1.1"
-
DEPEND="${RDEPEND}
+ doc? ( =dev-python/epydoc-3* )
test? ( dev-python/pygobject )
dev-util/pkgconfig"
-
-RESTRICT_PYTHON_ABIS="3*"
+RESTRICT_PYTHON_ABIS="3.*"
src_prepare() {
# Disable compiling of .pyc files.
mv "${S}"/py-compile "${S}"/py-compile.orig
ln -s $(type -P true) "${S}"/py-compile
- python_copy_sources
+ python_src_prepare
}
src_configure() {
configuration() {
- econf --docdir=/usr/share/doc/dbus-python-${PV}
+ econf \
+ --docdir=/usr/share/doc/dbus-python-${PV} \
+ $(use_enable doc api-docs)
}
python_execute_function -s configuration
}
-src_compile() {
- python_execute_function -d -s
-}
-
src_install() {
python_need_rebuild
- python_execute_function -d -s
+ python_src_install
+
+ if use doc; then
+ # Install documentation only once.
+ documentation_installed="0"
+ install_documentation() {
+ [[ "${documentation_installed}" == "1" ]] && return
+ dohtml api/* || return 1
+ documentation_installed="1"
+ }
+ python_execute_function -q -s install_documentation
+ fi
if use examples; then
insinto /usr/share/doc/${PF}/