summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-20 06:30:26 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-20 06:30:26 +0000
commit7a7a75f155c049a51a5b1992e07af67df10faab2 (patch)
tree0b0a620610387f8e99b0ee6f566909001691e91e /dev-python
parentVersion bump. (diff)
downloadgentoo-2-7a7a75f155c049a51a5b1992e07af67df10faab2.tar.gz
gentoo-2-7a7a75f155c049a51a5b1992e07af67df10faab2.tar.bz2
gentoo-2-7a7a75f155c049a51a5b1992e07af67df10faab2.zip
rm old impls, fix doc build in -1.3.1, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/webob/ChangeLog8
-rw-r--r--dev-python/webob/webob-1.0.7.ebuild56
-rw-r--r--dev-python/webob/webob-1.0.8-r1.ebuild49
-rw-r--r--dev-python/webob/webob-1.0.8.ebuild51
-rw-r--r--dev-python/webob/webob-1.1.ebuild51
-rw-r--r--dev-python/webob/webob-1.2.2.ebuild46
-rw-r--r--dev-python/webob/webob-1.2.3-r1.ebuild4
-rw-r--r--dev-python/webob/webob-1.3.1.ebuild8
-rw-r--r--dev-python/webob/webob-1.4.ebuild4
9 files changed, 15 insertions, 262 deletions
diff --git a/dev-python/webob/ChangeLog b/dev-python/webob/ChangeLog
index 06b1817273c2..7ea7ceb1cfe0 100644
--- a/dev-python/webob/ChangeLog
+++ b/dev-python/webob/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/webob
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/ChangeLog,v 1.95 2014/12/08 11:02:53 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/ChangeLog,v 1.96 2014/12/20 06:30:26 idella4 Exp $
+
+ 20 Dec 2014; Ian Delaney <idella4@gentoo.org> -webob-1.0.7.ebuild,
+ -webob-1.0.8-r1.ebuild, -webob-1.0.8.ebuild, -webob-1.1.ebuild,
+ -webob-1.2.2.ebuild, webob-1.2.3-r1.ebuild, webob-1.3.1.ebuild,
+ webob-1.4.ebuild:
+ rm old impls, fix doc build in -1.3.1, rm old
08 Dec 2014; Agostino Sarubbo <ago@gentoo.org> webob-1.4.ebuild:
Stable for ppc64, wrt bug #530620
diff --git a/dev-python/webob/webob-1.0.7.ebuild b/dev-python/webob/webob-1.0.7.ebuild
deleted file mode 100644
index 2f1a8aa38be3..000000000000
--- a/dev-python/webob/webob-1.0.7.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/webob-1.0.7.ebuild,v 1.8 2012/10/13 18:52:07 armin76 Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils eutils
-
-MY_PN="WebOb"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="WSGI request and response object"
-HOMEPAGE="http://webob.org/ http://pypi.python.org/pypi/WebOb"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~ia64 ppc ppc64 ~s390 ~sh ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc test"
-
-DEPEND="app-arch/unzip
- dev-python/setuptools
- doc? ( dev-python/sphinx )
- test? ( dev-python/webtest )"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}/${P}-tests.patch"
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- "$(PYTHON -f)" setup.py build_sphinx || die "Generation of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- pushd build/sphinx/html > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _static || die "Installation of documentation failed"
- popd > /dev/null
- fi
-}
diff --git a/dev-python/webob/webob-1.0.8-r1.ebuild b/dev-python/webob/webob-1.0.8-r1.ebuild
deleted file mode 100644
index 8e46422492e0..000000000000
--- a/dev-python/webob/webob-1.0.8-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/webob-1.0.8-r1.ebuild,v 1.2 2013/03/28 10:51:19 mgorny Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit distutils-r1
-
-MY_PN=WebOb
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="WSGI request and response object"
-HOMEPAGE="http://webob.org/ http://pypi.python.org/pypi/WebOb"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc" # test"
-
-DEPEND="app-arch/unzip
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-# test? ( dev-python/nose[${PYTHON_USEDEP}]
-# dev-python/webtest[${PYTHON_USEDEP}] )"
-RDEPEND=""
-
-# Almost impossible to solve circ-dep with dev-python/webtest.
-# (due to different PYTHON_COMPAT)
-RESTRICT=test
-
-S=${WORKDIR}/${MY_P}
-
-python_compile_all() {
- if use doc; then
- "${PYTHON}" setup.py build_sphinx || die
- fi
-}
-
-python_test() {
- nosetests -w tests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( build/sphinx/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/webob/webob-1.0.8.ebuild b/dev-python/webob/webob-1.0.8.ebuild
deleted file mode 100644
index cb5bac430940..000000000000
--- a/dev-python/webob/webob-1.0.8.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/webob-1.0.8.ebuild,v 1.1 2013/01/26 08:57:27 prometheanfire Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils eutils
-
-MY_PN="WebOb"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="WSGI request and response object"
-HOMEPAGE="http://webob.org/ http://pypi.python.org/pypi/WebOb"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc test"
-
-DEPEND="app-arch/unzip
- dev-python/setuptools
- doc? ( dev-python/sphinx )
- test? ( dev-python/webtest )"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- "$(PYTHON -f)" setup.py build_sphinx || die "Generation of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- pushd build/sphinx/html > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _static || die "Installation of documentation failed"
- popd > /dev/null
- fi
-}
diff --git a/dev-python/webob/webob-1.1.ebuild b/dev-python/webob/webob-1.1.ebuild
deleted file mode 100644
index d2994b5cd180..000000000000
--- a/dev-python/webob/webob-1.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/webob-1.1.ebuild,v 1.10 2012/10/13 18:52:07 armin76 Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.*"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils eutils
-
-MY_PN="WebOb"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="WSGI request and response object"
-HOMEPAGE="http://webob.org/ http://pypi.python.org/pypi/WebOb"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc test"
-
-DEPEND="app-arch/unzip
- dev-python/setuptools
- doc? ( dev-python/sphinx )
- test? ( dev-python/webtest )"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- "$(PYTHON -f)" setup.py build_sphinx || die "Generation of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- pushd build/sphinx/html > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _static || die "Installation of documentation failed"
- popd > /dev/null
- fi
-}
diff --git a/dev-python/webob/webob-1.2.2.ebuild b/dev-python/webob/webob-1.2.2.ebuild
deleted file mode 100644
index ea2dc07a7185..000000000000
--- a/dev-python/webob/webob-1.2.2.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/webob-1.2.2.ebuild,v 1.4 2012/10/13 18:52:07 armin76 Exp $
-
-EAPI=4
-
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.5 3.1"
-DISTUTILS_SRC_TEST=nosetests
-
-inherit distutils
-
-MY_PN=WebOb
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="WSGI request and response object"
-HOMEPAGE="http://webob.org/ http://pypi.python.org/pypi/WebOb"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc"
-
-DEPEND="app-arch/unzip
- dev-python/setuptools
- doc? ( dev-python/sphinx )"
-RDEPEND=""
-
-S=${WORKDIR}/${MY_P}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- "$(PYTHON -f)" setup.py build_sphinx || die
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r build/sphinx/html/
- fi
-}
diff --git a/dev-python/webob/webob-1.2.3-r1.ebuild b/dev-python/webob/webob-1.2.3-r1.ebuild
index 62978d3424df..0365dee149e5 100644
--- a/dev-python/webob/webob-1.2.3-r1.ebuild
+++ b/dev-python/webob/webob-1.2.3-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/webob-1.2.3-r1.ebuild,v 1.14 2014/06/18 16:01:01 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/webob-1.2.3-r1.ebuild,v 1.15 2014/12/20 06:30:26 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
+PYTHON_COMPAT=( python{2_7,3_3} pypy )
inherit distutils-r1
diff --git a/dev-python/webob/webob-1.3.1.ebuild b/dev-python/webob/webob-1.3.1.ebuild
index d9775f22b18d..0fbc6e3584ca 100644
--- a/dev-python/webob/webob-1.3.1.ebuild
+++ b/dev-python/webob/webob-1.3.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/webob-1.3.1.ebuild,v 1.3 2014/04/02 21:14:58 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/webob-1.3.1.ebuild,v 1.4 2014/12/20 06:30:26 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} pypy pypy2_0 )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
inherit distutils-r1
@@ -29,7 +29,7 @@ S=${WORKDIR}/${MY_P}
python_compile_all() {
if use doc; then
- "${PYTHON}" setup.py build_sphinx || die
+ "${PYTHON}" setup.py build_sphinx || die "Doc build failed"
fi
}
@@ -38,6 +38,6 @@ python_test() {
}
python_install_all() {
- use doc && local HTML_DOCS=( build/sphinx/html/. )
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
distutils-r1_python_install_all
}
diff --git a/dev-python/webob/webob-1.4.ebuild b/dev-python/webob/webob-1.4.ebuild
index 3622a89220d0..b0262695359a 100644
--- a/dev-python/webob/webob-1.4.ebuild
+++ b/dev-python/webob/webob-1.4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/webob-1.4.ebuild,v 1.7 2014/12/08 11:02:53 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/webob-1.4.ebuild,v 1.8 2014/12/20 06:30:26 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
inherit distutils-r1