summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2004-03-02 18:09:42 +0000
committerBryan Østergaard <kloeri@gentoo.org>2004-03-02 18:09:42 +0000
commit904fdec661cada9b30bf98161edca0f95a5b8a7e (patch)
treeec9da2b6527fd3fea6327545cdb14b6dd2257416 /dev-python
parentAdded amd64 to KEYWORDS. (Manifest recommit) (diff)
downloadgentoo-2-904fdec661cada9b30bf98161edca0f95a5b8a7e.tar.gz
gentoo-2-904fdec661cada9b30bf98161edca0f95a5b8a7e.tar.bz2
gentoo-2-904fdec661cada9b30bf98161edca0f95a5b8a7e.zip
Fix qt-3.3 compile problem. Close bug #43475.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyQt/ChangeLog6
-rw-r--r--dev-python/PyQt/PyQt-3.8.1.ebuild16
-rw-r--r--dev-python/PyQt/files/PyQt-3.8.1-qt-3.3.patch14
3 files changed, 30 insertions, 6 deletions
diff --git a/dev-python/PyQt/ChangeLog b/dev-python/PyQt/ChangeLog
index 15d6dd598a4b..47ac03590f3f 100644
--- a/dev-python/PyQt/ChangeLog
+++ b/dev-python/PyQt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/PyQt
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.28 2004/02/26 19:01:28 bazik Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.29 2004/03/02 18:09:42 kloeri Exp $
+
+ 02 Mar 2004; <kloeri@gentoo.org> PyQt-3.8.1.ebuild,
+ files/PyQt-3.8.1-qt-3.3.patch:
+ Fix qt-3.3 compile problem. Close bug #43475.
26 Feb 2004; Sven Blumenstein <bazik@gentoo.org> PyQt-3.8.1.ebuild:
Stable on sparc.
diff --git a/dev-python/PyQt/PyQt-3.8.1.ebuild b/dev-python/PyQt/PyQt-3.8.1.ebuild
index f5661634200a..8e22f368bfe0 100644
--- a/dev-python/PyQt/PyQt-3.8.1.ebuild
+++ b/dev-python/PyQt/PyQt-3.8.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.8.1.ebuild,v 1.4 2004/02/26 19:01:28 bazik Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.8.1.ebuild,v 1.5 2004/03/02 18:09:42 kloeri Exp $
-inherit eutils distutils
+inherit distutils
IUSE=""
@@ -34,8 +34,13 @@ src_unpack() {
}
src_compile() {
-
distutils_python_version
+
+ # fix qt-3.3 compile problem
+ if has_version '=x11-libs/qt-3.3*' ; then
+ epatch "${FILESDIR}/${P}-qt-3.3.patch"
+ fi
+
# standard qt sandbox problem workaround
[ -d "$QTDIR/etc/settings" ] && addwrite "$QTDIR/etc/settings"
dodir /usr/lib/python${PYVER}/site-packages
@@ -49,10 +54,11 @@ src_compile() {
}
src_install() {
+ distutils_python_version
+ dodir /usr/lib/python${PYVER}/site-packages
make DESTDIR=${D} install || die
dodoc README.Linux NEWS LICENSE README ChangeLog THANKS
dodir /usr/share/doc/${P}/
- mv ${D}/usr/share/doc/* ${D}/usr/share/doc/${P}/
# I found out this location from the redhat rpm
insinto /usr/share/sip/qt
doins ${S}/sip/*
diff --git a/dev-python/PyQt/files/PyQt-3.8.1-qt-3.3.patch b/dev-python/PyQt/files/PyQt-3.8.1-qt-3.3.patch
new file mode 100644
index 000000000000..5baec9bd6bf4
--- /dev/null
+++ b/dev-python/PyQt/files/PyQt-3.8.1-qt-3.3.patch
@@ -0,0 +1,14 @@
+--- PyQt-x11-gpl-3.8.1/sip/qtable.sip~ 2004-02-25 23:51:33.880257192 +0100
++++ PyQt-x11-gpl-3.8.1/sip/qtable.sip 2004-02-25 23:51:42.716913816 +0100
+@@ -149,11 +149,6 @@
+
+ virtual int rtti() const;
+ %End
+-
+-protected:
+-%If (Qt_3_2_0 -)
+- QString content() const;
+-%End
+ };
+
+