summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-03-27 10:19:26 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-03-27 10:19:26 +0000
commit9078c259a0c33f70ed969e808251cb8d8cf8fb36 (patch)
tree3f6b494e729d2e4638dfdfc7bc9824399e3b63d5 /dev-python
parentRedudant doman command.. (diff)
downloadgentoo-2-9078c259a0c33f70ed969e808251cb8d8cf8fb36.tar.gz
gentoo-2-9078c259a0c33f70ed969e808251cb8d8cf8fb36.tar.bz2
gentoo-2-9078c259a0c33f70ed969e808251cb8d8cf8fb36.zip
New version for GNOME 2.22. Bug fixes and new evolution/eds component.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/gnome-python-desktop/ChangeLog5
-rw-r--r--dev-python/gnome-python-desktop/gnome-python-desktop-2.22.0.ebuild (renamed from dev-python/gnome-python-desktop/gnome-python-desktop-2.18.0.ebuild)43
2 files changed, 35 insertions, 13 deletions
diff --git a/dev-python/gnome-python-desktop/ChangeLog b/dev-python/gnome-python-desktop/ChangeLog
index 6152385f510a..b90f3395056f 100644
--- a/dev-python/gnome-python-desktop/ChangeLog
+++ b/dev-python/gnome-python-desktop/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/gnome-python-desktop
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-desktop/ChangeLog,v 1.48 2008/02/10 22:04:04 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-desktop/ChangeLog,v 1.49 2008/03/27 10:19:26 eva Exp $
+
+ 27 Mar 2008; Gilles Dartiguelongue <eva@gentoo.org> ChangeLog:
+ New version for GNOME 2.22. Bug fixes and new evolution/eds component.
10 Feb 2008; Gilles Dartiguelongue <eva@gentoo.org>
gnome-python-desktop-2.20.0.ebuild:
diff --git a/dev-python/gnome-python-desktop/gnome-python-desktop-2.18.0.ebuild b/dev-python/gnome-python-desktop/gnome-python-desktop-2.22.0.ebuild
index 146e26c13b02..aa24f3bab764 100644
--- a/dev-python/gnome-python-desktop/gnome-python-desktop-2.18.0.ebuild
+++ b/dev-python/gnome-python-desktop/gnome-python-desktop-2.22.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-desktop/gnome-python-desktop-2.18.0.ebuild,v 1.13 2007/10/10 21:43:31 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-desktop/gnome-python-desktop-2.22.0.ebuild,v 1.1 2008/03/27 10:19:26 eva Exp $
+
+EAPI="1"
inherit gnome2 python virtualx
@@ -9,8 +11,10 @@ HOMEPAGE="http://pygtk.org/"
LICENSE="LGPL-2.1 GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~x86-fbsd"
-IUSE="doc"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc eds"
+
+# FIXME: upstream is intending to move to WAF build system
RDEPEND="virtual/python
>=dev-python/pygtk-2.10.3
@@ -20,26 +24,41 @@ RDEPEND="virtual/python
>=gnome-base/gnome-panel-2.13.4
>=gnome-base/libgnomeprint-2.2.0
>=gnome-base/libgnomeprintui-2.2.0
- =x11-libs/gtksourceview-1*
- >=x11-libs/libwnck-2.15.5
+ x11-libs/gtksourceview:1.0
+ >=x11-libs/libwnck-2.19.3
>=gnome-base/libgtop-2.13.0
>=gnome-extra/nautilus-cd-burner-2.15.3
>=gnome-extra/gnome-media-2.10.0
>=gnome-base/gconf-2.10.0
- >=x11-wm/metacity-2.17.8
+ >=x11-wm/metacity-2.21.5
dev-python/pycairo
>=gnome-base/librsvg-2.13.93
- >=gnome-base/gnome-keyring-0.5.0
+ >=gnome-base/gnome-keyring-2.20.1
>=gnome-base/gnome-desktop-2.10.0
- media-video/totem
+ eds? ( >=gnome-extra/evolution-data-server-1.8 )
+ >=media-video/totem-1.4.0
!<dev-python/gnome-python-extras-2.13"
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.7"
-DOCS="AUTHORS ChangeLog INSTALL MAINTAINERS NEWS README"
+DOCS="AUTHORS ChangeLog INSTALL* MAINTAINERS NEWS README"
+
+pkg_config() {
+ G2CONF="${G2CONF}
+ $(use_enable eds evolution)
+ $(use_enable eds evolution-ecal)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
src_test() {
- Xmake check || die "tests failed"
+ Xemake check || die "tests failed"
}
src_install() {
@@ -58,5 +77,5 @@ pkg_postinst() {
pkg_postrm() {
python_version
- python_mod_cleanup
+ python_mod_cleanup /usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
}