summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-11-21 09:40:51 +0000
committerJustin Lecher <jlec@gentoo.org>2013-11-21 09:40:51 +0000
commit94830905c84866a942277f92e3b5e05bdadeb039 (patch)
treeb1c6b97af84d8a31bd5a322cc128a3d21d057016 /dev-python
parentdev-python/mpi4py: Backport test fix for py3.3, #487836 (diff)
downloadgentoo-2-94830905c84866a942277f92e3b5e05bdadeb039.tar.gz
gentoo-2-94830905c84866a942277f92e3b5e05bdadeb039.tar.bz2
gentoo-2-94830905c84866a942277f92e3b5e05bdadeb039.zip
dev-python/mpi4py: Drop old
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/mpi4py/ChangeLog6
-rw-r--r--dev-python/mpi4py/mpi4py-1.3-r1.ebuild48
-rw-r--r--dev-python/mpi4py/mpi4py-1.3.ebuild50
3 files changed, 5 insertions, 99 deletions
diff --git a/dev-python/mpi4py/ChangeLog b/dev-python/mpi4py/ChangeLog
index 10385715d574..f0a630fa2d82 100644
--- a/dev-python/mpi4py/ChangeLog
+++ b/dev-python/mpi4py/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/mpi4py
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mpi4py/ChangeLog,v 1.14 2013/11/21 09:38:32 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpi4py/ChangeLog,v 1.15 2013/11/21 09:40:51 jlec Exp $
+
+ 21 Nov 2013; Justin Lecher <jlec@gentoo.org> -mpi4py-1.3.ebuild,
+ -mpi4py-1.3-r1.ebuild:
+ Drop old
21 Nov 2013; Justin Lecher <jlec@gentoo.org> mpi4py-1.3.1.ebuild,
+files/mpi4py-1.3.1-py3-test-backport-1.patch:
diff --git a/dev-python/mpi4py/mpi4py-1.3-r1.ebuild b/dev-python/mpi4py/mpi4py-1.3-r1.ebuild
deleted file mode 100644
index f1e84bda69ba..000000000000
--- a/dev-python/mpi4py/mpi4py-1.3-r1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mpi4py/mpi4py-1.3-r1.ebuild,v 1.2 2013/09/05 18:47:18 mgorny Exp $
-
-EAPI=5
-# README.txt excludes 3.3, absent tox.ini includes 3.3, tests fail py3.3
-PYTHON_COMPAT=( python{2_6,2_7,3_2} )
-
-inherit distutils-r1
-
-DESCRIPTION="Message Passing Interface for Python"
-HOMEPAGE="http://code.google.com/p/mpi4py/ http://pypi.python.org/pypi/mpi4py"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-RDEPEND="virtual/mpi"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- virtual/mpi[romio] )"
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
- # not needed on install
- rm -r docs/source || die
- distutils-r1_python_prepare_all
-}
-
-src_compile() {
- export FAKEROOTKEY=1
- distutils-r1_src_compile
-}
-
-python_test() {
- echo "Beginning test phase"
- pushd "${BUILD_DIR}"/../ &> /dev/null
- mpiexec -n 2 "${PYTHON}" ./test/runtests.py || die "Testsuite failed under ${EPYTHON}"
- popd &> /dev/null
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/. )
- use examples && local EXAMPLES=( demo/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/mpi4py/mpi4py-1.3.ebuild b/dev-python/mpi4py/mpi4py-1.3.ebuild
deleted file mode 100644
index ba9d25faeb19..000000000000
--- a/dev-python/mpi4py/mpi4py-1.3.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mpi4py/mpi4py-1.3.ebuild,v 1.5 2013/07/01 23:09:47 hasufell Exp $
-
-EAPI="4"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.7-pypy-* *-jython"
-
-inherit distutils eutils
-
-DESCRIPTION="Message Passing Interface for Python"
-HOMEPAGE="http://code.google.com/p/mpi4py/ http://pypi.python.org/pypi/mpi4py"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples"
-
-DEPEND="virtual/mpi"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- # not needed on install
- rm -r docs/source || die
-}
-
-src_compile() {
- export FAKEROOTKEY=1
- distutils_src_compile
-}
-
-src_test() {
- local exclude
- has_version virtual/mpi[romio] || exclude="--exclude=file --exclude=class"
- testing() {
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" \
- mpiexec -n 2 "$(PYTHON)" test/runtests.py ${exclude}
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- use doc && dohtml -r docs/*
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r demo/*
- fi
-}