summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-03-21 06:40:24 +0000
committerAli Polatel <hawking@gentoo.org>2008-03-21 06:40:24 +0000
commit99eba8e9be383516b1fa2ef22b180a137e7b1cc0 (patch)
tree26d9c4bc341bf3510519d55af237bdb8f6144635 /dev-python
parentVersion bump (diff)
downloadgentoo-2-99eba8e9be383516b1fa2ef22b180a137e7b1cc0.tar.gz
gentoo-2-99eba8e9be383516b1fa2ef22b180a137e7b1cc0.tar.bz2
gentoo-2-99eba8e9be383516b1fa2ef22b180a137e7b1cc0.zip
Version bump. Added longdescription. Added myself as maintainer.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pylint/ChangeLog12
-rw-r--r--dev-python/pylint/files/pylint-0.14.0-tests-reset_cache.patch25
-rw-r--r--dev-python/pylint/files/pylint-0.14.0-tests-typo.patch5
-rw-r--r--dev-python/pylint/metadata.xml19
-rw-r--r--dev-python/pylint/pylint-0.14.0.ebuild79
5 files changed, 137 insertions, 3 deletions
diff --git a/dev-python/pylint/ChangeLog b/dev-python/pylint/ChangeLog
index 62f72b4d8860..959c00d29058 100644
--- a/dev-python/pylint/ChangeLog
+++ b/dev-python/pylint/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/pylint
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.42 2007/07/11 14:58:46 pythonhead Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.43 2008/03/21 06:40:23 hawking Exp $
+
+*pylint-0.14.0 (21 Mar 2008)
+
+ 21 Mar 2008; Ali Polatel <hawking@gentoo.org>
+ +files/pylint-0.14.0-tests-reset_cache.patch,
+ +files/pylint-0.14.0-tests-typo.patch, metadata.xml,
+ +pylint-0.14.0.ebuild:
+ Version bump. Added longdescription. Added myself as maintainer.
11 Jul 2007; Rob Cakebread <pythonhead@gentoo.org> pylint-0.13.1.ebuild:
Removed test dep for egenix as its only needed for logilab-common
diff --git a/dev-python/pylint/files/pylint-0.14.0-tests-reset_cache.patch b/dev-python/pylint/files/pylint-0.14.0-tests-reset_cache.patch
new file mode 100644
index 000000000000..521cb49348e0
--- /dev/null
+++ b/dev-python/pylint/files/pylint-0.14.0-tests-reset_cache.patch
@@ -0,0 +1,25 @@
+--- test/func_test.py 2007-03-09 10:51:45.000000000 +0200
++++ test/func_test.py 2008-03-21 08:09:44.043941833 +0200
+@@ -1,4 +1,4 @@
+-# Copyright (c) 2003-2007 LOGILAB S.A. (Paris, FRANCE).
++# Copyright (c) 2003-2008 LOGILAB S.A. (Paris, FRANCE).
+ # http://www.logilab.fr/ -- mailto:contact@logilab.fr
+ #
+ # This program is free software; you can redistribute it and/or modify it under
+@@ -26,6 +26,7 @@
+
+ from utils import get_tests_info, fix_path, TestReporter
+
++from logilab.astng import MANAGER
+ from pylint.lint import PyLinter
+ from pylint import checkers
+
+@@ -59,6 +60,8 @@
+ class LintTestUsingModule(testlib.TestCase):
+ package = 'input'
+ linter = linter
++ def setUp(self):
++ MANAGER.set_cache_size(200) # reset cache
+ def test_functionality(self):
+ tocheck = [self.package+'.'+self.module]
+ if self.depends:
diff --git a/dev-python/pylint/files/pylint-0.14.0-tests-typo.patch b/dev-python/pylint/files/pylint-0.14.0-tests-typo.patch
new file mode 100644
index 000000000000..3a7f4836c8b9
--- /dev/null
+++ b/dev-python/pylint/files/pylint-0.14.0-tests-typo.patch
@@ -0,0 +1,5 @@
+--- test/messages/func_w0702.txt 2006-05-07 00:31:55.000000000 +0300
++++ test/messages/func_w0702.txt 2008-03-21 08:09:44.138931778 +0200
+@@ -1 +1 @@
+-W: 10: No exception's type specified
++W: 10: No exception type(s) specified
diff --git a/dev-python/pylint/metadata.xml b/dev-python/pylint/metadata.xml
index de483c53568f..af19cd652e54 100644
--- a/dev-python/pylint/metadata.xml
+++ b/dev-python/pylint/metadata.xml
@@ -1,5 +1,22 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>python</herd>
+ <herd>python</herd>
+ <maintainer>
+ <email>hawking@gentoo.org</email>
+ <name>Ali Polatel</name>
+ </maintainer>
+ <longdescription lang="en">
+ Pylint is a Python source code analyzer which looks for programming
+ errors, helps enforcing a coding standard and sniffs for some code
+ smells (as defined in Martin Fowler's Refactoring book).
+
+ Pylint can be seen as another PyChecker since nearly all tests you can
+ do with PyChecker can also be done with Pylint. However, Pylint offers
+ some more features, like checking length of lines of code, checking if
+ variable names are well-formed according to your coding standard, or
+ checking if declared interfaces are truly implemented, and much more.
+
+ Additionally, it is possible to write plugins to add your own checks.
+ </longdescription>
</pkgmetadata>
diff --git a/dev-python/pylint/pylint-0.14.0.ebuild b/dev-python/pylint/pylint-0.14.0.ebuild
new file mode 100644
index 000000000000..01911ee97a3b
--- /dev/null
+++ b/dev-python/pylint/pylint-0.14.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.14.0.ebuild,v 1.1 2008/03/21 06:40:23 hawking Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="PyLint is a tool to check if a Python module satisfies a coding standard"
+SRC_URI="ftp://ftp.logilab.org/pub/pylint/${P}.tar.gz"
+HOMEPAGE="http://www.logilab.org/projects/pylint/"
+
+IUSE="tk"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+DEPEND="|| ( >=dev-python/optik-1.4 >=dev-lang/python-2.3 )
+ >=dev-python/logilab-common-0.21.0
+ >=dev-python/astng-0.17.0
+ tk? ( >=dev-lang/tk-8.4.9 )"
+
+DOCS="doc/*.txt"
+
+pkg_setup() {
+ if use tk && ! built_with_use dev-lang/python tk; then
+ eerror "You have USE='tk' enabled."
+ eerror "Python has not been compiled with tkinter support."
+ eerror "Please re-emerge python with the 'tk' USE-flag set."
+ die "Missing USE-flag for dev-lang/python"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Make the test that tries to import gtk a bit less strict
+ epatch "${FILESDIR}/${PN}-0.10.0-extra-gtk-disable.patch"
+
+ # Make pylint-gui print a gentoo-specific message if Tkinter is missing
+ epatch "${FILESDIR}/${PN}-0.11.0-gui-no-tkinter.patch"
+
+ # Upstream fixes for tests
+ epatch "${FILESDIR}/${P}-tests-typo.patch"
+ epatch "${FILESDIR}/${P}-tests-reset_cache.patch"
+}
+
+src_install() {
+ distutils_src_install
+ # do not install the test suite (we ran it from src_test already
+ # and it makes .py[co] generation very noisy because there are
+ # files with SyntaxErrors in there)
+ python_version
+ rm -rf "${D}"/usr/lib*/python${PYVER}/site-packages/pylint/test
+
+ doman man/pylint.1
+ dohtml doc/*.html
+}
+
+src_test() {
+ # The tests will not work properly from the source dir, so do a
+ # temporary install:
+ "${python}" setup.py install --home="${T}/test" || die "test copy failed"
+ # dir needs to be this or the tests fail
+ cd "${T}/test/lib/python/pylint/test"
+
+ # These fail, have not been able to track down why.
+ rm rpythoninput/func_unsupported_protocol.py || die "rm failed"
+ rm func_test_rpython.py || die "rm failed"
+ PYTHONPATH="${T}/test/lib/python" "${python}" runtests.py || \
+ die "tests failed"
+ cd "${S}"
+ rm -rf "${T}/test"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ elog 'A couple of important configuration settings (like "disable-msg")'
+ elog 'moved from the "MASTER" to "MESSAGES CONTROL" section.'
+ elog 'See "pylint --help".'
+}