summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2007-02-15 20:00:30 +0000
committerTiziano Müller <dev-zero@gentoo.org>2007-02-15 20:00:30 +0000
commit9ec0b243505969072984b1c55ec81d63eaa65b5e (patch)
tree9a8ee63df2279b697af636685b337e7b39f1f3cf /dev-python
parentAdding ~amd64. (diff)
downloadgentoo-2-9ec0b243505969072984b1c55ec81d63eaa65b5e.tar.gz
gentoo-2-9ec0b243505969072984b1c55ec81d63eaa65b5e.tar.bz2
gentoo-2-9ec0b243505969072984b1c55ec81d63eaa65b5e.zip
Version bump.
(Portage version: 2.1.2-r7)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/gnome-python-extras/ChangeLog8
-rw-r--r--dev-python/gnome-python-extras/files/digest-gnome-python-extras-2.14.23
-rw-r--r--dev-python/gnome-python-extras/gnome-python-extras-2.14.2.ebuild78
3 files changed, 88 insertions, 1 deletions
diff --git a/dev-python/gnome-python-extras/ChangeLog b/dev-python/gnome-python-extras/ChangeLog
index cfe9d94c0496..a8e382c4fc87 100644
--- a/dev-python/gnome-python-extras/ChangeLog
+++ b/dev-python/gnome-python-extras/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/gnome-python-extras
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras/ChangeLog,v 1.44 2007/01/08 04:47:38 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras/ChangeLog,v 1.45 2007/02/15 20:00:29 dev-zero Exp $
+
+*gnome-python-extras-2.14.2 (15 Feb 2007)
+
+ 15 Feb 2007; Tiziano Müller <dev-zero@gentoo.org>
+ +gnome-python-extras-2.14.2.ebuild:
+ Version bump.
08 Jan 2007; Mart Raudsepp <leio@gentoo.org>
gnome-python-extras-2.14.0-r1.ebuild:
diff --git a/dev-python/gnome-python-extras/files/digest-gnome-python-extras-2.14.2 b/dev-python/gnome-python-extras/files/digest-gnome-python-extras-2.14.2
new file mode 100644
index 000000000000..f756dc74dabf
--- /dev/null
+++ b/dev-python/gnome-python-extras/files/digest-gnome-python-extras-2.14.2
@@ -0,0 +1,3 @@
+MD5 039e1300368df17de9867685e9705091 gnome-python-extras-2.14.2.tar.bz2 351780
+RMD160 d2707eee20a103f070455fef3bd9cddc1060ce93 gnome-python-extras-2.14.2.tar.bz2 351780
+SHA256 fcecd0098431c0baca72cc762560b15f330275727df4fd4157606a90252bae29 gnome-python-extras-2.14.2.tar.bz2 351780
diff --git a/dev-python/gnome-python-extras/gnome-python-extras-2.14.2.ebuild b/dev-python/gnome-python-extras/gnome-python-extras-2.14.2.ebuild
new file mode 100644
index 000000000000..ff7b6f2389a4
--- /dev/null
+++ b/dev-python/gnome-python-extras/gnome-python-extras-2.14.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras/gnome-python-extras-2.14.2.ebuild,v 1.1 2007/02/15 20:00:29 dev-zero Exp $
+
+NEED_PYTHON=2.4
+WANT_AUTOCONF=latest
+WANT_AUTOMAKE=1.9
+
+inherit eutils gnome2 python virtualx autotools
+
+DESCRIPTION="GNOME 2 Bindings for Python"
+HOMEPAGE="http://www.pygtk.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc firefox seamonkey"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ >=dev-libs/glib-2.6
+ >=dev-python/gnome-python-2.10
+ >=dev-python/pygtk-2.4
+ =gnome-extra/gtkhtml-2.6*
+ firefox? ( >=www-client/mozilla-firefox-1.0 )
+ !firefox? ( seamonkey? ( >=www-client/seamonkey-1.0 ) )
+ >=gnome-extra/libgda-1.2.0
+ >=app-text/gtkspell-2"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS NEWS"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # change mozilla to seamonkey
+ sed -i -e 's:1.2b):1.0.0):;s:mozilla):seamonkey):' configure.ac
+
+ eautoreconf
+}
+
+src_compile() {
+
+ # only controls linking, can't disable w/o a patch :)
+ if use firefox; then
+ G2CONF="${G2CONF} --with-gtkmozembed=firefox"
+ else
+ use seamonkey && G2CONF="${G2CONF} --with-gtkmozembed=seamonkey"
+ fi
+
+ gnome2_src_configure ${G2CONF}
+
+ emake || die "make failed!"
+}
+
+src_test() {
+ Xmake check || die "tests failed"
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize "${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0"
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup "${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0"
+}