summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn N. Laliberte <allanonjl@gentoo.org>2006-07-02 16:52:39 +0000
committerJohn N. Laliberte <allanonjl@gentoo.org>2006-07-02 16:52:39 +0000
commita22418cade99cc734c9893c99c66e62f7b65cd9c (patch)
tree5f3b7818f3d6674fb27fd5283d6a7ab9b5872ebe /dev-python
parentadd 'seamonkey' to use.mask on ppc64 (diff)
downloadgentoo-2-a22418cade99cc734c9893c99c66e62f7b65cd9c.tar.gz
gentoo-2-a22418cade99cc734c9893c99c66e62f7b65cd9c.tar.bz2
gentoo-2-a22418cade99cc734c9893c99c66e62f7b65cd9c.zip
clean up logic since seamonkey flag is masked on ia64, sparc, and ppc64. add stable revision for 2.12.1 to remove mozilla support and add seamonkey support. remove old revision.
(Portage version: 2.1.1_pre1-r5)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/gnome-python-extras/ChangeLog11
-rw-r--r--dev-python/gnome-python-extras/files/digest-gnome-python-extras-2.12.1-r13
-rw-r--r--dev-python/gnome-python-extras/gnome-python-extras-2.12.1-r1.ebuild85
-rw-r--r--dev-python/gnome-python-extras/gnome-python-extras-2.14.0-r1.ebuild19
4 files changed, 102 insertions, 16 deletions
diff --git a/dev-python/gnome-python-extras/ChangeLog b/dev-python/gnome-python-extras/ChangeLog
index d077951b3cc9..ec5bfc2aff07 100644
--- a/dev-python/gnome-python-extras/ChangeLog
+++ b/dev-python/gnome-python-extras/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-python/gnome-python-extras
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras/ChangeLog,v 1.31 2006/07/02 00:14:36 allanonjl Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras/ChangeLog,v 1.32 2006/07/02 16:52:39 allanonjl Exp $
+
+*gnome-python-extras-2.12.1-r1 (02 Jul 2006)
+
+ 02 Jul 2006; John N. Laliberte <allanonjl@gentoo.org>
+ -gnome-python-extras-2.10.2.ebuild, +gnome-python-extras-2.12.1-r1.ebuild,
+ gnome-python-extras-2.14.0-r1.ebuild:
+ clean up logic since seamonkey flag is masked on ia64, sparc, and ppc64. add
+ stable revision for 2.12.1 to remove mozilla support and add seamonkey
+ support. remove old revision.
*gnome-python-extras-2.14.0-r1 (02 Jul 2006)
diff --git a/dev-python/gnome-python-extras/files/digest-gnome-python-extras-2.12.1-r1 b/dev-python/gnome-python-extras/files/digest-gnome-python-extras-2.12.1-r1
new file mode 100644
index 000000000000..fb6d2d00c022
--- /dev/null
+++ b/dev-python/gnome-python-extras/files/digest-gnome-python-extras-2.12.1-r1
@@ -0,0 +1,3 @@
+MD5 62a3d8bb5bd5c1696c7200c001ea34f2 gnome-python-extras-2.12.1.tar.bz2 476483
+RMD160 278bf74c35644ea27689dddbd89d6c0cd8ca7706 gnome-python-extras-2.12.1.tar.bz2 476483
+SHA256 d1f93adf096bd739cba988d9cdea8978faa97ac928bad26352e62830e8806ab5 gnome-python-extras-2.12.1.tar.bz2 476483
diff --git a/dev-python/gnome-python-extras/gnome-python-extras-2.12.1-r1.ebuild b/dev-python/gnome-python-extras/gnome-python-extras-2.12.1-r1.ebuild
new file mode 100644
index 000000000000..f8b695d98e4e
--- /dev/null
+++ b/dev-python/gnome-python-extras/gnome-python-extras-2.12.1-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras/gnome-python-extras-2.12.1-r1.ebuild,v 1.1 2006/07/02 16:52:39 allanonjl Exp $
+
+NEED_PYTHON=2.4
+
+inherit eutils gnome2 python autotools
+
+DESCRIPTION="GNOME 2 Bindings for Python"
+HOMEPAGE="http://www.pygtk.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE="doc firefox seamonkey"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ >=dev-libs/glib-2.6
+ >=dev-python/gnome-python-2.10
+ >=dev-python/pygtk-2.4
+ =gnome-extra/gtkhtml-2.6*
+ >=gnome-base/libgnomeprint-2.2
+ >=gnome-base/libgnomeprintui-2.2
+ >=x11-libs/gtksourceview-1.1.90
+ >=gnome-base/gnome-panel-2.10
+ >=x11-libs/libwnck-2.9.92
+ firefox? ( >=www-client/mozilla-firefox-1.0 )
+ !firefox? ( seamonkey? ( >=www-client/seamonkey-1.0 ) )
+ >=gnome-base/libgtop-2.9.5
+ >=gnome-extra/nautilus-cd-burner-2.11.1
+ >=gnome-extra/libgda-1.2.0
+ >=app-text/gtkspell-2
+ >=gnome-base/gconf-2.10
+ media-video/totem
+ "
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ app-text/scrollkeeper
+ "
+
+G2CONF=""
+DOCS="AUTHORS COPYING* ChangeLog INSTALL NEWS README"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # change mozilla to seamonkey
+ sed -i -e 's:1.2b):1.0.0):;s:mozilla):seamonkey):' configure.ac
+
+ eautoreconf
+}
+
+src_compile() {
+
+ # only controls linking, can't disable w/o a patch :)
+ if use firefox; then
+ G2CONF="${G2CONF} --with-gtkmozembed=firefox"
+ else
+ use seamonkey && G2CONF="${G2CONF} --with-gtkmozembed=seamonkey"
+ fi
+
+ gnome2_src_configure ${G2CONF}
+
+ emake || die "make failed!"
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize ${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}
diff --git a/dev-python/gnome-python-extras/gnome-python-extras-2.14.0-r1.ebuild b/dev-python/gnome-python-extras/gnome-python-extras-2.14.0-r1.ebuild
index c18c21bd0ac5..ff1a73d24057 100644
--- a/dev-python/gnome-python-extras/gnome-python-extras-2.14.0-r1.ebuild
+++ b/dev-python/gnome-python-extras/gnome-python-extras-2.14.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras/gnome-python-extras-2.14.0-r1.ebuild,v 1.1 2006/07/02 00:14:36 allanonjl Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras/gnome-python-extras-2.14.0-r1.ebuild,v 1.2 2006/07/02 16:52:39 allanonjl Exp $
NEED_PYTHON=2.4
@@ -14,21 +14,13 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="doc firefox seamonkey"
-# seamonkey is not keyworded on sparc/ia64, so only give them the
-# firefox option.
-# logic:
-# if they aren't sparc or ia64, they can choose seamonkey
-# everyone can choose whether or not to choose firefox
RDEPEND=">=x11-libs/gtk+-2.4
>=dev-libs/glib-2.6
>=dev-python/gnome-python-2.10
>=dev-python/pygtk-2.4
=gnome-extra/gtkhtml-2.6*
firefox? ( >=www-client/mozilla-firefox-1.0 )
- !sparc? ( !ia64? (
- !firefox? ( seamonkey? ( >=www-client/seamonkey-1.0 ) )
- )
- )
+ !firefox? ( seamonkey? ( >=www-client/seamonkey-1.0 ) )
>=gnome-extra/libgda-1.2.0
>=app-text/gtkspell-2"
@@ -41,8 +33,7 @@ src_unpack() {
gnome2_src_unpack
# change mozilla to seamonkey
- sed -i -e 's:1.2b):1.0.0):' configure.ac
- sed -i -e 's:mozilla):seamonkey):' configure.ac
+ sed -i -e 's:1.2b):1.0.0):;s:mozilla):seamonkey):' configure.ac
eautoreconf
}
@@ -52,9 +43,7 @@ src_compile() {
# only controls linking, can't disable w/o a patch :)
if use firefox; then
G2CONF="${G2CONF} --with-gtkmozembed=firefox"
- fi
-
- if ! use firefox && ! use sparc && ! use ia64; then
+ else
use seamonkey && G2CONF="${G2CONF} --with-gtkmozembed=seamonkey"
fi