summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Lauwers <blauwers@gentoo.org>2002-12-17 20:10:56 +0000
committerBart Lauwers <blauwers@gentoo.org>2002-12-17 20:10:56 +0000
commitab04a6f124c1297e00592a52f652849371a15ab5 (patch)
treefdb7784a16726f9fcefbb5c09117535ef6224ba7 /dev-python
parentadded header (diff)
downloadgentoo-2-ab04a6f124c1297e00592a52f652849371a15ab5.tar.gz
gentoo-2-ab04a6f124c1297e00592a52f652849371a15ab5.tar.bz2
gentoo-2-ab04a6f124c1297e00592a52f652849371a15ab5.zip
Version bump per Bug#9990
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Numeric/ChangeLog7
-rw-r--r--dev-python/Numeric/Numeric-22.0.ebuild45
-rw-r--r--dev-python/Numeric/files/digest-Numeric-22.01
3 files changed, 52 insertions, 1 deletions
diff --git a/dev-python/Numeric/ChangeLog b/dev-python/Numeric/ChangeLog
index 68f27ed7ac3b..1ea26433d133 100644
--- a/dev-python/Numeric/ChangeLog
+++ b/dev-python/Numeric/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/Numeric
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-python/Numeric/ChangeLog,v 1.6 2002/12/13 10:56:44 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/Numeric/ChangeLog,v 1.7 2002/12/17 20:10:56 blauwers Exp $
+
+*Numeric-22.0 (17 Dec 20020
+
+ 17 Dec 2002; B.Lauwers <blauwers@gentoo.org> :
+ Version bump.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/dev-python/Numeric/Numeric-22.0.ebuild b/dev-python/Numeric/Numeric-22.0.ebuild
new file mode 100644
index 000000000000..f5b4413d4f2c
--- /dev/null
+++ b/dev-python/Numeric/Numeric-22.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-20022 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/Numeric/Numeric-22.0.ebuild,v 1.1 2002/12/17 20:10:56 blauwers Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="numerical python module"
+SRC_URI="mirror://sourceforge/numpy/${P}.tar.gz"
+HOMEPAGE="http://www.pfdubois.com/numpy/"
+
+# 2.1 gave sandbox violations see #21
+DEPEND=">=dev-lang/python-2.2"
+
+SLOT="0"
+KEYWORDS="x86 ppc sparc alpha"
+LICENSE="as-is"
+
+src_compile() {
+
+#The ebuild as is uses a small local version of BLAS and LAPACK provided
+#by the Numeric package. If I ever get ATLAS and LAPACK ebuilds finished,
+#we'll need to edit (sed) setup.py to use the real libraries.
+
+ python setup.py build || die
+
+}
+
+src_install() {
+
+ python setup.py install --prefix=${D}/usr || die
+
+ dodoc MANIFEST PKG-INFO README
+
+#grab python verision so ebuild doesn't depend on it
+ local pv
+ pv=$(python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:')
+
+#Numerical Tutorial is nice for testing and learning
+ insinto /usr/lib/python${pv}/site-packages/NumTut
+ doins Demo/NumTut/*
+
+}
+
+
+
+
diff --git a/dev-python/Numeric/files/digest-Numeric-22.0 b/dev-python/Numeric/files/digest-Numeric-22.0
new file mode 100644
index 000000000000..12e3cad6bd11
--- /dev/null
+++ b/dev-python/Numeric/files/digest-Numeric-22.0
@@ -0,0 +1 @@
+MD5 222b71d150efa9be52622a288547d9d7 Numeric-22.0.tar.gz 722237