summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-04-27 02:21:28 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-04-27 02:21:28 +0000
commitb1947e5ecfb1d8f4132c78cc9aa65d67840c01db (patch)
tree329262667ca1a352a533cb2f4c3f733a3302f348 /dev-python
parentRemove old. (diff)
downloadgentoo-2-b1947e5ecfb1d8f4132c78cc9aa65d67840c01db.tar.gz
gentoo-2-b1947e5ecfb1d8f4132c78cc9aa65d67840c01db.tar.bz2
gentoo-2-b1947e5ecfb1d8f4132c78cc9aa65d67840c01db.zip
Remove old
(Portage version: 2.2.18/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pylint/ChangeLog6
-rw-r--r--dev-python/pylint/pylint-0.25.2.ebuild55
-rw-r--r--dev-python/pylint/pylint-1.3.0.ebuild58
-rw-r--r--dev-python/pylint/pylint-1.3.1.ebuild56
4 files changed, 5 insertions, 170 deletions
diff --git a/dev-python/pylint/ChangeLog b/dev-python/pylint/ChangeLog
index b3511abb3950..eaea3d0bb3b1 100644
--- a/dev-python/pylint/ChangeLog
+++ b/dev-python/pylint/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pylint
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.127 2015/04/26 16:51:55 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.128 2015/04/27 02:21:28 patrick Exp $
+
+ 27 Apr 2015; Patrick Lauer <patrick@gentoo.org> -pylint-0.25.2.ebuild,
+ -pylint-1.3.0.ebuild, -pylint-1.3.1.ebuild:
+ Remove old
26 Apr 2015; Pacho Ramos <pacho@gentoo.org> pylint-1.3.1.ebuild:
ppc stable wrt bug #530562
diff --git a/dev-python/pylint/pylint-0.25.2.ebuild b/dev-python/pylint/pylint-0.25.2.ebuild
deleted file mode 100644
index 2b8605b25ee1..000000000000
--- a/dev-python/pylint/pylint-0.25.2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.25.2.ebuild,v 1.6 2015/03/23 05:28:21 patrick Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python code static checker"
-HOMEPAGE="http://www.logilab.org/project/pylint http://pypi.python.org/pypi/pylint"
-SRC_URI="ftp://ftp.logilab.org/pub/${PN}/${P}.tar.gz mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="examples"
-
-# Versions specified in __pkginfo__.py.
-RDEPEND=">=dev-python/logilab-common-0.53.0[${PYTHON_USEDEP}]
- >=dev-python/astng-0.24.3[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-PATCHES=( "${FILESDIR}"/${PN}-0.26.0-gtktest.patch )
-
-python_test() {
- # Test suite broken with Python 3
- local msg="Test suite broken with ${EPYTHON}"
- if [[ "${EPYTHON}" == python3* ]]; then
- einfo "${msg}"
- else
- # https://bitbucket.org/logilab/pylint/issue/11/apparent-regression-in-testsuite-pylint
- # This 'issue' became' declared fixed by accident for version 0.27.0 despite being made citing 0.28.0
- pytest || die "Tests failed under ${EPYTHON}"
- fi
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- doman man/{pylint,pyreverse}.1
-
- if use examples; then
- docinto examples
- dodoc examples/*
- fi
-}
-
-pkg_postinst() {
- # Optional dependency on "tk" USE flag would break support for Jython.
- elog "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled."
-}
diff --git a/dev-python/pylint/pylint-1.3.0.ebuild b/dev-python/pylint/pylint-1.3.0.ebuild
deleted file mode 100644
index 9ec8f8068e58..000000000000
--- a/dev-python/pylint/pylint-1.3.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-1.3.0.ebuild,v 1.3 2014/09/10 13:23:50 idella4 Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Python code static checker"
-HOMEPAGE="http://www.logilab.org/project/pylint http://pypi.python.org/pypi/pylint"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="doc examples test"
-
-RDEPEND=">=dev-python/logilab-common-0.53.0[${PYTHON_USEDEP}]
- ~dev-python/astroid-1.2.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( "${RDEPEND}" )"
-
-PATCHES=( "${FILESDIR}"/${PN}-0.26.0-gtktest.patch )
-
-# Usual. Requ'd for impl specific failures in test phase
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
- # selection of straight html triggers a trivial annoying bug, we skirt it
- use doc && emake -C doc singlehtml
-}
-
-python_test() {
- # Test suite appears not to work under Python 3.
- # https://bitbucket.org/logilab/pylint/issue/240/
- local msg="Test suite broken with ${EPYTHON}"
- if [[ "${EPYTHON}" == python3* ]]; then
- einfo "${msg}"
- return 0
- fi
-
- pytest || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- doman man/{pylint,pyreverse}.1
- use examples && local EXAMPLES=( examples/. )
- use doc && local HTML_DOCS=( doc/_build/singlehtml/. )
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- # Optional dependency on "tk" USE flag would break support for Jython.
- elog "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled."
-}
diff --git a/dev-python/pylint/pylint-1.3.1.ebuild b/dev-python/pylint/pylint-1.3.1.ebuild
deleted file mode 100644
index 2ad212faa483..000000000000
--- a/dev-python/pylint/pylint-1.3.1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-1.3.1.ebuild,v 1.3 2015/04/26 16:51:55 pacho Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Python code static checker"
-HOMEPAGE="http://www.logilab.org/project/pylint http://pypi.python.org/pypi/pylint"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="doc examples test"
-
-RDEPEND=">=dev-python/logilab-common-0.53.0[${PYTHON_USEDEP}]
- ~dev-python/astroid-1.2.1[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( "${RDEPEND}" )"
-
-# Usual. Requ'd for impl specific failures in test phase
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
- # selection of straight html triggers a trivial annoying bug, we skirt it
- use doc && emake -C doc singlehtml
-}
-
-python_test() {
- # Test suite appears not to work under Python 3.
- # https://bitbucket.org/logilab/pylint/issue/240/
- local msg="Test suite broken with ${EPYTHON}"
- if python_is_python3; then
- einfo "${msg}"
- return 0
- fi
-
- pytest || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- doman man/{pylint,pyreverse}.1
- use examples && local EXAMPLES=( examples/. )
- use doc && local HTML_DOCS=( doc/_build/singlehtml/. )
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- # Optional dependency on "tk" USE flag would break support for Jython.
- elog "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled."
-}