summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2008-09-04 01:59:13 +0000
committerRob Cakebread <pythonhead@gentoo.org>2008-09-04 01:59:13 +0000
commitb277476378e25025926a9a29543a69a7455596cd (patch)
tree1e33d13a2d8f239c8691486086dfd54395796038 /dev-python
parentVersion bump (diff)
downloadgentoo-2-b277476378e25025926a9a29543a69a7455596cd.tar.gz
gentoo-2-b277476378e25025926a9a29543a69a7455596cd.tar.bz2
gentoo-2-b277476378e25025926a9a29543a69a7455596cd.zip
Remove test if not using Python 2.5+ bug# 234370
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/twisted/ChangeLog5
-rw-r--r--dev-python/twisted/twisted-8.1.0.ebuild9
2 files changed, 12 insertions, 2 deletions
diff --git a/dev-python/twisted/ChangeLog b/dev-python/twisted/ChangeLog
index a282ad476e8e..0cb6563d2200 100644
--- a/dev-python/twisted/ChangeLog
+++ b/dev-python/twisted/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/twisted
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.97 2008/08/13 08:43:53 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.98 2008/09/04 01:59:13 pythonhead Exp $
+
+ 04 Sep 2008; Rob Cakebread <pythonhead@gentoo.org> twisted-8.1.0.ebuild:
+ Remove test if not using Python 2.5+ bug# 234370
13 Aug 2008; Santiago M. Mola <coldwind@gentoo.org> twisted-8.1.0.ebuild:
amd64 stable wrt bug #231675
diff --git a/dev-python/twisted/twisted-8.1.0.ebuild b/dev-python/twisted/twisted-8.1.0.ebuild
index 425128895911..a3121495c101 100644
--- a/dev-python/twisted/twisted-8.1.0.ebuild
+++ b/dev-python/twisted/twisted-8.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-8.1.0.ebuild,v 1.6 2008/08/13 08:43:53 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-8.1.0.ebuild,v 1.7 2008/09/04 01:59:13 pythonhead Exp $
inherit eutils distutils versionator
@@ -27,6 +27,7 @@ S=${WORKDIR}/${MY_P}
DOCS="CREDITS NEWS README"
src_unpack() {
+ python_version
unpack ${A}
cd "${S}"
@@ -35,6 +36,12 @@ src_unpack() {
# Pass valid arguments to "head" in the zsh completion function.
epatch "${FILESDIR}/${PN}-2.1.0-zsh-head.patch"
+
+ # Skip test that only works with Python >=2.5 (won't byte-compile)
+ if [ "${PYVER_MINOR}" -lt 5 ]; then
+ echo "'''skip'''" > "${S}"/twisted/test/generator_failure_tests.py || die
+ fi
+
}
src_install() {