summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-11-10 06:49:00 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-11-10 06:49:00 +0000
commitc5e890444b4d8b5282d44aaef9b461aaa618536f (patch)
tree49e13c0a4c5b7469187ec7e923bb114825cc9786 /dev-python
parentadding for openstack (diff)
downloadgentoo-2-c5e890444b4d8b5282d44aaef9b461aaa618536f.tar.gz
gentoo-2-c5e890444b4d8b5282d44aaef9b461aaa618536f.tar.bz2
gentoo-2-c5e890444b4d8b5282d44aaef9b461aaa618536f.zip
bup
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pycadf/ChangeLog7
-rw-r--r--dev-python/pycadf/pycadf-0.6.0.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/dev-python/pycadf/ChangeLog b/dev-python/pycadf/ChangeLog
index 19c43374cac7..1c70a40d4e9a 100644
--- a/dev-python/pycadf/ChangeLog
+++ b/dev-python/pycadf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pycadf
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycadf/ChangeLog,v 1.3 2014/07/06 12:45:32 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycadf/ChangeLog,v 1.4 2014/11/10 06:49:00 prometheanfire Exp $
+
+*pycadf-0.6.0 (10 Nov 2014)
+
+ 10 Nov 2014; Matthew Thode <prometheanfire@gentoo.org> +pycadf-0.6.0.ebuild:
+ bup
06 Jul 2014; Michał Górny <mgorny@gentoo.org> pycadf-0.5-r1.ebuild:
Clean up obsolete dependencies on virtual/python-argparse and virtual/python-
diff --git a/dev-python/pycadf/pycadf-0.6.0.ebuild b/dev-python/pycadf/pycadf-0.6.0.ebuild
new file mode 100644
index 000000000000..94aac36c3119
--- /dev/null
+++ b/dev-python/pycadf/pycadf-0.6.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycadf/pycadf-0.6.0.ebuild,v 1.1 2014/11/10 06:49:00 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="python implementation of DMTF Cloud Audit (CADF) data model"
+HOMEPAGE="https://pypi.python.org/pypi/pycadf"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.8[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+ test? ( >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.2[${PYTHON_USEDEP}]
+ dev-python/oslo-sphinx[${PYTHON_USEDEP}]
+ ~dev-python/docutils-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/hacking-0.9.2[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.10[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/mox-0.5.3[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}] )
+ doc? (
+ dev-python/oslo-sphinx[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND=">=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.9[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.6[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-messaging-1.4.0[${PYTHON_USEDEP}]
+ dev-python/posix_ipc[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2010h[${PYTHON_USEDEP}]
+ >=dev-python/six-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.2.3[${PYTHON_USEDEP}]"
+
+PATCHES=()
+
+python_prepare_all() {
+ # ? typo error in conf.py
+ sed -e s':oslosphinx:oslo.sphinx:' -i doc/source/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ nosetests ${PN}/tests || die "test failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}