summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2007-10-12 12:46:24 +0000
committerRémi Cardona <remi@gentoo.org>2007-10-12 12:46:24 +0000
commitc9885f9a592db643f39000242436b881814be8be (patch)
treee72bb0dcc852bc08d2b969c9e1497580ee411063 /dev-python
parent-m Bump to tikiwiki-1.9.8.1. See sec issue #195503 (diff)
downloadgentoo-2-c9885f9a592db643f39000242436b881814be8be.tar.gz
gentoo-2-c9885f9a592db643f39000242436b881814be8be.tar.bz2
gentoo-2-c9885f9a592db643f39000242436b881814be8be.zip
dev-python/gnome-python: new version for Gnome 2.20
(Portage version: 2.1.3.12)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/gnome-python/ChangeLog7
-rw-r--r--dev-python/gnome-python/files/digest-gnome-python-2.20.03
-rw-r--r--dev-python/gnome-python/gnome-python-2.20.0.ebuild59
3 files changed, 68 insertions, 1 deletions
diff --git a/dev-python/gnome-python/ChangeLog b/dev-python/gnome-python/ChangeLog
index 592ddf46d8c2..1425832dae23 100644
--- a/dev-python/gnome-python/ChangeLog
+++ b/dev-python/gnome-python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/gnome-python
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python/ChangeLog,v 1.100 2007/09/22 09:28:01 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python/ChangeLog,v 1.101 2007/10/12 12:46:24 remi Exp $
+
+*gnome-python-2.20.0 (12 Oct 2007)
+
+ 12 Oct 2007; Rémi Cardona <remi@gentoo.org> +gnome-python-2.20.0.ebuild:
+ new version for Gnome 2.20
22 Sep 2007; Tom Gall <tgall@gentoo.org> gnome-python-2.18.2.ebuild:
stable on ppc64
diff --git a/dev-python/gnome-python/files/digest-gnome-python-2.20.0 b/dev-python/gnome-python/files/digest-gnome-python-2.20.0
new file mode 100644
index 000000000000..07d05039a28d
--- /dev/null
+++ b/dev-python/gnome-python/files/digest-gnome-python-2.20.0
@@ -0,0 +1,3 @@
+MD5 b5f17b65333f1cf6a8c0de914eb06191 gnome-python-2.20.0.tar.bz2 417469
+RMD160 2483ab3d9154b70c2b9684cc41101f837c813bbb gnome-python-2.20.0.tar.bz2 417469
+SHA256 45bf3132203f724f0ba4a4597b50c43a361d57e48dfc236c78882654204b4d06 gnome-python-2.20.0.tar.bz2 417469
diff --git a/dev-python/gnome-python/gnome-python-2.20.0.ebuild b/dev-python/gnome-python/gnome-python-2.20.0.ebuild
new file mode 100644
index 000000000000..5fb29606ba08
--- /dev/null
+++ b/dev-python/gnome-python/gnome-python-2.20.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python/gnome-python-2.20.0.ebuild,v 1.1 2007/10/12 12:46:24 remi Exp $
+
+inherit gnome2 python eutils
+
+DESCRIPTION="GNOME 2 bindings for Python"
+HOMEPAGE="http://www.pygtk.org/"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+RDEPEND=">=dev-lang/python-2.2
+ >=dev-python/pygtk-2.10.3
+ >=dev-python/pyorbit-2.0.1
+ >=dev-libs/glib-2.6
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/libgnome-2.8
+ >=gnome-base/libgnomeui-2.8
+ >=gnome-base/libgnomecanvas-2.8
+ >=gnome-base/gnome-vfs-2.14.0
+ >=gnome-base/gconf-2.11.1
+ >=gnome-base/libbonobo-2.8
+ >=gnome-base/libbonoboui-2.8"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+
+# Skip test, to avoid gnome-python-2.0 block (fixes bug 72594)
+RESTRICT="test"
+DOCS="AUTHORS ChangeLog NEWS"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/gtk-2.0
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}