summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-11-15 14:26:03 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-11-15 14:26:03 +0000
commitcc71db7a6366e6d8555bd5e720b48a043d57e5b3 (patch)
treec85c9703a82144ad6598f648147dd9b0e447bb74 /dev-python
parentVersion bump. (diff)
downloadgentoo-2-cc71db7a6366e6d8555bd5e720b48a043d57e5b3.tar.gz
gentoo-2-cc71db7a6366e6d8555bd5e720b48a043d57e5b3.tar.bz2
gentoo-2-cc71db7a6366e6d8555bd5e720b48a043d57e5b3.zip
Delete older ebuilds.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinx/sphinx-0.6.5.ebuild70
-rw-r--r--dev-python/sphinx/sphinx-0.6.6.ebuild70
-rw-r--r--dev-python/sphinx/sphinx-1.0.1.ebuild84
-rw-r--r--dev-python/sphinx/sphinx-1.0.3.ebuild84
-rw-r--r--dev-python/sphinx/sphinx-1.0.ebuild71
5 files changed, 0 insertions, 379 deletions
diff --git a/dev-python/sphinx/sphinx-0.6.5.ebuild b/dev-python/sphinx/sphinx-0.6.5.ebuild
deleted file mode 100644
index c0e0253752db..000000000000
--- a/dev-python/sphinx/sphinx-0.6.5.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-0.6.5.ebuild,v 1.10 2010/05/26 18:24:41 arfrever Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils
-
-MY_PN="Sphinx"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Tool to create documentation for Python projects"
-HOMEPAGE="http://sphinx.pocoo.org/ http://pypi.python.org/pypi/Sphinx"
-SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test latex"
-
-RDEPEND=">=dev-python/pygments-0.8
- >=dev-python/jinja-2.1
- >=dev-python/docutils-0.4
- latex? ( dev-texlive/texlive-latexextra )"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- test? ( dev-python/nose )"
-RESTRICT_PYTHON_ABIS="3.*"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="CHANGES"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- cd doc
- einfo "Generation of documentation"
- PYTHONPATH="../" emake SPHINXBUILD="$(PYTHON -f) ../sphinx-build.py" html || die "Generation of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -A txt -r doc/_build/html/* || die "dohtml failed"
- fi
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
-
- # Generating the Grammar pickle to avoid on the fly generation causing sandbox violations (bug #266015)
- generation_of_grammar_pickle() {
- "$(PYTHON)" -c "from sphinx.pycode.pgen2.driver import load_grammar; load_grammar('${ROOT%/}${EPREFIX}$(python_get_sitedir)/sphinx/pycode/Grammar.txt')" || die "Generation of grammar pickle failed"
- }
- python_execute_function --action-message 'Generation of Grammar pickle with Python ${PYTHON_ABI}...' generation_of_grammar_pickle
-}
-
-pkg_postrm() {
- distutils_pkg_postrm
-
- deletion_of_grammar_pickle() {
- rm "${ROOT%/}${EPREFIX}$(python_get_sitedir)/sphinx/pycode"/Grammar*.pickle
- }
- python_execute_function --action-message 'Deletion of Grammar pickle with Python ${PYTHON_ABI}...' deletion_of_grammar_pickle
-}
diff --git a/dev-python/sphinx/sphinx-0.6.6.ebuild b/dev-python/sphinx/sphinx-0.6.6.ebuild
deleted file mode 100644
index e85ac26fa099..000000000000
--- a/dev-python/sphinx/sphinx-0.6.6.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-0.6.6.ebuild,v 1.2 2010/05/26 18:24:41 arfrever Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils
-
-MY_PN="Sphinx"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Tool to create documentation for Python projects"
-HOMEPAGE="http://sphinx.pocoo.org/ http://pypi.python.org/pypi/Sphinx"
-SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test latex"
-
-RDEPEND=">=dev-python/pygments-0.8
- >=dev-python/jinja-2.1
- >=dev-python/docutils-0.4
- latex? ( dev-texlive/texlive-latexextra )"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- test? ( dev-python/nose )"
-RESTRICT_PYTHON_ABIS="3.*"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="CHANGES"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- cd doc
- einfo "Generation of documentation"
- PYTHONPATH="../" emake SPHINXBUILD="$(PYTHON -f) ../sphinx-build.py" html || die "Generation of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -A txt -r doc/_build/html/* || die "dohtml failed"
- fi
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
-
- # Generating the Grammar pickle to avoid on the fly generation causing sandbox violations (bug #266015)
- generation_of_grammar_pickle() {
- "$(PYTHON)" -c "from sphinx.pycode.pgen2.driver import load_grammar; load_grammar('${ROOT%/}${EPREFIX}$(python_get_sitedir)/sphinx/pycode/Grammar.txt')" || die "Generation of grammar pickle failed"
- }
- python_execute_function --action-message 'Generation of Grammar pickle with Python ${PYTHON_ABI}...' generation_of_grammar_pickle
-}
-
-pkg_postrm() {
- distutils_pkg_postrm
-
- deletion_of_grammar_pickle() {
- rm "${ROOT%/}${EPREFIX}$(python_get_sitedir)/sphinx/pycode"/Grammar*.pickle
- }
- python_execute_function --action-message 'Deletion of Grammar pickle with Python ${PYTHON_ABI}...' deletion_of_grammar_pickle
-}
diff --git a/dev-python/sphinx/sphinx-1.0.1.ebuild b/dev-python/sphinx/sphinx-1.0.1.ebuild
deleted file mode 100644
index 91c3d4ef147f..000000000000
--- a/dev-python/sphinx/sphinx-1.0.1.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-1.0.1.ebuild,v 1.1 2010/07/27 18:15:56 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils
-
-MY_PN="Sphinx"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Tool to create documentation for Python projects"
-HOMEPAGE="http://sphinx.pocoo.org/ http://pypi.python.org/pypi/Sphinx"
-SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc latex"
-
-RDEPEND=">=dev-python/pygments-0.8
- >=dev-python/jinja-2.2
- >=dev-python/docutils-0.5
- latex? ( dev-texlive/texlive-latexextra )"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="CHANGES"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- cd doc
- einfo "Generation of documentation"
- PYTHONPATH="../" emake SPHINXBUILD="$(PYTHON -f) ../sphinx-build.py" html || die "Generation of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -A txt -r doc/_build/html/* || die "Installation of documentation failed"
- fi
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
-
- # Generate the Grammar pickle to avoid sandbox violations.
- generation_of_grammar_pickle() {
- "$(PYTHON)" -c "import sys; sys.path.insert(0, '${EROOT}$(python_get_sitedir -b)'); from sphinx.pycode.pgen2.driver import load_grammar; load_grammar('${EROOT}$(python_get_sitedir -b)/sphinx/pycode/Grammar.txt')"
- }
- python_execute_function \
- --action-message 'Generation of Grammar pickle with $(python_get_implementation) $(python_get_version)...' \
- --failure-message 'Generation of Grammar pickle with $(python_get_implementation) $(python_get_version) failed' \
- generation_of_grammar_pickle
-}
-
-pkg_postrm() {
- distutils_pkg_postrm
-
- deletion_of_grammar_pickle() {
- rm -f "${EROOT}$(python_get_sitedir -b)/sphinx/pycode"/Grammar*.pickle || return 1
-
- # Delete empty parent directories.
- local dir="${EROOT}$(python_get_sitedir -b)/sphinx/pycode"
- while [[ "${dir}" != "${EROOT%/}" ]]; do
- rmdir "${dir}" 2> /dev/null || break
- dir="${dir%/*}"
- done
- }
- python_execute_function \
- --action-message 'Deletion of Grammar pickle with $(python_get_implementation) $(python_get_version)...' \
- --failure-message 'Deletion of Grammar pickle with $(python_get_implementation) $(python_get_version) failed' \
- deletion_of_grammar_pickle
-}
diff --git a/dev-python/sphinx/sphinx-1.0.3.ebuild b/dev-python/sphinx/sphinx-1.0.3.ebuild
deleted file mode 100644
index 6e02cd369ade..000000000000
--- a/dev-python/sphinx/sphinx-1.0.3.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-1.0.3.ebuild,v 1.5 2010/10/09 16:44:59 armin76 Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils
-
-MY_PN="Sphinx"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Tool to create documentation for Python projects"
-HOMEPAGE="http://sphinx.pocoo.org/ http://pypi.python.org/pypi/Sphinx"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~hppa ia64 ppc ~ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc latex"
-
-RDEPEND=">=dev-python/pygments-0.8
- >=dev-python/jinja-2.2
- >=dev-python/docutils-0.5
- latex? ( dev-texlive/texlive-latexextra )"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="CHANGES"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- cd doc
- einfo "Generation of documentation"
- PYTHONPATH="../" emake SPHINXBUILD="$(PYTHON -f) ../sphinx-build.py" html || die "Generation of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -A txt -r doc/_build/html/* || die "Installation of documentation failed"
- fi
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
-
- # Generate the Grammar pickle to avoid sandbox violations.
- generation_of_grammar_pickle() {
- "$(PYTHON)" -c "import sys; sys.path.insert(0, '${EROOT}$(python_get_sitedir -b)'); from sphinx.pycode.pgen2.driver import load_grammar; load_grammar('${EROOT}$(python_get_sitedir -b)/sphinx/pycode/Grammar.txt')"
- }
- python_execute_function \
- --action-message 'Generation of Grammar pickle with $(python_get_implementation) $(python_get_version)...' \
- --failure-message 'Generation of Grammar pickle with $(python_get_implementation) $(python_get_version) failed' \
- generation_of_grammar_pickle
-}
-
-pkg_postrm() {
- distutils_pkg_postrm
-
- deletion_of_grammar_pickle() {
- rm -f "${EROOT}$(python_get_sitedir -b)/sphinx/pycode"/Grammar*.pickle || return 1
-
- # Delete empty parent directories.
- local dir="${EROOT}$(python_get_sitedir -b)/sphinx/pycode"
- while [[ "${dir}" != "${EROOT%/}" ]]; do
- rmdir "${dir}" 2> /dev/null || break
- dir="${dir%/*}"
- done
- }
- python_execute_function \
- --action-message 'Deletion of Grammar pickle with $(python_get_implementation) $(python_get_version)...' \
- --failure-message 'Deletion of Grammar pickle with $(python_get_implementation) $(python_get_version) failed' \
- deletion_of_grammar_pickle
-}
diff --git a/dev-python/sphinx/sphinx-1.0.ebuild b/dev-python/sphinx/sphinx-1.0.ebuild
deleted file mode 100644
index 52a8ec9e3935..000000000000
--- a/dev-python/sphinx/sphinx-1.0.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-1.0.ebuild,v 1.1 2010/07/23 11:30:45 djc Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils
-
-MY_PN="Sphinx"
-MY_P="${MY_PN}-${PV/_beta/b}"
-
-DESCRIPTION="Tool to create documentation for Python projects"
-HOMEPAGE="http://sphinx.pocoo.org/ http://pypi.python.org/pypi/Sphinx"
-SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc latex"
-
-RDEPEND=">=dev-python/pygments-0.8
- >=dev-python/jinja-2.2
- >=dev-python/docutils-0.5
- latex? ( dev-texlive/texlive-latexextra )"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-RESTRICT_PYTHON_ABIS="3.*"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="CHANGES"
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- cd doc
- einfo "Generation of documentation"
- PYTHONPATH="../" emake SPHINXBUILD="$(PYTHON -f) ../sphinx-build.py" html || die "Generation of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -A txt -r doc/_build/html/* || die "dohtml failed"
- fi
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
-
- # Generating the Grammar pickle to avoid on the fly generation causing sandbox violations (bug #266015)
- generation_of_grammar_pickle() {
- "$(PYTHON)" -c "from sphinx.pycode.pgen2.driver import load_grammar; load_grammar('${ROOT%/}${EPREFIX}$(python_get_sitedir)/sphinx/pycode/Grammar.txt')" || die "Generation of grammar pickle failed"
- }
- python_execute_function --action-message 'Generation of Grammar pickle with Python ${PYTHON_ABI}...' generation_of_grammar_pickle
-}
-
-pkg_postrm() {
- distutils_pkg_postrm
-
- deletion_of_grammar_pickle() {
- rm "${ROOT%/}${EPREFIX}$(python_get_sitedir)/sphinx/pycode"/Grammar*.pickle
- }
- python_execute_function --action-message 'Deletion of Grammar pickle with Python ${PYTHON_ABI}...' deletion_of_grammar_pickle
-}