summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2008-03-18 21:49:37 +0000
committerMarkus Ullmann <jokey@gentoo.org>2008-03-18 21:49:37 +0000
commitcf297beee9d0622270738758a9c5e3f5cb0ac103 (patch)
treef8be3b1532b5c8a229de77cb12079db749a9fd52 /dev-python
parentVersion bump. Add 3.5.1 and remove 3.4.1. Include patch from upstream (r780036). (diff)
downloadgentoo-2-cf297beee9d0622270738758a9c5e3f5cb0ac103.tar.gz
gentoo-2-cf297beee9d0622270738758a9c5e3f5cb0ac103.tar.bz2
gentoo-2-cf297beee9d0622270738758a9c5e3f5cb0ac103.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/snakeoil/ChangeLog7
-rw-r--r--dev-python/snakeoil/snakeoil-0.2.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-python/snakeoil/ChangeLog b/dev-python/snakeoil/ChangeLog
index b0d4e5e89958..d422332a65c7 100644
--- a/dev-python/snakeoil/ChangeLog
+++ b/dev-python/snakeoil/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/snakeoil
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/snakeoil/ChangeLog,v 1.10 2008/03/12 18:18:05 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/snakeoil/ChangeLog,v 1.11 2008/03/18 21:49:37 jokey Exp $
+
+*snakeoil-0.2 (18 Mar 2008)
+
+ 18 Mar 2008; Markus Ullmann <jokey@gentoo.org> +snakeoil-0.2.ebuild:
+ Version bump
12 Mar 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing Marien Zwart (marienz, #107204) from metadata.xml.
diff --git a/dev-python/snakeoil/snakeoil-0.2.ebuild b/dev-python/snakeoil/snakeoil-0.2.ebuild
new file mode 100644
index 000000000000..1e44b3600869
--- /dev/null
+++ b/dev-python/snakeoil/snakeoil-0.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/snakeoil/snakeoil-0.2.ebuild,v 1.1 2008/03/18 21:49:37 jokey Exp $
+
+NEED_PYTHON=2.4
+
+inherit distutils
+
+DESCRIPTION="Miscellaneous python utility code."
+HOMEPAGE="http://www.pkgcore.org/"
+SRC_URI="http://www.pkgcore.org/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DOCS="AUTHORS NEWS"
+
+# Uses an ugly hack to install for all versions of python on the
+# system. This should be supported through the eclass at some point.
+# pkgcore needs it now to support upgrading to a different python slot.
+
+src_compile() {
+ local opython=${python}
+ for python in /usr/bin/python2.[4-9]; do
+ distutils_src_compile
+ done
+ python=${opython}
+}
+
+src_test() {
+ local opython=${python} tempdir
+ for python in /usr/bin/python2.[4-9]; do
+ tempdir="${T}/tests/$(basename ${python})"
+ mkdir -p "${tempdir}" || die "tempdir creation failed"
+ cp -r "${S}" "${tempdir}" || die "test copy failed"
+ cd "${tempdir}/${P}"
+ "${python}" setup.py test || die "testing returned non zero"
+ done
+ python=${opython}
+ rm -rf "${T}/tests"
+}
+
+src_install() {
+ local opython=${python}
+ for python in /usr/bin/python2.[4-9]; do
+ distutils_src_install
+ done
+}