summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-13 18:27:29 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-13 18:27:29 +0000
commitdcc27891a960a68f849a659b33a3e19828939e48 (patch)
treeddbf6fd88719518bb1695221dd0395df9d72b030 /dev-python
parentversion bump (bug #318615) (diff)
downloadgentoo-2-dcc27891a960a68f849a659b33a3e19828939e48.tar.gz
gentoo-2-dcc27891a960a68f849a659b33a3e19828939e48.tar.bz2
gentoo-2-dcc27891a960a68f849a659b33a3e19828939e48.zip
Version bump.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pylint/ChangeLog8
-rw-r--r--dev-python/pylint/pylint-0.21.0.ebuild66
2 files changed, 73 insertions, 1 deletions
diff --git a/dev-python/pylint/ChangeLog b/dev-python/pylint/ChangeLog
index 58ec4c05ef3b..3a132978b613 100644
--- a/dev-python/pylint/ChangeLog
+++ b/dev-python/pylint/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pylint
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.64 2010/05/03 19:24:34 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.65 2010/05/13 18:27:29 arfrever Exp $
+
+*pylint-0.21.0 (13 May 2010)
+
+ 13 May 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pylint-0.21.0.ebuild:
+ Version bump.
03 May 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
pylint-0.20.0.ebuild:
diff --git a/dev-python/pylint/pylint-0.21.0.ebuild b/dev-python/pylint/pylint-0.21.0.ebuild
new file mode 100644
index 000000000000..4c4cba938f2b
--- /dev/null
+++ b/dev-python/pylint/pylint-0.21.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.21.0.ebuild,v 1.1 2010/05/13 18:27:29 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="tk"
+PYTHON_USE_WITH_OPT="tk"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="a tool to check if a Python module satisfies a coding standard"
+HOMEPAGE="http://www.logilab.org/projects/pylint/ http://pypi.python.org/pypi/pylint"
+SRC_URI="ftp://ftp.logilab.org/pub/${PN}/${P}.tar.gz http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc examples test tk"
+
+DEPEND=">=dev-python/logilab-common-0.44.0
+ >=dev-python/astng-0.20"
+RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Disable failing tests.
+ rm -f test/input/func_arguments.py
+ sed -e "s/test_exhaustivity/_&/" -i test/test_func.py || die "sed failed"
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" pytest -v
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ doman man/{pylint,pyreverse}.1 || die "doman failed"
+ dodoc doc/FAQ.txt || die "dodoc failed"
+
+ if use doc; then
+ dodoc doc/*.txt || die "dodoc failed"
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc examples/* || die "dodoc failed"
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ if ! has_version "=dev-lang/python-2*[tk]"; then
+ ewarn "dev-lang/python has been built without tk support,"
+ ewarn "${PN}-gui doesn't work without Tkinter so if you really need it,"
+ ewarn "re-install dev-lang/python with \"tk\" useflag enabled."
+ fi
+}