summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-08-08 09:29:14 +0000
committerMichał Górny <mgorny@gentoo.org>2013-08-08 09:29:14 +0000
commitdeb10fa76e0e03c68b490c529303ba31058561e3 (patch)
treeb10585ceffbd0f931e13b48dcf00759f6c01fecb /dev-python
parentStable for amd64, wrt bug #480138 (diff)
downloadgentoo-2-deb10fa76e0e03c68b490c529303ba31058561e3.tar.gz
gentoo-2-deb10fa76e0e03c68b490c529303ba31058561e3.tar.bz2
gentoo-2-deb10fa76e0e03c68b490c529303ba31058561e3.zip
Migrate to python-r1.
(Portage version: 2.2.0_alpha195/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-gudev/ChangeLog7
-rw-r--r--dev-python/python-gudev/python-gudev-147.2-r1.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/python-gudev/ChangeLog b/dev-python/python-gudev/ChangeLog
index 1c794f780cba..df6c50c1bad6 100644
--- a/dev-python/python-gudev/ChangeLog
+++ b/dev-python/python-gudev/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/python-gudev
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-gudev/ChangeLog,v 1.9 2013/02/05 18:22:34 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-gudev/ChangeLog,v 1.10 2013/08/08 09:29:14 mgorny Exp $
+
+*python-gudev-147.2-r1 (08 Aug 2013)
+
+ 08 Aug 2013; Michał Górny <mgorny@gentoo.org> +python-gudev-147.2-r1.ebuild:
+ Migrate to python-r1.
05 Feb 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup after talking with Ford_Prefect
diff --git a/dev-python/python-gudev/python-gudev-147.2-r1.ebuild b/dev-python/python-gudev/python-gudev-147.2-r1.ebuild
new file mode 100644
index 000000000000..c64d5a8efc65
--- /dev/null
+++ b/dev-python/python-gudev/python-gudev-147.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-gudev/python-gudev-147.2-r1.ebuild,v 1.1 2013/08/08 09:29:14 mgorny Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=modules
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit autotools-utils python-r1 vcs-snapshot
+
+DESCRIPTION="Python binding to the GUDev udev helper library"
+HOMEPAGE="http://github.com/nzjrs/python-gudev"
+SRC_URI="https://github.com/nzjrs/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pygobject:2[${PYTHON_USEDEP}]
+ virtual/udev[gudev]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ python_foreach_impl autotools-utils_src_configure
+}
+
+src_compile() {
+ python_foreach_impl autotools-utils_src_compile
+}
+
+src_test() {
+ python_foreach_impl autotools-utils_src_test
+}
+
+src_install() {
+ python_foreach_impl autotools-utils_src_install
+}