summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-04-24 22:42:53 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-04-24 22:42:53 +0000
commite4d74e678cf535df7b70311bd025c70990a38942 (patch)
treed962a2d0e70925a7d42deac6058282552943c1f5 /dev-python
parentCommit grub-2.00-zfs-feature-flag-support-r1.patch in preparation for sys-boo... (diff)
downloadgentoo-2-e4d74e678cf535df7b70311bd025c70990a38942.tar.gz
gentoo-2-e4d74e678cf535df7b70311bd025c70990a38942.tar.bz2
gentoo-2-e4d74e678cf535df7b70311bd025c70990a38942.zip
Switched to distutils-r1, fixed pkg-config modversion in wcs unbundling patch
(Portage version: 2.2.01.21890-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pywcs/ChangeLog8
-rw-r--r--dev-python/pywcs/files/pywcs-1.11-wcslib.patch2
-rw-r--r--dev-python/pywcs/pywcs-1.11-r1.ebuild41
3 files changed, 49 insertions, 2 deletions
diff --git a/dev-python/pywcs/ChangeLog b/dev-python/pywcs/ChangeLog
index 9736aee0f63e..caec983ed8a7 100644
--- a/dev-python/pywcs/ChangeLog
+++ b/dev-python/pywcs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pywcs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pywcs/ChangeLog,v 1.8 2013/04/23 16:00:52 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pywcs/ChangeLog,v 1.9 2013/04/24 22:42:52 bicatali Exp $
+
+*pywcs-1.11-r1 (24 Apr 2013)
+
+ 24 Apr 2013; Sébastien Fabbro <bicatali@gentoo.org> +pywcs-1.11-r1.ebuild,
+ files/pywcs-1.11-wcslib.patch:
+ Switched to distutils-r1, fixed pkg-config modversion in wcs unbundling patch
23 Apr 2013; Sébastien Fabbro <bicatali@gentoo.org> pywcs-1.11.ebuild:
Block astropy
diff --git a/dev-python/pywcs/files/pywcs-1.11-wcslib.patch b/dev-python/pywcs/files/pywcs-1.11-wcslib.patch
index 2dd198677307..14cd4e3dceab 100644
--- a/dev-python/pywcs/files/pywcs-1.11-wcslib.patch
+++ b/dev-python/pywcs/files/pywcs-1.11-wcslib.patch
@@ -81,7 +81,7 @@
-""" % (WCSVERSION, determine_64_bit_int()))
-write_if_different(join(srcroot, 'src', 'wcsconfig.h'), h_file.getvalue())
+WCSLIB = pkgconfig('wcslib')
-+WCSVERSION = WCSLIB['version'][0]
++WCSVERSION = Popen(["pkg-config --modversion"],stdout=PIPE, shell=True).communicate()[0].split()
######################################################################
# GENERATE DOCSTRINGS IN C
diff --git a/dev-python/pywcs/pywcs-1.11-r1.ebuild b/dev-python/pywcs/pywcs-1.11-r1.ebuild
new file mode 100644
index 000000000000..19c1a642ab09
--- /dev/null
+++ b/dev-python/pywcs/pywcs-1.11-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pywcs/pywcs-1.11-r1.ebuild,v 1.1 2013/04/24 22:42:52 bicatali Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1 eutils
+
+WCS_V=4.8.2
+MYP=${P}-${WCS_V}
+
+DESCRIPTION="Python routines for handling the FITS World Coordinate System"
+HOMEPAGE="https://trac6.assembla.com/astrolib/wiki"
+SRC_URI="http://stsdas.stsci.edu/astrolib/${MYP}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="
+ >=sci-astronomy/wcslib-${WCS_V}
+ virtual/pkgconfig"
+RDEPEND="
+ >=sci-astronomy/wcslib-${WCS_V}
+ virtual/pyfits
+ !dev-python/astropy"
+
+# missing data to run tests
+RESTRICT=test
+S="${WORKDIR}/${MYP}"
+
+python_prepare_all(){
+ epatch "${FILESDIR}"/${P}-wcslib.patch
+}
+
+python_test() {
+ nosetests -w "${BUILD_DIR}"/lib || die "Tests fail with ${EPYTHON}"
+}