summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-30 04:54:01 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-30 04:54:01 +0000
commitfc201bdd4994739c116330d0608429281762dbdc (patch)
tree77436588f9ec08015923f9fc2c1a03c25023f451 /dev-python
parentFix dependencies. (diff)
downloadgentoo-2-fc201bdd4994739c116330d0608429281762dbdc.tar.gz
gentoo-2-fc201bdd4994739c116330d0608429281762dbdc.tar.bz2
gentoo-2-fc201bdd4994739c116330d0608429281762dbdc.zip
Version bump.
(Portage version: 2.2.0_alpha19_p14/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/traitsgui/ChangeLog8
-rw-r--r--dev-python/traitsgui/traitsgui-3.6.0.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/dev-python/traitsgui/ChangeLog b/dev-python/traitsgui/ChangeLog
index 7e33cfc2c5e6..e1e210fbef09 100644
--- a/dev-python/traitsgui/ChangeLog
+++ b/dev-python/traitsgui/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/traitsgui
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/traitsgui/ChangeLog,v 1.13 2011/01/27 10:02:13 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/traitsgui/ChangeLog,v 1.14 2011/01/30 04:54:01 arfrever Exp $
+
+*traitsgui-3.6.0 (30 Jan 2011)
+
+ 30 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +traitsgui-3.6.0.ebuild:
+ Version bump.
27 Jan 2011; Markos Chandras <hwoarang@gentoo.org> traitsgui-3.5.0.ebuild:
Stable on amd64 wrt bug #347107
diff --git a/dev-python/traitsgui/traitsgui-3.6.0.ebuild b/dev-python/traitsgui/traitsgui-3.6.0.ebuild
new file mode 100644
index 000000000000..ef67bc013c96
--- /dev/null
+++ b/dev-python/traitsgui/traitsgui-3.6.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/traitsgui/traitsgui-3.6.0.ebuild,v 1.1 2011/01/30 04:54:01 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils
+
+MY_PN="TraitsGUI"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Traits-capable windowing framework"
+HOMEPAGE="http://code.enthought.com/projects/traits_gui/ http://pypi.python.org/pypi/TraitsGUI"
+SRC_URI="http://www.enthought.com/repo/ETS/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc examples qt4 wxwidgets"
+
+RDEPEND=">=dev-python/enthoughtbase-3.1.0
+ >=dev-python/traits-${PV}
+ qt4? ( >=dev-python/traitsbackendqt-${PV} )
+ wxwidgets? ( >=dev-python/traitsbackendwx-${PV} )
+ !wxwidgets? ( !qt4? ( >=dev-python/traitsbackendwx-${PV} ) )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="docs/*.txt docs/*.pdf"
+PYTHON_MODNAME="enthought"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ pushd docs > /dev/null
+ emake html || die "Generation of documentation failed"
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ find -name "*LICENSE.txt" -delete
+ distutils_src_install
+
+ if use doc; then
+ pushd docs/build/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/* || die "Installation of examples failed"
+ fi
+}