summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-05-06 19:29:41 +0000
committerHans de Graaff <graaff@gentoo.org>2014-05-06 19:29:41 +0000
commit0de3bcddd1e5a885a9aa94b53f3290a2f608f6f3 (patch)
tree21a6d3ba1583156061b5894f1dcf0f6b9c098016 /dev-ruby/actionpack
parentVersion bump for Rails 4.0.5, security bug 509706. (diff)
downloadgentoo-2-0de3bcddd1e5a885a9aa94b53f3290a2f608f6f3.tar.gz
gentoo-2-0de3bcddd1e5a885a9aa94b53f3290a2f608f6f3.tar.bz2
gentoo-2-0de3bcddd1e5a885a9aa94b53f3290a2f608f6f3.zip
Version bump for Rails 4.0.5, security bug 509706.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/actionpack')
-rw-r--r--dev-ruby/actionpack/ChangeLog7
-rw-r--r--dev-ruby/actionpack/actionpack-4.0.5.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index dc0ca442f72e..bb94911538b6 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionpack
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.276 2014/05/06 18:52:29 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.277 2014/05/06 19:29:41 graaff Exp $
+
+*actionpack-4.0.5 (06 May 2014)
+
+ 06 May 2014; Hans de Graaff <graaff@gentoo.org> +actionpack-4.0.5.ebuild:
+ Version bump for Rails 4.0.5, security bug 509706.
*actionpack-3.2.18 (06 May 2014)
diff --git a/dev-ruby/actionpack/actionpack-4.0.5.ebuild b/dev-ruby/actionpack/actionpack-4.0.5.ebuild
new file mode 100644
index 000000000000..0682b1218b2a
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-4.0.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-4.0.5.ebuild,v 1.1 2014/05/06 19:29:41 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+# The default test task tries to test activerecord with SQLite as well.
+RUBY_FAKEGEM_TASK_TEST="test_action_pack"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.1.0:3.1
+ >=dev-ruby/rack-1.5.2:1.5
+ >=dev-ruby/rack-test-0.6.2:0.6
+ >=dev-ruby/erubis-2.7.0"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha:0.13
+ dev-ruby/bundler
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ dev-ruby/sprockets-rails:2.0
+ >=dev-ruby/tzinfo-0.3.29:0
+ >=dev-ruby/uglifier-1.0.3
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\)/d" ../Gemfile || die
+
+ sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
+ sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
+
+ sed -i -e '/bcrypt/ s/3.0.0/3.0/' ../Gemfile || die
+
+ # Add back json in the Gemfile because we dropped some dependencies
+ # earlier that implicitly required it.
+ sed -i -e '$agem "json"' ../Gemfile || die
+
+ # Avoid fragile test that gets more output than it expects.
+ sed -i -e '/test_locals_option_to_assert_template_is_not_supported/,/end/ s:^:#:' test/controller/render_test.rb || die
+}