summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-07-12 07:01:53 +0000
committerHans de Graaff <graaff@gentoo.org>2014-07-12 07:01:53 +0000
commitb64c2f389ce709f74a5341954ddc0a8f17cb2a8f (patch)
tree41596ee6e050d91e74c1533b04482a74d54a06be /dev-ruby/actionpack
parentRemove vulnerable versions. (diff)
downloadgentoo-2-b64c2f389ce709f74a5341954ddc0a8f17cb2a8f.tar.gz
gentoo-2-b64c2f389ce709f74a5341954ddc0a8f17cb2a8f.tar.bz2
gentoo-2-b64c2f389ce709f74a5341954ddc0a8f17cb2a8f.zip
Remove vulnerable versions.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/actionpack')
-rw-r--r--dev-ruby/actionpack/ChangeLog7
-rw-r--r--dev-ruby/actionpack/actionpack-3.2.18.ebuild74
-rw-r--r--dev-ruby/actionpack/actionpack-4.0.5.ebuild66
-rw-r--r--dev-ruby/actionpack/actionpack-4.0.6.ebuild66
-rw-r--r--dev-ruby/actionpack/actionpack-4.1.1.ebuild46
-rw-r--r--dev-ruby/actionpack/actionpack-4.1.2.ebuild46
6 files changed, 6 insertions, 299 deletions
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index 31e7677b108a..8fb737ee469d 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionpack
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.284 2014/07/03 06:20:06 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.285 2014/07/12 07:01:53 graaff Exp $
+
+ 12 Jul 2014; Hans de Graaff <graaff@gentoo.org> -actionpack-3.2.18.ebuild,
+ -actionpack-4.0.5.ebuild, -actionpack-4.0.6.ebuild, -actionpack-4.1.1.ebuild,
+ -actionpack-4.1.2.ebuild:
+ Remove vulnerable versions.
*actionpack-4.1.4 (03 Jul 2014)
diff --git a/dev-ruby/actionpack/actionpack-3.2.18.ebuild b/dev-ruby/actionpack/actionpack-3.2.18.ebuild
deleted file mode 100644
index bbf6e9ae5efd..000000000000
--- a/dev-ruby/actionpack/actionpack-3.2.18.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-3.2.18.ebuild,v 1.1 2014/05/06 18:52:29 graaff Exp $
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20"
-
-# The default test task tries to test activerecord with SQLite as well.
-RUBY_FAKEGEM_TASK_TEST="test_action_pack"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Eases web-request routing, handling, and response."
-HOMEPAGE="http://rubyforge.org/projects/actionpack/"
-SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- ~dev-ruby/activemodel-${PV}
- ~dev-ruby/activesupport-${PV}
- >=dev-ruby/rack-cache-1.2
- >=dev-ruby/builder-3.0.0:3
- >=dev-ruby/rack-1.4.5:1.4
- >=dev-ruby/rack-test-0.6.1:0.6
- >=dev-ruby/journey-1.0.4:1.0
- >=dev-ruby/sprockets-2.2.1:2.2
- >=dev-ruby/erubis-2.7.0"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/mocha:0.13
- dev-ruby/bundler
- ~dev-ruby/activerecord-${PV}
- ~dev-ruby/actionmailer-${PV}
- >=dev-ruby/tzinfo-0.3.29:0
- >=dev-ruby/uglifier-1.0.3
- )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|nokogiri\)/d" ../Gemfile || die
-
- sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
- sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
-
- sed -i -e '/bcrypt/ s/3.0.0/3.0/' ../Gemfile || die
-
- # Avoid fragile tests depending on hash ordering
- sed -i -e '/cookie_3=chocolate/ s:^:#:' test/controller/integration_test.rb || die
- sed -i -e '/test_to_s/,/end/ s:^:#:' test/template/html-scanner/tag_node_test.rb || die
- sed -i -e '/"name":"david"/ s:^:#:' test/controller/mime_responds_test.rb || die
- sed -i -e '/test_option_html_attributes_with_multiple_element_hash/, / end/ s:^:#:' test/template/form_options_helper_test.rb || die
- sed -i -e '/test_option_html_attributes_with_multiple_hashes/, / end/ s:^:#:' test/template/form_options_helper_test.rb || die
-
- # Avoid fragile test that gets more output than it expects.
- sed -i -e '/test_locals_option_to_assert_template_is_not_supported/,/end/ s:^:#:' test/controller/render_test.rb || die
-
- # Avoid test broken by security updates in i18n.
- sed -i -e '/test_number_to_i18n_currency/,/end/ s:^:#:' test/template/number_helper_i18n_test.rb || die
-}
diff --git a/dev-ruby/actionpack/actionpack-4.0.5.ebuild b/dev-ruby/actionpack/actionpack-4.0.5.ebuild
deleted file mode 100644
index 0682b1218b2a..000000000000
--- a/dev-ruby/actionpack/actionpack-4.0.5.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-4.0.5.ebuild,v 1.1 2014/05/06 19:29:41 graaff Exp $
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20 ruby21"
-
-# The default test task tries to test activerecord with SQLite as well.
-RUBY_FAKEGEM_TASK_TEST="test_action_pack"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Eases web-request routing, handling, and response."
-HOMEPAGE="http://rubyforge.org/projects/actionpack/"
-SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- ~dev-ruby/activesupport-${PV}
- >=dev-ruby/builder-3.1.0:3.1
- >=dev-ruby/rack-1.5.2:1.5
- >=dev-ruby/rack-test-0.6.2:0.6
- >=dev-ruby/erubis-2.7.0"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/mocha:0.13
- dev-ruby/bundler
- ~dev-ruby/activemodel-${PV}
- ~dev-ruby/activerecord-${PV}
- ~dev-ruby/actionmailer-${PV}
- dev-ruby/sprockets-rails:2.0
- >=dev-ruby/tzinfo-0.3.29:0
- >=dev-ruby/uglifier-1.0.3
- )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\)/d" ../Gemfile || die
-
- sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
- sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
-
- sed -i -e '/bcrypt/ s/3.0.0/3.0/' ../Gemfile || die
-
- # Add back json in the Gemfile because we dropped some dependencies
- # earlier that implicitly required it.
- sed -i -e '$agem "json"' ../Gemfile || die
-
- # Avoid fragile test that gets more output than it expects.
- sed -i -e '/test_locals_option_to_assert_template_is_not_supported/,/end/ s:^:#:' test/controller/render_test.rb || die
-}
diff --git a/dev-ruby/actionpack/actionpack-4.0.6.ebuild b/dev-ruby/actionpack/actionpack-4.0.6.ebuild
deleted file mode 100644
index 62c9554f5b10..000000000000
--- a/dev-ruby/actionpack/actionpack-4.0.6.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-4.0.6.ebuild,v 1.1 2014/06/26 19:21:19 graaff Exp $
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20 ruby21"
-
-# The default test task tries to test activerecord with SQLite as well.
-RUBY_FAKEGEM_TASK_TEST="test_action_pack"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Eases web-request routing, handling, and response."
-HOMEPAGE="http://rubyforge.org/projects/actionpack/"
-SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- ~dev-ruby/activesupport-${PV}
- >=dev-ruby/builder-3.1.0:3.1
- >=dev-ruby/rack-1.5.2:1.5
- >=dev-ruby/rack-test-0.6.2:0.6
- >=dev-ruby/erubis-2.7.0"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/mocha:0.13
- dev-ruby/bundler
- ~dev-ruby/activemodel-${PV}
- ~dev-ruby/activerecord-${PV}
- ~dev-ruby/actionmailer-${PV}
- dev-ruby/sprockets-rails:2.0
- >=dev-ruby/tzinfo-0.3.37:0
- >=dev-ruby/uglifier-1.0.3
- )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\)/d" ../Gemfile || die
-
- sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
- sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
-
- sed -i -e '/bcrypt/ s/3.0.0/3.0/' ../Gemfile || die
-
- # Add back json in the Gemfile because we dropped some dependencies
- # earlier that implicitly required it.
- sed -i -e '$agem "json"' ../Gemfile || die
-
- # Avoid fragile test that gets more output than it expects.
- sed -i -e '/test_locals_option_to_assert_template_is_not_supported/,/end/ s:^:#:' test/controller/render_test.rb || die
-}
diff --git a/dev-ruby/actionpack/actionpack-4.1.1.ebuild b/dev-ruby/actionpack/actionpack-4.1.1.ebuild
deleted file mode 100644
index 2be90f16e3e1..000000000000
--- a/dev-ruby/actionpack/actionpack-4.1.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-4.1.1.ebuild,v 1.1 2014/05/06 20:00:29 graaff Exp $
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20 ruby21"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Eases web-request routing, handling, and response."
-HOMEPAGE="http://rubyforge.org/projects/actionpack/"
-SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- ~dev-ruby/activesupport-${PV}
- ~dev-ruby/actionview-${PV}
- >=dev-ruby/rack-1.5.2:1.5
- >=dev-ruby/rack-test-0.6.2:0.6"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/mocha:0.14
- dev-ruby/bundler
- ~dev-ruby/activemodel-${PV}
- >=dev-ruby/rack-cache-1.2:1.2
- )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\)/ s:^:#:" ../Gemfile || die
-}
diff --git a/dev-ruby/actionpack/actionpack-4.1.2.ebuild b/dev-ruby/actionpack/actionpack-4.1.2.ebuild
deleted file mode 100644
index 275c27c9c7a1..000000000000
--- a/dev-ruby/actionpack/actionpack-4.1.2.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-4.1.2.ebuild,v 1.1 2014/06/26 20:06:53 graaff Exp $
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20 ruby21"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Eases web-request routing, handling, and response."
-HOMEPAGE="http://rubyforge.org/projects/actionpack/"
-SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- ~dev-ruby/activesupport-${PV}
- ~dev-ruby/actionview-${PV}
- >=dev-ruby/rack-1.5.2:1.5
- >=dev-ruby/rack-test-0.6.2:0.6"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/mocha:0.14
- dev-ruby/bundler
- ~dev-ruby/activemodel-${PV}
- >=dev-ruby/rack-cache-1.2:1.2
- )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|minitest\)/ s:^:#:" ../Gemfile || die
-}