summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-03-30 09:33:18 +0000
committerHans de Graaff <graaff@gentoo.org>2013-03-30 09:33:18 +0000
commite4150d44b8bcf4941b3d5901fb1ec2f7a77c0575 (patch)
tree7319dd0b7e58c7d63a4e9447d0c2165622932d4e /dev-ruby/activerecord
parentVersion bump for security bug 462452. (diff)
downloadgentoo-2-e4150d44b8bcf4941b3d5901fb1ec2f7a77c0575.tar.gz
gentoo-2-e4150d44b8bcf4941b3d5901fb1ec2f7a77c0575.tar.bz2
gentoo-2-e4150d44b8bcf4941b3d5901fb1ec2f7a77c0575.zip
Version bump for security bug 462452.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/activerecord')
-rw-r--r--dev-ruby/activerecord/ChangeLog7
-rw-r--r--dev-ruby/activerecord/activerecord-2.3.18.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index 2354e5230cc8..ffb939fb3c74 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.233 2013/03/27 13:33:45 moult Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.234 2013/03/30 09:33:18 graaff Exp $
+
+*activerecord-2.3.18 (30 Mar 2013)
+
+ 30 Mar 2013; Hans de Graaff <graaff@gentoo.org> +activerecord-2.3.18.ebuild:
+ Version bump for security bug 462452.
27 Mar 2013; Dion Moult <moult@gentoo.org> -activerecord-3.0.20.ebuild:
Remove dev-ruby/activerecord:3.0 due to lack of upstream support
diff --git a/dev-ruby/activerecord/activerecord-2.3.18.ebuild b/dev-ruby/activerecord/activerecord-2.3.18.ebuild
new file mode 100644
index 000000000000..86e7766fe752
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-2.3.18.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-2.3.18.ebuild,v 1.1 2013/03/30 09:33:18 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 jruby"
+
+# this is not null so that the dependencies will actually be filled
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="mysql postgres sqlite3" #sqlite
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}"
+
+#ruby_add_rdepend sqlite ">=dev-ruby/sqlite-ruby-2.2.2"
+USE_RUBY=ruby18 \
+ ruby_add_rdepend "
+ sqlite3? ( dev-ruby/sqlite3 )
+ mysql? ( >=dev-ruby/mysql-ruby-2.7 )
+ postgres? ( dev-ruby/pg )"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/rdoc
+ =dev-ruby/mocha-0.10*
+ )"
+
+all_ruby_prepare() {
+ # Custom template not found in package
+ sed -i -e '/horo/d' Rakefile || die
+
+ # Remove test cases with hash ordering failures.
+ sed -i -e '/test_bind_enumerable/,/end/ s:^:#:' test/cases/finder_test.rb || die
+ sed -i -e '/test_should_automatically_build_new_associated/,/^ end/ s:^:#:' test/cases/nested_attributes_test.rb || die
+
+ # Make sure we load a compatible version of activesupport for tests.
+ sed -i -e '10igem "activesupport", "~>2.3.15"' test/cases/helper.rb || die
+
+ # Drop test now broken by security fixes.
+ rm test/cases/serialization_test.rb
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *)
+ if use sqlite3; then
+ ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
+ fi
+ ;;
+ esac
+}