summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-10-06 17:04:11 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-10-06 17:04:11 +0000
commit4248853e5fc3470e8a89eea60ae99eeee896ffad (patch)
tree8119261cb186145da4326810985bd58ef66939ea /dev-ruby/bluecloth
parentAdd ruby20 target. (diff)
downloadgentoo-2-4248853e5fc3470e8a89eea60ae99eeee896ffad.tar.gz
gentoo-2-4248853e5fc3470e8a89eea60ae99eeee896ffad.tar.bz2
gentoo-2-4248853e5fc3470e8a89eea60ae99eeee896ffad.zip
Add ruby20 target.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/bluecloth')
-rw-r--r--dev-ruby/bluecloth/ChangeLog7
-rw-r--r--dev-ruby/bluecloth/bluecloth-2.2.0-r1.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-ruby/bluecloth/ChangeLog b/dev-ruby/bluecloth/ChangeLog
index 3b4d4c95e9ac..c4471b019844 100644
--- a/dev-ruby/bluecloth/ChangeLog
+++ b/dev-ruby/bluecloth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/bluecloth
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/ChangeLog,v 1.70 2013/07/08 18:46:51 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/ChangeLog,v 1.71 2013/10/06 17:04:11 mrueg Exp $
+
+*bluecloth-2.2.0-r1 (06 Oct 2013)
+
+ 06 Oct 2013; Manuel Rüger <mrueg@gentoo.org> +bluecloth-2.2.0-r1.ebuild:
+ Add ruby20 target.
08 Jul 2013; Hans de Graaff <graaff@gentoo.org> -bluecloth-2.0.7.ebuild:
Cleanup.
diff --git a/dev-ruby/bluecloth/bluecloth-2.2.0-r1.ebuild b/dev-ruby/bluecloth/bluecloth-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..cf80ab0751cf
--- /dev/null
+++ b/dev-ruby/bluecloth/bluecloth-2.2.0-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/bluecloth-2.2.0-r1.ebuild,v 1.1 2013/10/06 17:04:11 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A Ruby implementation of Markdown"
+HOMEPAGE="http://www.deveiate.org/projects/BlueCloth"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+DEPEND+=" doc? ( dev-lang/perl )"
+
+ruby_add_bdepend "
+ dev-ruby/hoe
+ dev-ruby/rake-compiler
+ test? (
+ dev-ruby/diff-lcs
+ dev-ruby/tidy-ext
+ )"
+
+all_ruby_prepare() {
+ # for Ruby 1.9.2 compatibility
+ sed -i -e '1i $: << "."' Rakefile || die
+}
+
+all_ruby_compile() {
+ rake man/man1/bluecloth.1 || die
+
+ all_fakegem_compile
+}
+
+each_ruby_compile() {
+ ${RUBY} -S rake compile || die "extension build failed"
+}
+
+all_ruby_install() {
+ doman man/man1/bluecloth.1
+
+ all_fakegem_install
+}