summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-16 14:21:25 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-16 14:21:25 +0000
commitda7bb63fb01001ffbbd3615c26e9d86410dc04c9 (patch)
tree7e87f9b964bfe5eb9dabfd2b3676b0b3df828d25 /dev-ruby/bluecloth
parentRemove duplicates of MIT license, bug 301168. (diff)
downloadgentoo-2-da7bb63fb01001ffbbd3615c26e9d86410dc04c9.tar.gz
gentoo-2-da7bb63fb01001ffbbd3615c26e9d86410dc04c9.tar.bz2
gentoo-2-da7bb63fb01001ffbbd3615c26e9d86410dc04c9.zip
Version bump; use rake-compiler this time. Simplify ebuild with the ruby-fakegem variables.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/bluecloth')
-rw-r--r--dev-ruby/bluecloth/ChangeLog9
-rw-r--r--dev-ruby/bluecloth/bluecloth-2.0.6_pre120.ebuild42
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-ruby/bluecloth/ChangeLog b/dev-ruby/bluecloth/ChangeLog
index 57f71351b3a9..2eb5a6c1e690 100644
--- a/dev-ruby/bluecloth/ChangeLog
+++ b/dev-ruby/bluecloth/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/bluecloth
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/ChangeLog,v 1.30 2010/01/13 17:47:41 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/ChangeLog,v 1.31 2010/01/16 14:21:25 flameeyes Exp $
+
+*bluecloth-2.0.6_pre120 (16 Jan 2010)
+
+ 16 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +bluecloth-2.0.6_pre120.ebuild:
+ Version bump; use rake-compiler this time. Simplify ebuild with the
+ ruby-fakegem variables.
13 Jan 2010; Brent Baude <ranger@gentoo.org> bluecloth-2.0.5-r1.ebuild:
Marking bluecloth-2.0.5-r1 ~ppc64 for bug 297041
diff --git a/dev-ruby/bluecloth/bluecloth-2.0.6_pre120.ebuild b/dev-ruby/bluecloth/bluecloth-2.0.6_pre120.ebuild
new file mode 100644
index 000000000000..825fd35677af
--- /dev/null
+++ b/dev-ruby/bluecloth/bluecloth-2.0.6_pre120.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/bluecloth-2.0.6_pre120.ebuild,v 1.1 2010/01/16 14:21:25 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_VERSION="${PV/_pre/.pre}"
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README"
+RUBY_FAKEGEM_DOCDIR="docs/api"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A Ruby implementation of Markdown"
+HOMEPAGE="http://www.deveiate.org/projects/BlueCloth"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend ">=dev-ruby/rdoc-2.4.1 dev-ruby/rake-compiler"
+ruby_add_bdepend test "dev-ruby/rspec
+ dev-ruby/diff-lcs"
+
+all_ruby_prepare() {
+ # The Rakefile uses the rubygems' package_task unconditionally,
+ # but this breaks when we don't install rubygems proper (like for
+ # Ruby 1.9 or JRuby). For this reason, patch it away. It should
+ # really be submitted upstream so that, if missing, only the
+ # packaging tasks will be ignored.
+ sed -i \
+ -e '/^\(Gem\|Rake\)::PackageTask/, /^end/ s:^:#:' \
+ -e '/package_task/s:^:#:' \
+ -e '/task :package/s:^:#:' \
+ rake/packaging.rb || die
+}
+
+each_ruby_compile() {
+ ${RUBY} -S rake compile || die "extension build failed"
+}