summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-11-20 13:26:45 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-11-20 13:26:45 +0000
commita25d0e0a095af1af2e105e7863ea7b9e3f077181 (patch)
tree227ce62f1bea206e32395fc875b937e6e70a19da /dev-ruby/css_parser
parentFix introspection deps (diff)
downloadgentoo-2-a25d0e0a095af1af2e105e7863ea7b9e3f077181.tar.gz
gentoo-2-a25d0e0a095af1af2e105e7863ea7b9e3f077181.tar.bz2
gentoo-2-a25d0e0a095af1af2e105e7863ea7b9e3f077181.zip
Fix tests for jruby. Cleanup old.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/css_parser')
-rw-r--r--dev-ruby/css_parser/ChangeLog8
-rw-r--r--dev-ruby/css_parser/css_parser-1.2.6.ebuild50
-rw-r--r--dev-ruby/css_parser/css_parser-1.3.5-r1.ebuild (renamed from dev-ruby/css_parser/css_parser-1.3.5.ebuild)3
3 files changed, 9 insertions, 52 deletions
diff --git a/dev-ruby/css_parser/ChangeLog b/dev-ruby/css_parser/ChangeLog
index ede765cab0b2..d350fe93d988 100644
--- a/dev-ruby/css_parser/ChangeLog
+++ b/dev-ruby/css_parser/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/css_parser
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/css_parser/ChangeLog,v 1.4 2013/11/18 02:25:28 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/css_parser/ChangeLog,v 1.5 2013/11/20 13:26:45 mrueg Exp $
+
+*css_parser-1.3.5-r1 (20 Nov 2013)
+
+ 20 Nov 2013; Manuel Rüger <mrueg@gentoo.org> +css_parser-1.3.5-r1.ebuild,
+ -css_parser-1.2.6.ebuild, -css_parser-1.3.5.ebuild:
+ Fix tests for jruby. Cleanup old.
*css_parser-1.3.5 (18 Nov 2013)
diff --git a/dev-ruby/css_parser/css_parser-1.2.6.ebuild b/dev-ruby/css_parser/css_parser-1.2.6.ebuild
deleted file mode 100644
index 247861f5f0f6..000000000000
--- a/dev-ruby/css_parser/css_parser-1.2.6.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/css_parser/css_parser-1.2.6.ebuild,v 1.3 2013/02/10 08:59:29 graaff Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ruby19 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_DOC="rdoc"
-RUBY_FAKEGEM_DOC_DIR="doc"
-RUBY_FAKEGEM_EXTRADOC="README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-GITHUB_USER="alexdunae"
-GITHUB_PROJECT="${PN}"
-RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Sass-based Stylesheet Framework"
-HOMEPAGE="http://compass-style.org/"
-LICENSE="MIT"
-
-SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/tarball/${PV} -> ${GITHUB_PROJECT}-${PV}.tar.gz"
-
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc test"
-
-ruby_add_rdepend "dev-ruby/addressable
- virtual/ruby-ssl"
-
-all_ruby_prepare() {
- # fix wrong runtime dependency over rdoc
- sed -i -e '/rdoc/s:add_dep:add_development_dep:' "${RUBY_FAKEGEM_GEMSPEC}" || die
-
- # get rid of bundler usage
- rm Gemfile || die
- sed -i -e '/bundler/d' rakefile.rb || die
-
- # Avoid tests using the network.
- sed -i -e '/test_loading_a_remote_file_over_ssl/,/end/ s:^:#:' test/test_css_parser_loading.rb || die
-
-}
-
-each_ruby_prepare() {
- if [[ ${RUBY} == */jruby ]]; then
- sed -i -e '/add_development_dependency/i s.add_dependency("jruby-openssl")' "${RUBY_FAKEGEM_GEMSPEC}" || die
- fi
-}
diff --git a/dev-ruby/css_parser/css_parser-1.3.5.ebuild b/dev-ruby/css_parser/css_parser-1.3.5-r1.ebuild
index 51173a061a61..9370c963c8c2 100644
--- a/dev-ruby/css_parser/css_parser-1.3.5.ebuild
+++ b/dev-ruby/css_parser/css_parser-1.3.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/css_parser/css_parser-1.3.5.ebuild,v 1.1 2013/11/18 02:25:28 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/css_parser/css_parser-1.3.5-r1.ebuild,v 1.1 2013/11/20 13:26:45 mrueg Exp $
EAPI=5
USE_RUBY="ruby18 ruby19 ruby20 jruby"
@@ -32,6 +32,7 @@ all_ruby_prepare() {
# get rid of bundler usage
rm Gemfile || die
sed -i -e '/bundler/d' -e '/bump/d' Rakefile || die
+ sed -i -e '/bundler/d' test/test_helper.rb || die
# Avoid tests using the network.
sed -i -e '/test_loading_a_remote_file_over_ssl/,/end/ s:^:#:' test/test_css_parser_loading.rb || die