summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-07-19 06:53:23 +0000
committerHans de Graaff <graaff@gentoo.org>2010-07-19 06:53:23 +0000
commitc2757fe7c07192a0b9a9ab0dfd93caa911cdeb1c (patch)
treed63e168fe2d036097ac88aabcec94f4fd09868d7 /dev-ruby/daemons
parentno more xul:1.8 (diff)
downloadgentoo-2-c2757fe7c07192a0b9a9ab0dfd93caa911cdeb1c.tar.gz
gentoo-2-c2757fe7c07192a0b9a9ab0dfd93caa911cdeb1c.tar.bz2
gentoo-2-c2757fe7c07192a0b9a9ab0dfd93caa911cdeb1c.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/daemons')
-rw-r--r--dev-ruby/daemons/ChangeLog7
-rw-r--r--dev-ruby/daemons/daemons-1.1.0.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-ruby/daemons/ChangeLog b/dev-ruby/daemons/ChangeLog
index 4fed3abaee9c..cd05fd072a6e 100644
--- a/dev-ruby/daemons/ChangeLog
+++ b/dev-ruby/daemons/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/daemons
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemons/ChangeLog,v 1.46 2010/05/24 21:51:55 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemons/ChangeLog,v 1.47 2010/07/19 06:53:23 graaff Exp $
+
+*daemons-1.1.0 (19 Jul 2010)
+
+ 19 Jul 2010; Hans de Graaff <graaff@gentoo.org> +daemons-1.1.0.ebuild:
+ Version bump.
24 May 2010; Alex Legler <a3li@gentoo.org> daemons-1.0.10-r1.ebuild:
Add REE18 support
diff --git a/dev-ruby/daemons/daemons-1.1.0.ebuild b/dev-ruby/daemons/daemons-1.1.0.ebuild
new file mode 100644
index 000000000000..36b8844e255c
--- /dev/null
+++ b/dev-ruby/daemons/daemons-1.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemons/daemons-1.1.0.ebuild,v 1.1 2010/07/19 06:53:23 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_EXTRADOC="Releases README TODO"
+RUBY_FAKEGEM_DOCDIR="html"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Wrap existing ruby scripts to be run as a daemon"
+HOMEPAGE="http://daemons.rubyforge.org/"
+
+LICENSE="|| ( Ruby GPL-2 ) MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="examples"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ use examples || return
+
+ insinto /usr/share/doc/${PF}/
+ doins -r examples || die "Failed to install examples"
+}