summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-09-10 09:25:05 +0000
committerHans de Graaff <graaff@gentoo.org>2011-09-10 09:25:05 +0000
commit410ae00e534d358b0510ac6391a76441587ddf90 (patch)
treeee86ad001c8a400d18f865a28f124236c0702947 /dev-ruby/gherkin
parentVersion bump to 9.7.4. (diff)
downloadgentoo-2-410ae00e534d358b0510ac6391a76441587ddf90.tar.gz
gentoo-2-410ae00e534d358b0510ac6391a76441587ddf90.tar.bz2
gentoo-2-410ae00e534d358b0510ac6391a76441587ddf90.zip
Remove old versions.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/gherkin')
-rw-r--r--dev-ruby/gherkin/ChangeLog6
-rw-r--r--dev-ruby/gherkin/gherkin-2.3.7.ebuild72
-rw-r--r--dev-ruby/gherkin/gherkin-2.3.9.ebuild70
-rw-r--r--dev-ruby/gherkin/gherkin-2.4.2.ebuild72
-rw-r--r--dev-ruby/gherkin/gherkin-2.4.6.ebuild72
5 files changed, 5 insertions, 287 deletions
diff --git a/dev-ruby/gherkin/ChangeLog b/dev-ruby/gherkin/ChangeLog
index 610ae6157047..bd101b61ed57 100644
--- a/dev-ruby/gherkin/ChangeLog
+++ b/dev-ruby/gherkin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/gherkin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/ChangeLog,v 1.28 2011/08/26 06:07:26 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/ChangeLog,v 1.29 2011/09/10 09:25:05 graaff Exp $
+
+ 10 Sep 2011; Hans de Graaff <graaff@gentoo.org> -gherkin-2.3.7.ebuild,
+ -gherkin-2.3.9.ebuild, -gherkin-2.4.2.ebuild, -gherkin-2.4.6.ebuild:
+ Remove old versions.
*gherkin-2.4.15 (26 Aug 2011)
diff --git a/dev-ruby/gherkin/gherkin-2.3.7.ebuild b/dev-ruby/gherkin/gherkin-2.3.7.ebuild
deleted file mode 100644
index be756b08bd3e..000000000000
--- a/dev-ruby/gherkin/gherkin-2.3.7.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/gherkin-2.3.7.ebuild,v 1.1 2011/05/06 14:47:18 graaff Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18"
-
-RUBY_FAKEGEM_TASK_DOC="-Ilib -rgherkin/version -f tasks/rdoc.rake rdoc"
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
-
-RUBY_FAKEGEM_EXTRAINSTALL="VERSION"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Fast Gherkin lexer and parser based on Ragel."
-HOMEPAGE="http://wiki.github.com/aslakhellesoy/cucumber/gherkin"
-LICENSE="MIT"
-SRC_URI="https://github.com/aslakhellesoy/gherkin/tarball/v${PV} -> ${P}.tgz"
-
-KEYWORDS="~amd64"
-SLOT="0"
-IUSE="doc test"
-
-DEPEND="${DEPEND} dev-util/ragel"
-RDEPEND="${RDEPEND}"
-
-S="${WORKDIR}/aslakhellesoy-gherkin-*"
-
-ruby_add_bdepend "
- dev-ruby/rake-compiler
- test? (
- >=dev-ruby/awesome_print-0.3
- >=dev-ruby/builder-3.0.0
- >=dev-util/cucumber-0.10.0
- >=dev-ruby/rspec-2.5.0
- >=dev-ruby/term-ansicolor-1.0.5
- )"
-
-ruby_add_rdepend ">=dev-ruby/json-1.4.6"
-
-all_ruby_prepare() {
- # Remove Bundler-related things.
- sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb features/support/env.rb || die
- rm Gemfile || die
-
- # Don't use compile dependencies to avoid building again for specs.
- sed -i -e '/:compile/d' Rakefile
-
- # Remove feature that depends on direct access to the cucumber
- # source We could probably set this up by downloading the source
- # and unpacking it, but skipping this now in the interest of time.
- rm features/pretty_formatter.feature || die
-
- # We need to remove this tasks during bootstrapping since it tries
- # to load cucumber already but we can be sure it isn't installed
- # yet.
- if ! use test ; then
- rm tasks/cucumber.rake || die "Unable to remove cucumber tasks."
- fi
-}
-
-each_ruby_compile() {
- ${RUBY} -I lib -S rake -rrake/clean -f tasks/compile.rake compile || die
-}
-
-each_ruby_test() {
- ${RUBY} -S rake spec || die "Specs failed"
- CUCUMBER_HOME="${HOME}" ${RUBY} -S rake cucumber || die "Cucumber features failed"
-}
diff --git a/dev-ruby/gherkin/gherkin-2.3.9.ebuild b/dev-ruby/gherkin/gherkin-2.3.9.ebuild
deleted file mode 100644
index a505345e40ca..000000000000
--- a/dev-ruby/gherkin/gherkin-2.3.9.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/gherkin-2.3.9.ebuild,v 1.1 2011/05/29 07:01:05 graaff Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18"
-
-RUBY_FAKEGEM_TASK_DOC="-Ilib -rgherkin/version -f tasks/rdoc.rake rdoc"
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Fast Gherkin lexer and parser based on Ragel."
-HOMEPAGE="http://wiki.github.com/aslakhellesoy/cucumber/gherkin"
-LICENSE="MIT"
-SRC_URI="https://github.com/cucumber/gherkin/tarball/v${PV} -> ${P}.tgz"
-
-KEYWORDS="~amd64"
-SLOT="0"
-IUSE="doc test"
-
-DEPEND="${DEPEND} dev-util/ragel"
-RDEPEND="${RDEPEND}"
-
-S="${WORKDIR}/cucumber-gherkin-*"
-
-ruby_add_bdepend "
- dev-ruby/rake-compiler
- test? (
- >=dev-ruby/awesome_print-0.3
- >=dev-ruby/builder-3.0.0
- >=dev-util/cucumber-0.10.0
- >=dev-ruby/rspec-2.5.0
- >=dev-ruby/term-ansicolor-1.0.5
- )"
-
-ruby_add_rdepend ">=dev-ruby/json-1.4.6"
-
-all_ruby_prepare() {
- # Remove Bundler-related things.
- sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb features/support/env.rb || die
- rm Gemfile || die
-
- # Don't use compile dependencies to avoid building again for specs.
- sed -i -e '/:compile/d' Rakefile
-
- # Remove feature that depends on direct access to the cucumber
- # source. We could probably set this up by downloading the source
- # and unpacking it, but skipping this now in the interest of time.
- rm features/pretty_formatter.feature || die
-
- # We need to remove this tasks during bootstrapping since it tries
- # to load cucumber already but we can be sure it isn't installed
- # yet.
- if ! use test ; then
- rm tasks/cucumber.rake || die "Unable to remove cucumber tasks."
- fi
-}
-
-each_ruby_compile() {
- ${RUBY} -I lib -S rake -rrake/clean -f tasks/compile.rake compile || die
-}
-
-each_ruby_test() {
- ${RUBY} -S rake spec || die "Specs failed"
- CUCUMBER_HOME="${HOME}" ${RUBY} -S rake cucumber || die "Cucumber features failed"
-}
diff --git a/dev-ruby/gherkin/gherkin-2.4.2.ebuild b/dev-ruby/gherkin/gherkin-2.4.2.ebuild
deleted file mode 100644
index efedcff700a9..000000000000
--- a/dev-ruby/gherkin/gherkin-2.4.2.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/gherkin-2.4.2.ebuild,v 1.1 2011/07/08 18:45:44 graaff Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18"
-
-RUBY_FAKEGEM_TASK_DOC="yard"
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="History.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Fast Gherkin lexer and parser based on Ragel."
-HOMEPAGE="http://wiki.github.com/aslakhellesoy/cucumber/gherkin"
-LICENSE="MIT"
-SRC_URI="https://github.com/cucumber/gherkin/tarball/v${PV} -> ${P}.tgz"
-
-KEYWORDS="~amd64"
-SLOT="0"
-IUSE="doc test"
-
-DEPEND="${DEPEND} dev-util/ragel"
-RDEPEND="${RDEPEND}"
-
-S="${WORKDIR}/cucumber-gherkin-*"
-
-ruby_add_bdepend "
- dev-ruby/rake-compiler
- test? (
- >=dev-ruby/awesome_print-0.4.0
- >=dev-ruby/builder-2.1.2
- >=dev-util/cucumber-1.0.0
- >=dev-ruby/rspec-2.6.0
- >=dev-ruby/term-ansicolor-1.0.5
- )
- doc? ( >=dev-ruby/yard-0.7.2 )"
-
-ruby_add_rdepend ">=dev-ruby/json-1.4.6"
-
-all_ruby_prepare() {
- # Remove Bundler-related things.
- sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb features/support/env.rb || die
- rm Gemfile || die
-
- # Don't use compile dependencies to avoid building again for specs.
- sed -i -e '/:compile/d' Rakefile
-
- # Remove feature that depends on direct access to the cucumber
- # source. We could probably set this up by downloading the source
- # and unpacking it, but skipping this now in the interest of time.
- rm features/pretty_formatter.feature || die
-
- # We need to remove these tasks during bootstrapping since it tries
- # to load cucumber already but we can be sure it isn't installed
- # yet. Also remove other rake tasks for which we may not yet have
- # dependencies.
- if ! use test ; then
- rm tasks/cucumber.rake tasks/rspec.rake || die "Unable to remove rake tasks."
- fi
-}
-
-each_ruby_compile() {
- ${RUBY} -I lib -S rake -rrake/clean -f tasks/compile.rake compile || die
-}
-
-each_ruby_test() {
- ${RUBY} -I lib -S rake spec || die "Specs failed"
- CUCUMBER_HOME="${HOME}" RUBYLIB=lib ${RUBY} -S cucumber features || die "Cucumber features failed"
-}
diff --git a/dev-ruby/gherkin/gherkin-2.4.6.ebuild b/dev-ruby/gherkin/gherkin-2.4.6.ebuild
deleted file mode 100644
index 540b9fa126a0..000000000000
--- a/dev-ruby/gherkin/gherkin-2.4.6.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/gherkin-2.4.6.ebuild,v 1.1 2011/08/08 06:05:51 graaff Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ree18"
-
-RUBY_FAKEGEM_TASK_DOC="yard"
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="History.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Fast Gherkin lexer and parser based on Ragel."
-HOMEPAGE="http://wiki.github.com/aslakhellesoy/cucumber/gherkin"
-LICENSE="MIT"
-SRC_URI="https://github.com/cucumber/gherkin/tarball/v${PV} -> ${P}.tgz"
-
-KEYWORDS="~amd64"
-SLOT="0"
-IUSE="doc test"
-
-DEPEND="${DEPEND} dev-util/ragel"
-RDEPEND="${RDEPEND}"
-
-RUBY_S="cucumber-gherkin-*"
-
-ruby_add_bdepend "
- dev-ruby/rake-compiler
- test? (
- >=dev-ruby/awesome_print-0.4.0
- >=dev-ruby/builder-2.1.2
- >=dev-util/cucumber-1.0.0
- >=dev-ruby/rspec-2.6.0
- >=dev-ruby/term-ansicolor-1.0.5
- )
- doc? ( >=dev-ruby/yard-0.7.2 )"
-
-ruby_add_rdepend ">=dev-ruby/json-1.4.6"
-
-all_ruby_prepare() {
- # Remove Bundler-related things.
- sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb features/support/env.rb || die
- rm Gemfile || die
-
- # Don't use compile dependencies to avoid building again for specs.
- sed -i -e '/:compile/d' Rakefile
-
- # Remove feature that depends on direct access to the cucumber
- # source. We could probably set this up by downloading the source
- # and unpacking it, but skipping this now in the interest of time.
- rm features/pretty_formatter.feature || die
-
- # We need to remove these tasks during bootstrapping since it tries
- # to load cucumber already but we can be sure it isn't installed
- # yet. Also remove other rake tasks for which we may not yet have
- # dependencies.
- if ! use test ; then
- rm tasks/cucumber.rake tasks/rspec.rake || die "Unable to remove rake tasks."
- fi
-}
-
-each_ruby_compile() {
- ${RUBY} -I lib -S rake -rrake/clean -f tasks/compile.rake compile || die
-}
-
-each_ruby_test() {
- ${RUBY} -I lib -S rake spec || die "Specs failed"
- CUCUMBER_HOME="${HOME}" RUBYLIB=lib ${RUBY} -S cucumber features || die "Cucumber features failed"
-}