summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-05-20 16:18:03 +0000
committerHans de Graaff <graaff@gentoo.org>2012-05-20 16:18:03 +0000
commit17dc9a5f7cf8c45872a1dbeb66939ed305d5d9a6 (patch)
tree8203b9874bf90b2e8f25e018aa50def429a70e21 /dev-ruby/json
parentRemove old versions. (diff)
downloadgentoo-2-17dc9a5f7cf8c45872a1dbeb66939ed305d5d9a6.tar.gz
gentoo-2-17dc9a5f7cf8c45872a1dbeb66939ed305d5d9a6.tar.bz2
gentoo-2-17dc9a5f7cf8c45872a1dbeb66939ed305d5d9a6.zip
Add revision for ruby19 stable request.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/json')
-rw-r--r--dev-ruby/json/ChangeLog7
-rw-r--r--dev-ruby/json/json-1.5.4-r1.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/dev-ruby/json/ChangeLog b/dev-ruby/json/ChangeLog
index 7f36550f1f26..93398966efa0 100644
--- a/dev-ruby/json/ChangeLog
+++ b/dev-ruby/json/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/json
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.84 2012/05/13 06:04:43 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.85 2012/05/20 16:18:03 graaff Exp $
+
+*json-1.5.4-r1 (20 May 2012)
+
+ 20 May 2012; Hans de Graaff <graaff@gentoo.org> +json-1.5.4-r1.ebuild:
+ Add revision for ruby19 stable request.
*json-1.6.7 (13 May 2012)
diff --git a/dev-ruby/json/json-1.5.4-r1.ebuild b/dev-ruby/json/json-1.5.4-r1.ebuild
new file mode 100644
index 000000000000..80b4e8424068
--- /dev/null
+++ b/dev-ruby/json/json-1.5.4-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.5.4-r1.ebuild,v 1.1 2012/05/20 16:18:03 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 jruby ruby19"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES TODO README.rdoc README-json-jruby.markdown"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A JSON implementation as a Ruby extension."
+HOMEPAGE="http://json.rubyforge.org/"
+LICENSE="|| ( Ruby GPL-2 )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+RDEPEND="${RDEPEND}"
+DEPEND="${DEPEND}
+ dev-util/ragel"
+
+ruby_add_bdepend "dev-ruby/rake
+ test? ( virtual/ruby-test-unit )"
+
+all_ruby_prepare() {
+ # Avoid building the extension twice!
+ # And use rdoc instead of sdoc which we don't have packaged
+ sed -i \
+ -e 's| => :compile||' \
+ -e 's| => :clean||' \
+ -e 's|sdoc|rdoc|' \
+ Rakefile || die "rakefile fix failed"
+}
+
+each_ruby_compile() {
+ # Since 1.5.0 a Java extension is provided but it does not compile.
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ ${RUBY} -S rake compile || die "extension compile failed"
+ fi
+}
+
+each_ruby_test() {
+ JSON=pure \
+ ${RUBY} -Iext:lib -rtest/unit -e "Dir['test/*.rb'].each{|f| require f}" || die "pure ruby tests failed"
+
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ JSON=ext \
+ ${RUBY} -Iext:lib -rtest/unit -e "Dir['test/*.rb'].each{|f| require f}" || die "ext ruby tests failed"
+ fi
+}
+
+each_ruby_install() {
+ each_fakegem_install
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ ruby_fakegem_newins ext/json/ext/generator$(get_modname) lib/json/ext/generator$(get_modname)
+ ruby_fakegem_newins ext/json/ext/parser$(get_modname) lib/json/ext/parser$(get_modname)
+ fi
+}