summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-04-11 06:54:26 +0000
committerHans de Graaff <graaff@gentoo.org>2010-04-11 06:54:26 +0000
commit329890a1a0203b5f1b9a4c6d1f36dbbf8844964f (patch)
tree7f8d7e1fd9a5e5f6a2539e5884d0d5d3441e4a94 /dev-ruby/json
parentold (diff)
downloadgentoo-2-329890a1a0203b5f1b9a4c6d1f36dbbf8844964f.tar.gz
gentoo-2-329890a1a0203b5f1b9a4c6d1f36dbbf8844964f.tar.bz2
gentoo-2-329890a1a0203b5f1b9a4c6d1f36dbbf8844964f.zip
Version bump: Triger const_missing callback to make Rails' dynamic class loading work.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/json')
-rw-r--r--dev-ruby/json/ChangeLog8
-rw-r--r--dev-ruby/json/json-1.2.4.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/dev-ruby/json/ChangeLog b/dev-ruby/json/ChangeLog
index 2bc04f0ffadb..c49e1af8048f 100644
--- a/dev-ruby/json/ChangeLog
+++ b/dev-ruby/json/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/json
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.21 2010/04/04 06:54:38 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.22 2010/04/11 06:54:26 graaff Exp $
+
+*json-1.2.4 (11 Apr 2010)
+
+ 11 Apr 2010; Hans de Graaff <graaff@gentoo.org> +json-1.2.4.ebuild:
+ Version bump: Triger const_missing callback to make Rails' dynamic class
+ loading work.
*json-1.2.3 (04 Apr 2010)
diff --git a/dev-ruby/json/json-1.2.4.ebuild b/dev-ruby/json/json-1.2.4.ebuild
new file mode 100644
index 000000000000..6de72cf9cc5f
--- /dev/null
+++ b/dev-ruby/json/json-1.2.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.2.4.ebuild,v 1.1 2010/04/11 06:54:26 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES TODO README"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A JSON implementation as a Ruby extension."
+HOMEPAGE="http://json.rubyforge.org/"
+LICENSE="|| ( Ruby GPL-2 )"
+SRC_URI="mirror://rubygems/${P}.gem"
+
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-util/ragel"
+
+ruby_add_bdepend test virtual/ruby-test-unit
+ruby_add_bdepend dev-ruby/rake
+
+all_ruby_prepare() {
+ # Avoid building the extension twice!
+ sed -i \
+ -e 's| => :compile_ext||' \
+ -e 's| => :clean||' \
+ Rakefile || die "rakefile fix failed"
+}
+
+each_ruby_compile() {
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ ${RUBY} -S rake compile_ext || die "extension compile failed"
+ fi
+}
+
+each_ruby_test() {
+ # We have to set RUBYLIB because otherwise the tests will run
+ # against the sytem-installed json; at the same time, we cannot
+ # use the -I parameter because rake won't let it pass to the
+ # testrb call that is executed down the road.
+
+ RUBYLIB="${RUBYLIB}${RUBYLIB+:}lib:ext/json/ext" \
+ ${RUBY} -S rake test_pure || die "pure ruby tests failed"
+
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ RUBYLIB="${RUBYLIB}${RUBYLIB+:}lib:ext/json/ext" \
+ ${RUBY} -Ilib:ext/json/ext -S rake test_ext || die " ruby extension tests failed"
+ fi
+}
+
+each_ruby_install() {
+ each_fakegem_install
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ ruby_fakegem_newins ext/json/ext/generator.so lib/json/generator.so
+ ruby_fakegem_newins ext/json/ext/parser.so lib/json/parser.so
+ fi
+}