summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-10-30 03:54:10 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-10-30 03:54:10 +0000
commite64bb2acaa04894421a0cd0a62025aa575be95b5 (patch)
tree81c81cf828b73b9bbe6dbb08801a1755f18473ac /dev-ruby/matchy
parentAdd ruby20 target. (diff)
downloadgentoo-2-e64bb2acaa04894421a0cd0a62025aa575be95b5.tar.gz
gentoo-2-e64bb2acaa04894421a0cd0a62025aa575be95b5.tar.bz2
gentoo-2-e64bb2acaa04894421a0cd0a62025aa575be95b5.zip
Add ruby20 target.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/matchy')
-rw-r--r--dev-ruby/matchy/ChangeLog7
-rw-r--r--dev-ruby/matchy/matchy-0.5.2-r1.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-ruby/matchy/ChangeLog b/dev-ruby/matchy/ChangeLog
index cd6505f935db..84591c7ec5e6 100644
--- a/dev-ruby/matchy/ChangeLog
+++ b/dev-ruby/matchy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/matchy
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/matchy/ChangeLog,v 1.10 2013/01/01 09:04:30 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/matchy/ChangeLog,v 1.11 2013/10/30 03:54:10 mrueg Exp $
+
+*matchy-0.5.2-r1 (30 Oct 2013)
+
+ 30 Oct 2013; Manuel Rüger <mrueg@gentoo.org> +matchy-0.5.2-r1.ebuild:
+ Add ruby20 target.
01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> matchy-0.5.2.ebuild:
Stable for x86, wrt bug #448672
diff --git a/dev-ruby/matchy/matchy-0.5.2-r1.ebuild b/dev-ruby/matchy/matchy-0.5.2-r1.ebuild
new file mode 100644
index 000000000000..5583b8b88691
--- /dev/null
+++ b/dev-ruby/matchy/matchy-0.5.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/matchy/matchy-0.5.2-r1.ebuild,v 1.1 2013/10/30 03:54:10 mrueg Exp $
+
+EAPI=5
+
+MY_OWNER="mcmire"
+
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC=""
+
+RUBY_FAKEGEM_NAME="${MY_OWNER}-${PN}"
+
+inherit ruby-fakegem
+
+DESCRIPTION="RSpec-esque matchers for use in Test::Unit"
+HOMEPAGE="http://github.com/mcmire/matchy"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# workaround for ruby 1.9.2, sent upstream after 0.5.2
+each_ruby_test() {
+ RUBYLIB="$(pwd)${RUBYLIB+:${RUBYLIB}}" each_fakegem_test
+}