summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-02-20 18:15:13 +0000
committerMamoru Komachi <usata@gentoo.org>2004-02-20 18:15:13 +0000
commit30afe90d2aed7087baa3a9e878d9a722fc7f83e8 (patch)
treef373eeb6c6e66904aca6a875b53dd568e8613e5d /dev-ruby/mod-ruby
parentFixed typo, closing bug #42063 (Manifest recommit) (diff)
downloadgentoo-2-30afe90d2aed7087baa3a9e878d9a722fc7f83e8.tar.gz
gentoo-2-30afe90d2aed7087baa3a9e878d9a722fc7f83e8.tar.bz2
gentoo-2-30afe90d2aed7087baa3a9e878d9a722fc7f83e8.zip
Fixed conditional statement when only apache2 is installed but apache2 USE flag is not set. Closing bug #41458
Diffstat (limited to 'dev-ruby/mod-ruby')
-rw-r--r--dev-ruby/mod-ruby/ChangeLog7
-rw-r--r--dev-ruby/mod-ruby/files/digest-mod-ruby-1.1.11
-rw-r--r--dev-ruby/mod-ruby/files/digest-mod-ruby-1.1.1-r11
-rw-r--r--dev-ruby/mod-ruby/mod-ruby-1.1.1-r1.ebuild80
-rw-r--r--dev-ruby/mod-ruby/mod-ruby-1.1.1-r2.ebuild12
-rw-r--r--dev-ruby/mod-ruby/mod-ruby-1.1.1.ebuild74
6 files changed, 14 insertions, 161 deletions
diff --git a/dev-ruby/mod-ruby/ChangeLog b/dev-ruby/mod-ruby/ChangeLog
index a84092537907..752793104105 100644
--- a/dev-ruby/mod-ruby/ChangeLog
+++ b/dev-ruby/mod-ruby/ChangeLog
@@ -1,11 +1,16 @@
# ChangeLog for dev-ruby/mod-ruby
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mod-ruby/ChangeLog,v 1.7 2004/02/20 17:46:06 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mod-ruby/ChangeLog,v 1.8 2004/02/20 18:15:13 usata Exp $
*mod-ruby-1.1.1-r2 (21 Feb 2004)
21 Feb 2004; Mamoru KOMACHI <usata@gentoo.org> mod-ruby-1.1.1-r1.ebuild,
mod-ruby-1.1.1-r2.ebuild, mod-ruby-1.1.1.ebuild:
+ Fixed conditional statement when only apache2 is installed but apache2
+ USE flag is not set. Closing bug #41458
+
+ 21 Feb 2004; Mamoru KOMACHI <usata@gentoo.org> mod-ruby-1.1.1-r1.ebuild,
+ mod-ruby-1.1.1-r2.ebuild, mod-ruby-1.1.1.ebuild:
Fixed typo
10 Jun 2003; Tom Payne <twp@gentoo.org> mod-ruby-1.1.1-r1.ebuild :
diff --git a/dev-ruby/mod-ruby/files/digest-mod-ruby-1.1.1 b/dev-ruby/mod-ruby/files/digest-mod-ruby-1.1.1
deleted file mode 100644
index 1cad513b26f3..000000000000
--- a/dev-ruby/mod-ruby/files/digest-mod-ruby-1.1.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 ea1ab677de5f129cb3ba21d55a57a1b3 mod_ruby-1.1.1.tar.gz 62191
diff --git a/dev-ruby/mod-ruby/files/digest-mod-ruby-1.1.1-r1 b/dev-ruby/mod-ruby/files/digest-mod-ruby-1.1.1-r1
deleted file mode 100644
index 1cad513b26f3..000000000000
--- a/dev-ruby/mod-ruby/files/digest-mod-ruby-1.1.1-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 ea1ab677de5f129cb3ba21d55a57a1b3 mod_ruby-1.1.1.tar.gz 62191
diff --git a/dev-ruby/mod-ruby/mod-ruby-1.1.1-r1.ebuild b/dev-ruby/mod-ruby/mod-ruby-1.1.1-r1.ebuild
deleted file mode 100644
index 319128eeda56..000000000000
--- a/dev-ruby/mod-ruby/mod-ruby-1.1.1-r1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mod-ruby/mod-ruby-1.1.1-r1.ebuild,v 1.3 2004/02/20 17:46:06 usata Exp $
-
-MY_P=mod_ruby-${PV}
-DESCRIPTION="Embeds the Ruby interpreter into Apache"
-HOMEPAGE="http://modruby.net/"
-SRC_URI="http://modruby.net/archive/${MY_P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="apache2"
-DEPEND=">=net-www/apache-1.3.3
- >=dev-lang/ruby-1.6.4
- doc? ( dev-ruby/rdtool )"
-S=${WORKDIR}/${MY_P}
-
-src_compile() {
-
- if [ "`use apache2`" ]; then
- :;
- else
- ewarn "apache support is UNTESTED"
- fi
-
- local two
- [ "`use apache2`" ] && two="2" || two=""
-
- ./configure.rb --with-apxs=/usr/sbin/apxs${two}
-
- cp Makefile Makefile.orig
- sed -e "s:\(^APACHE_LIBEXECDIR = \$(DESTDIR)/usr/lib/apache${two}\):\1-extramodules:" \
- Makefile.orig > Makefile
-
- emake || die
-
- if [ "`use doc`" ]; then
- :
- fi
-
-}
-
-src_install() {
-
- make DESTDIR=${D} install || die
-
- if [ "`use apache2`" ]; then
- insinto /etc/apache2/conf/modules.d
- doins ${FILESDIR}/20_mod_ruby.conf
- else
- insinto /etc/apache/conf/addon-modules
- doins ${FILESDIR}/mod_ruby.conf
- fi
-
- dodoc ChangeLog COPYING README.*
-
-}
-
-pkg_postinst() {
- if [ "`use apache2`" ]; then
- einfo "To enable mod_ruby, edit /etc/conf.d/apache2 and add \"-D RUBY\""
- einfo "You may also wish to edit /etc/conf.d/apache2/modules.d/20_mod_ruby.conf"
- else
- einfo "To enable mod_ruby:"
- einfo "1. Run \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
- einfo "2. Edit /etc/conf.d/apache and add \"-D RUBY\""
- fi
- einfo "You must restart apache for changes to take effect"
-}
-
-pkg_config() {
- if [ "`use apache2`" ]; then
- :;
- else
- ${ROOT}/usr/sbin/apacheaddmod \
- ${ROOT}/etc/apache/conf/apache.conf \
- extramodules/mod_ruby.so mod_ruby.c ruby_module \
- before=perl define=RUBY addconf=conf/addon-modules/mod_ruby.conf
- fi
-}
diff --git a/dev-ruby/mod-ruby/mod-ruby-1.1.1-r2.ebuild b/dev-ruby/mod-ruby/mod-ruby-1.1.1-r2.ebuild
index 849d0ae2b735..3ce1cbf252af 100644
--- a/dev-ruby/mod-ruby/mod-ruby-1.1.1-r2.ebuild
+++ b/dev-ruby/mod-ruby/mod-ruby-1.1.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mod-ruby/mod-ruby-1.1.1-r2.ebuild,v 1.3 2004/02/20 17:46:06 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mod-ruby/mod-ruby-1.1.1-r2.ebuild,v 1.4 2004/02/20 18:15:13 usata Exp $
MY_P=mod_ruby-${PV}
DESCRIPTION="Embeds the Ruby interpreter into Apache"
@@ -17,14 +17,18 @@ S=${WORKDIR}/${MY_P}
src_compile() {
- if [ "`use apache2`" ]; then
+ if [ "`use apache2`" -o "`has_version '=net-www/apache-1*'`" != 1 ]; then
:;
else
- ewarn "apache support is UNTESTED"
+ ewarn "apache 1.3.x support is UNTESTED"
fi
local two
- [ "`use apache2`" ] && two="2" || two=""
+ if [ -n "`use apache2`" -o "`has_version '=net-www/apache-1*'`" != 1 ]; then
+ two="2"
+ else
+ two=""
+ fi
./configure.rb --with-apxs=/usr/sbin/apxs${two}
diff --git a/dev-ruby/mod-ruby/mod-ruby-1.1.1.ebuild b/dev-ruby/mod-ruby/mod-ruby-1.1.1.ebuild
deleted file mode 100644
index 1e3c1304febc..000000000000
--- a/dev-ruby/mod-ruby/mod-ruby-1.1.1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mod-ruby/mod-ruby-1.1.1.ebuild,v 1.3 2004/02/20 17:46:06 usata Exp $
-
-MY_P=mod_ruby-${PV}
-DESCRIPTION="Embeds the Ruby interpreter into Apache"
-HOMEPAGE="http://modruby.net/"
-SRC_URI="http://modruby.net/archive/${MY_P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="apache2"
-DEPEND=">=net-www/apache-1.3.3 >=dev-lang/ruby-1.6.4"
-S=${WORKDIR}/${MY_P}
-
-src_compile() {
-
- if [ "`use apache2`" ]; then
- :;
- else
- ewarn "apache support is UNTESTED"
- fi
-
- local two
- [ "`use apache2`" ] && two="2" || two=""
-
- ./configure.rb --with-apxs=/usr/sbin/apxs${two}
-
- cp Makefile Makefile.orig
- sed -e "s:\(^APACHE_LIBEXECDIR = \$(DESTDIR)/usr/lib/apache${two}\):\1-extramodules:" \
- Makefile.orig > Makefile
-
- emake || die
-
-}
-
-src_install() {
-
- make DESTDIR=${D} install || die
-
- if [ "`use apache2`" ]; then
- insinto /etc/apache2/conf/modules.d
- doins ${FILESDIR}/20_mod_ruby.conf
- else
- insinto /etc/apache/conf/addon-modules
- doins ${FILESDIR}/mod_ruby.conf
- fi
-
- dodoc ChangeLog COPYING README.*
-
-}
-
-pkg_postinst() {
- if [ "`use apache2`" ]; then
- einfo "To enable mod_ruby, edit /etc/conf.d/apache2 and add \"-D RUBY\""
- einfo "You may also wish to edit /etc/conf.d/apache2/modules.d/20_mod_ruby.conf"
- else
- einfo "To enable mod_ruby:"
- einfo "1. Run \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
- einfo "2. Edit /etc/conf.d/apache and add \"-D RUBY\""
- fi
- einfo "You must restart apache for changes to take effect"
-}
-
-pkg_config() {
- if [ "`use apache2`" ]; then
- :;
- else
- ${ROOT}/usr/sbin/apacheaddmod \
- ${ROOT}/etc/apache/conf/apache.conf \
- extramodules/mod_ruby.so mod_ruby.c ruby_module \
- before=perl define=RUBY addconf=conf/addon-modules/mod_ruby.conf
- fi
-}