summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-09-09 17:28:24 +0000
committerHans de Graaff <graaff@gentoo.org>2012-09-09 17:28:24 +0000
commitc927c3f97026997a0f31b7e3ec21221114e5a2a0 (patch)
tree4caa9393c1b701093c34fa730a03364a201ce247 /dev-ruby/oauth2
parentVersion bump to catalyst-2.0.11. (diff)
downloadgentoo-2-c927c3f97026997a0f31b7e3ec21221114e5a2a0.tar.gz
gentoo-2-c927c3f97026997a0f31b7e3ec21221114e5a2a0.tar.bz2
gentoo-2-c927c3f97026997a0f31b7e3ec21221114e5a2a0.zip
Version bump. Drop x86 due to new dependencies, bug 434488.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/oauth2')
-rw-r--r--dev-ruby/oauth2/ChangeLog7
-rw-r--r--dev-ruby/oauth2/oauth2-0.8.0.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-ruby/oauth2/ChangeLog b/dev-ruby/oauth2/ChangeLog
index 808d40e5050f..53ecb72fb468 100644
--- a/dev-ruby/oauth2/ChangeLog
+++ b/dev-ruby/oauth2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/oauth2
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/ChangeLog,v 1.12 2012/04/18 13:38:14 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/ChangeLog,v 1.13 2012/09/09 17:28:24 graaff Exp $
+
+*oauth2-0.8.0 (09 Sep 2012)
+
+ 09 Sep 2012; Hans de Graaff <graaff@gentoo.org> +oauth2-0.8.0.ebuild:
+ Version bump. Drop x86 due to new dependencies, bug 434488.
*oauth2-0.5.2 (18 Apr 2012)
diff --git a/dev-ruby/oauth2/oauth2-0.8.0.ebuild b/dev-ruby/oauth2/oauth2-0.8.0.ebuild
new file mode 100644
index 000000000000..fc036b6770ab
--- /dev/null
+++ b/dev-ruby/oauth2/oauth2-0.8.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/oauth2-0.8.0.ebuild,v 1.1 2012/09/09 17:28:24 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth gem."
+HOMEPAGE="http://github.com/intridea/oauth2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/faraday-0.8
+ >=dev-ruby/httpauth-0.1
+ >=dev-ruby/jwt-0.1.4
+ >=dev-ruby/multi_json-1.0.3
+ >=dev-ruby/rack-1.2"
+ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.5.0:2 dev-ruby/multi_xml )"
+
+all_ruby_prepare() {
+ rm .rspec || die
+}
+
+each_ruby_test() {
+ CI=true ${RUBY} -S rspec spec || die
+}