summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-09-16 18:47:14 +0000
committerHans de Graaff <graaff@gentoo.org>2011-09-16 18:47:14 +0000
commitd09703fbc9f9498d563b96782370c87fd987905a (patch)
treeebdd18d9225d954cf1a45a3ee806a5c3762ac2a3 /dev-ruby/patron
parentUse ffmpeg virtual, bug 362129 (diff)
downloadgentoo-2-d09703fbc9f9498d563b96782370c87fd987905a.tar.gz
gentoo-2-d09703fbc9f9498d563b96782370c87fd987905a.tar.bz2
gentoo-2-d09703fbc9f9498d563b96782370c87fd987905a.zip
Version bump.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/patron')
-rw-r--r--dev-ruby/patron/ChangeLog7
-rw-r--r--dev-ruby/patron/patron-0.4.16.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-ruby/patron/ChangeLog b/dev-ruby/patron/ChangeLog
index 436d823ff94c..413d9da8f04a 100644
--- a/dev-ruby/patron/ChangeLog
+++ b/dev-ruby/patron/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/patron
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/ChangeLog,v 1.18 2011/08/26 06:42:31 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/ChangeLog,v 1.19 2011/09/16 18:47:14 graaff Exp $
+
+*patron-0.4.16 (16 Sep 2011)
+
+ 16 Sep 2011; Hans de Graaff <graaff@gentoo.org> +patron-0.4.16.ebuild:
+ Version bump.
*patron-0.4.15 (26 Aug 2011)
diff --git a/dev-ruby/patron/patron-0.4.16.ebuild b/dev-ruby/patron/patron-0.4.16.ebuild
new file mode 100644
index 000000000000..9787d69f2733
--- /dev/null
+++ b/dev-ruby/patron/patron-0.4.16.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/patron-0.4.16.ebuild,v 1.1 2011/09/16 18:47:14 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_EXTRADOC="README.txt"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Patron is a Ruby HTTP client library based on libcurl."
+HOMEPAGE="http://toland.github.com/patron/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+#ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+
+DEPEND="${DEPEND} net-misc/curl"
+RDEPEND="${RDEPEND} net-misc/curl"
+
+# Tests require a live web service that is not included in the distribution.
+RESTRICT="test"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/patron extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/patron || die
+ cp ext/patron/session_ext$(get_modname) lib/patron/ || die "Unable to cp shared object file"
+}