summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-01-24 15:43:02 +0000
committerHans de Graaff <graaff@gentoo.org>2010-01-24 15:43:02 +0000
commitbdafc5ded985c801868cff16539665263319ea99 (patch)
treee266f2fc2e4c5320ce838cd94c550adaf3f9e3a9 /dev-ruby/prawn-security
parentVersion bump for prawn 0.7.1. Convert to ruby-fakegem. (diff)
downloadgentoo-2-bdafc5ded985c801868cff16539665263319ea99.tar.gz
gentoo-2-bdafc5ded985c801868cff16539665263319ea99.tar.bz2
gentoo-2-bdafc5ded985c801868cff16539665263319ea99.zip
Initial import. New dependency of dev-ruby/prawn.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/prawn-security')
-rw-r--r--dev-ruby/prawn-security/ChangeLog10
-rw-r--r--dev-ruby/prawn-security/metadata.xml5
-rw-r--r--dev-ruby/prawn-security/prawn-security-0.7.1.ebuild32
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/prawn-security/ChangeLog b/dev-ruby/prawn-security/ChangeLog
new file mode 100644
index 000000000000..5a41237db24b
--- /dev/null
+++ b/dev-ruby/prawn-security/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/prawn-security
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/prawn-security/ChangeLog,v 1.1 2010/01/24 15:43:02 graaff Exp $
+
+*prawn-security-0.7.1 (24 Jan 2010)
+
+ 24 Jan 2010; Hans de Graaff <graaff@gentoo.org>
+ +prawn-security-0.7.1.ebuild, +metadata.xml:
+ Initial import. New dependency of dev-ruby/prawn.
+
diff --git a/dev-ruby/prawn-security/metadata.xml b/dev-ruby/prawn-security/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/prawn-security/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/prawn-security/prawn-security-0.7.1.ebuild b/dev-ruby/prawn-security/prawn-security-0.7.1.ebuild
new file mode 100644
index 000000000000..f6753167b734
--- /dev/null
+++ b/dev-ruby/prawn-security/prawn-security-0.7.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/prawn-security/prawn-security-0.7.1.ebuild,v 1.1 2010/01/24 15:43:02 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Popular Password Protection & Permissions for Prawn PDFs"
+HOMEPAGE="http://prawn.majesticseacreature.com/"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+ruby_add_bdepend "dev-ruby/test-spec dev-ruby/mocha"
+
+ruby_add_rdepend ">=dev-ruby/prawn-core-${PV}"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}