summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2002-08-18 00:43:41 +0000
committerAron Griffis <agriffis@gentoo.org>2002-08-18 00:43:41 +0000
commite9eadb674c061fd9f5e9ec0423fe846fcaf72592 (patch)
treef3ca97104c9852df722cc0049efd61c2147ae2d8 /dev-ruby/racc
parentfirst relase (diff)
downloadgentoo-2-e9eadb674c061fd9f5e9ec0423fe846fcaf72592.tar.gz
gentoo-2-e9eadb674c061fd9f5e9ec0423fe846fcaf72592.tar.bz2
gentoo-2-e9eadb674c061fd9f5e9ec0423fe846fcaf72592.zip
updated to racc-1.4.1
Diffstat (limited to 'dev-ruby/racc')
-rw-r--r--dev-ruby/racc/ChangeLog28
-rw-r--r--dev-ruby/racc/files/digest-racc-1.4.11
-rw-r--r--dev-ruby/racc/racc-1.4.1.ebuild28
3 files changed, 47 insertions, 10 deletions
diff --git a/dev-ruby/racc/ChangeLog b/dev-ruby/racc/ChangeLog
index 9af25792d568..8024e3d6ee7f 100644
--- a/dev-ruby/racc/ChangeLog
+++ b/dev-ruby/racc/ChangeLog
@@ -1,17 +1,25 @@
# ChangeLog for dev-ruby/racc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/ChangeLog,v 1.2 2002/07/08 02:33:16 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/ChangeLog,v 1.3 2002/08/18 00:43:41 agriffis Exp $
+
+*racc-1.4.1 (17 Aug 2002)
+
+ 17 Aug 2002; Aron Griffis <agriffis@gentoo.org> racc-1.4.1.ebuild:
+
+ Updated to version 1.4.1 and modified the ebuild to work correctly for the
+ new version.
*racc-1.2.4 (1 Feb 2002)
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that
+ the comments should well explained and written in clean English. The
+ details about writing correct changelogs are explained in the
+ skel.ChangeLog file which you can find in the root directory of the
+ portage repository.
- 07 Jul 2002; Aron Griffis <agriffis@gentoo.org> racc-1.2.4.ebuild:
+ 07 Jul 2002; Aron Griffis <agriffis@gentoo.org> racc-1.2.4.ebuild:
- Added LICENSE, KEYWORDS, SLOT.
+ Added LICENSE, KEYWORDS, SLOT.
diff --git a/dev-ruby/racc/files/digest-racc-1.4.1 b/dev-ruby/racc/files/digest-racc-1.4.1
new file mode 100644
index 000000000000..992328c6f822
--- /dev/null
+++ b/dev-ruby/racc/files/digest-racc-1.4.1
@@ -0,0 +1 @@
+MD5 70553dbc819f706989a9f10cf52dc9cb racc-1.4.1-all.tar.gz 120111
diff --git a/dev-ruby/racc/racc-1.4.1.ebuild b/dev-ruby/racc/racc-1.4.1.ebuild
new file mode 100644
index 000000000000..8cf4c12fb3e5
--- /dev/null
+++ b/dev-ruby/racc/racc-1.4.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/racc-1.4.1.ebuild,v 1.1 2002/08/18 00:43:41 agriffis Exp $
+
+S=${WORKDIR}/${P}-all
+DESCRIPTION="LALR parser generator for Ruby"
+SRC_URI="http://www.loveruby.net/archive/racc/${P}-all.tar.gz"
+HOMEPAGE="http://www1.u-netsurf.ne.jp/~brew/mine/en/index.html"
+LICENSE="LGPL"
+KEYWORDS="x86"
+SLOT="0"
+
+DEPEND=">=dev-lang/ruby-1.6.1
+ >=dev-ruby/amstd-1.9.5"
+
+src_compile() {
+ ruby setup.rb config --without=amstd || die
+ ruby setup.rb setup || die
+}
+
+src_install () {
+ # It appears that this reconfig doesn't hurt anything.
+ # The --prefix and --rb-dir args don't work on the install line.
+ ruby setup.rb config \
+ --prefix=${D}/usr \
+ --rb-dir=${D}/usr/lib/ruby/site_ruby/1.6 || die
+ ruby setup.rb install || die
+}