summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-28 12:27:41 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-28 12:27:41 +0000
commit3c18a4744aeca40be5f3ae7f38facc7f9f9bf607 (patch)
treeabf746360c989903cd735742b99b5b04462ea61e /dev-ruby/rack-protection
parentFix deps, use fdo-mime for desktop update (diff)
downloadgentoo-2-3c18a4744aeca40be5f3ae7f38facc7f9f9bf607.tar.gz
gentoo-2-3c18a4744aeca40be5f3ae7f38facc7f9f9bf607.tar.bz2
gentoo-2-3c18a4744aeca40be5f3ae7f38facc7f9f9bf607.zip
Initial import.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rack-protection')
-rw-r--r--dev-ruby/rack-protection/ChangeLog10
-rw-r--r--dev-ruby/rack-protection/metadata.xml9
-rw-r--r--dev-ruby/rack-protection/rack-protection-1.1.4.ebuild23
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/rack-protection/ChangeLog b/dev-ruby/rack-protection/ChangeLog
new file mode 100644
index 000000000000..d651edb71fe9
--- /dev/null
+++ b/dev-ruby/rack-protection/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/rack-protection
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack-protection/ChangeLog,v 1.1 2011/12/28 12:27:41 graaff Exp $
+
+*rack-protection-1.1.4 (28 Dec 2011)
+
+ 28 Dec 2011; Hans de Graaff <graaff@gentoo.org>
+ +rack-protection-1.1.4.ebuild, +metadata.xml:
+ Initial import.
+
diff --git a/dev-ruby/rack-protection/metadata.xml b/dev-ruby/rack-protection/metadata.xml
new file mode 100644
index 000000000000..9fdeb09b3746
--- /dev/null
+++ b/dev-ruby/rack-protection/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+<longdescription>
+Rack provides a common API for connecting web frameworks, web servers and layers
+of software inbetween.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-ruby/rack-protection/rack-protection-1.1.4.ebuild b/dev-ruby/rack-protection/rack-protection-1.1.4.ebuild
new file mode 100644
index 000000000000..f9f04d227f52
--- /dev/null
+++ b/dev-ruby/rack-protection/rack-protection-1.1.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack-protection/rack-protection-1.1.4.ebuild,v 1.1 2011/12/28 12:27:41 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="rack-protection.gemspec"
+
+inherit ruby-fakegem eutils versionator
+
+DESCRIPTION="This gem protects against typical web attacks."
+HOMEPAGE="https://github.com/rkh/rack-protection"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1)"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/rack-test dev-ruby/rspec:2 )"