summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2015-06-27 23:54:14 +0000
committerMichael Orlitzky <mjo@gentoo.org>2015-06-27 23:54:14 +0000
commit3150a62523e866b8c2034b0672872c53ca3b7ec3 (patch)
treeed72d9aa556edd96f2810283d78fdc81c79d4cbf /dev-ruby/rbpdf
parentAdding optional kdbus patch. Won't apply by default. Use flags 'kdbus' and 'e... (diff)
downloadgentoo-2-3150a62523e866b8c2034b0672872c53ca3b7ec3.tar.gz
gentoo-2-3150a62523e866b8c2034b0672872c53ca3b7ec3.tar.bz2
gentoo-2-3150a62523e866b8c2034b0672872c53ca3b7ec3.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x6F48D3DA05C2DADB!)
Diffstat (limited to 'dev-ruby/rbpdf')
-rw-r--r--dev-ruby/rbpdf/ChangeLog8
-rw-r--r--dev-ruby/rbpdf/rbpdf-1.18.5.ebuild57
-rw-r--r--dev-ruby/rbpdf/rbpdf-1.18.6.ebuild58
3 files changed, 65 insertions, 58 deletions
diff --git a/dev-ruby/rbpdf/ChangeLog b/dev-ruby/rbpdf/ChangeLog
index 3db4ebf17978..af68024bdee5 100644
--- a/dev-ruby/rbpdf/ChangeLog
+++ b/dev-ruby/rbpdf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rbpdf
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rbpdf/ChangeLog,v 1.2 2015/06/07 19:17:48 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rbpdf/ChangeLog,v 1.3 2015/06/27 23:54:14 mjo Exp $
+
+*rbpdf-1.18.6 (27 Jun 2015)
+
+ 27 Jun 2015; Michael Orlitzky <mjo@gentoo.org> +rbpdf-1.18.6.ebuild,
+ -rbpdf-1.18.5.ebuild:
+ Version bump.
07 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add github to remote-id in metadata.xml
diff --git a/dev-ruby/rbpdf/rbpdf-1.18.5.ebuild b/dev-ruby/rbpdf/rbpdf-1.18.5.ebuild
deleted file mode 100644
index f6374e519ffb..000000000000
--- a/dev-ruby/rbpdf/rbpdf-1.18.5.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rbpdf/rbpdf-1.18.5.ebuild,v 1.1 2015/04/11 02:59:00 mjo Exp $
-
-EAPI=5
-
-# As long as we conditionally depend on dev-ruby/rails:3.2, we're
-# helpless to add ruby21 or ruby22 support. It should be possible, it
-# just hasn't happened yet. See https://github.com/naitoh/rbpdf/issues/9
-USE_RUBY="ruby19 ruby20"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Ruby on Rails TCPDF plugin"
-HOMEPAGE="https://github.com/naitoh/rbpdf"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-# We need to set up a fake Rails environment to run the tests.
-ruby_add_bdepend "test? ( dev-ruby/rails:3.2 )"
-
-src_test() {
- # Create a fake Rails environment once, then do the default ruby-ng
- # thing. Make sure we use the rails-3.x.y executable.
- local rails="${ROOT}usr/bin/rails-3.2*"
-
- $rails new "${T}/dummy" \
- --skip-javascript \
- --skip-git \
- --skip-bundle \
- --skip-sprockets \
- --skip-active-record \
- || die "failed to create rails environment"
-
- ruby-ng_src_test
-}
-
-each_ruby_test() {
- # The test suite needs to run within a Rails environment, so in
- # src_test(), we created an empty Rails instance in ${T}/dummy. Now
- # we copy ourselves into the vendor/plugins directory of that Rails
- # instance, and run the tests using Rails's Rakefile. Assuming the
- # tests pass, we remove the plugin again so everything is nice and
- # tidy for the next ruby implementation.
- cp -r . "${T}/dummy/vendor/plugins/${PN}" || \
- die "failed to install plugin"
- cd "${T}/dummy" || die
- rake test TEST="vendor/plugins/${PN}/test/*_test.rb" || \
- die "test suite failed"
- rm -r "vendor/plugins/${PN}" || die "failed to uninstall plugin"
-}
diff --git a/dev-ruby/rbpdf/rbpdf-1.18.6.ebuild b/dev-ruby/rbpdf/rbpdf-1.18.6.ebuild
new file mode 100644
index 000000000000..afbdfcae1492
--- /dev/null
+++ b/dev-ruby/rbpdf/rbpdf-1.18.6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rbpdf/rbpdf-1.18.6.ebuild,v 1.1 2015/06/27 23:54:14 mjo Exp $
+
+EAPI=5
+
+# ruby22 support waiting on dev-ruby/action{pack,view}.
+# ruby21 works, but not while we support rails-3.2.
+USE_RUBY="ruby19 ruby20"
+
+# Avoid the complexity of the "rake" recipe and run the tests manually.
+RUBY_FAKEGEM_RECIPE_TEST=none
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby on Rails TCPDF plugin"
+HOMEPAGE="https://github.com/naitoh/rbpdf"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# Try to pick the right version of minitest. Conflicts are still
+# possible, but this is probably the best we can do...
+ruby_add_bdepend "test? ( || (
+ ( dev-ruby/actionpack:3.2 dev-ruby/minitest:0 )
+ ( dev-ruby/actionpack:4.0 dev-ruby/minitest:0 )
+ ( dev-ruby/actionview:* dev-ruby/minitest:5 )
+) )"
+
+# We need the action_view gem; it was split out of actionpack in 4.1.
+ruby_add_rdepend "|| (
+ dev-ruby/actionpack:3.2
+ dev-ruby/actionpack:4.0
+ dev-ruby/actionview:*
+)"
+
+all_ruby_prepare(){
+ default
+
+ # This test is enabled automagically in the presence of rmagick, and
+ # then fails.
+ rm -f test/rbpdf_image_rmagick_test.rb \
+ || die "failed to remove rmagick tests"
+}
+
+each_ruby_test() {
+ local cmd='gem "minitest"'
+ cmd+=' and '
+ cmd+='require "minitest/autorun"'
+ cmd+=' and '
+ cmd+='Dir["test/**/*_test.rb"].each{|f| require f}'
+ ${RUBY} -Ilib:.:test -e "${cmd}" || die "test suite failed"
+}