summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-14 14:18:25 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-14 14:18:25 +0000
commitbece845ce9f80405a7699e7b60579af10f4cc9a2 (patch)
tree7e22980848fee97ba5930cb2f140e72f67aeabde /dev-ruby/redcloth
parentRemove unused patch; add a new revision of rake-compiler that calls RSpec and... (diff)
downloadgentoo-2-bece845ce9f80405a7699e7b60579af10f4cc9a2.tar.gz
gentoo-2-bece845ce9f80405a7699e7b60579af10f4cc9a2.tar.bz2
gentoo-2-bece845ce9f80405a7699e7b60579af10f4cc9a2.zip
Port to rspec helper for testing.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/redcloth')
-rw-r--r--dev-ruby/redcloth/ChangeLog6
-rw-r--r--dev-ruby/redcloth/redcloth-4.2.9.ebuild17
2 files changed, 8 insertions, 15 deletions
diff --git a/dev-ruby/redcloth/ChangeLog b/dev-ruby/redcloth/ChangeLog
index 694591d8d58b..5bc6c16e9fb5 100644
--- a/dev-ruby/redcloth/ChangeLog
+++ b/dev-ruby/redcloth/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/redcloth
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/ChangeLog,v 1.72 2012/08/09 14:34:23 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/ChangeLog,v 1.73 2012/08/14 14:18:25 flameeyes Exp $
+
+ 14 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> redcloth-4.2.9.ebuild:
+ Port to rspec helper for testing.
09 Aug 2012; Anthony G. Basile <blueness@gentoo.org> redcloth-4.2.9.ebuild:
Stable ppc, bug #427594
@@ -278,4 +281,3 @@
26 Jan 2005; Michael Kohl <citizen428@gentoo.org> +metadata.xml,
+redcloth-3.0.1.ebuild:
Initial import. Ebuild submitted by Leonardo Boshell in bug #71520
-
diff --git a/dev-ruby/redcloth/redcloth-4.2.9.ebuild b/dev-ruby/redcloth/redcloth-4.2.9.ebuild
index faa25426ec49..61c4e681b311 100644
--- a/dev-ruby/redcloth/redcloth-4.2.9.ebuild
+++ b/dev-ruby/redcloth/redcloth-4.2.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/redcloth-4.2.9.ebuild,v 1.6 2012/08/09 14:34:23 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/redcloth-4.2.9.ebuild,v 1.7 2012/08/14 14:18:25 flameeyes Exp $
EAPI=4
@@ -10,7 +10,7 @@ USE_RUBY="ruby18 ree18 ruby19"
RUBY_FAKEGEM_NAME="RedCloth"
-RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_DOCDIR="doc"
@@ -33,17 +33,12 @@ SLOT="0"
KEYWORDS="amd64 ~hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
-DEPEND="$DEPEND
- dev-util/ragel"
-RDEPEND="$RDEPEND"
+DEPEND+=" dev-util/ragel"
ruby_add_bdepend "
>=dev-ruby/rake-0.8.7
>=dev-ruby/rake-compiler-0.7.1
- test? (
- >=dev-ruby/rspec-2.4
- >=dev-ruby/diff-lcs-1.1.2
- )"
+ test? ( >=dev-ruby/diff-lcs-1.1.2 )"
pkg_setup() {
ruby-ng_pkg_setup
@@ -64,7 +59,3 @@ each_ruby_compile() {
# is a mess
${RUBY} -S rake compile || die "rake compile failed"
}
-
-each_ruby_test() {
- ${RUBY} -I lib -S rspec spec || die
-}