summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-04-25 05:36:25 +0000
committerHans de Graaff <graaff@gentoo.org>2014-04-25 05:36:25 +0000
commitb62cdbb6915869ba36e23f06a8822767c1974f7b (patch)
treee191a7eff3e732a125c4482b7366dfb42885515a /dev-ruby/rjb
parentVersion bump. (diff)
downloadgentoo-2-b62cdbb6915869ba36e23f06a8822767c1974f7b.tar.gz
gentoo-2-b62cdbb6915869ba36e23f06a8822767c1974f7b.tar.bz2
gentoo-2-b62cdbb6915869ba36e23f06a8822767c1974f7b.zip
Version bump. Install documentation. Fix tests to work and avoid tests that cannot work for us. Use eclass to install additional files. Add ruby20, ruby21.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/rjb')
-rw-r--r--dev-ruby/rjb/ChangeLog9
-rw-r--r--dev-ruby/rjb/rjb-1.4.9.ebuild73
2 files changed, 81 insertions, 1 deletions
diff --git a/dev-ruby/rjb/ChangeLog b/dev-ruby/rjb/ChangeLog
index 3e629dccd6d1..9027e4c6d0c2 100644
--- a/dev-ruby/rjb/ChangeLog
+++ b/dev-ruby/rjb/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/rjb
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rjb/ChangeLog,v 1.3 2014/04/25 05:17:59 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rjb/ChangeLog,v 1.4 2014/04/25 05:36:25 graaff Exp $
+
+*rjb-1.4.9 (25 Apr 2014)
+
+ 25 Apr 2014; Hans de Graaff <graaff@gentoo.org> +rjb-1.4.9.ebuild:
+ Version bump. Install documentation. Fix tests to work and avoid tests that
+ cannot work for us. Use eclass to install additional files. Add ruby20,
+ ruby21.
25 Apr 2014; Hans de Graaff <graaff@gentoo.org> -rjb-1.4.5.ebuild:
Cleanup.
diff --git a/dev-ruby/rjb/rjb-1.4.9.ebuild b/dev-ruby/rjb/rjb-1.4.9.ebuild
new file mode 100644
index 000000000000..1c1b8fb8d49a
--- /dev/null
+++ b/dev-ruby/rjb/rjb-1.4.9.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rjb/rjb-1.4.9.ebuild,v 1.1 2014/04/25 05:36:25 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_EXTRADOC="readme.txt ChangeLog"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit java-pkg-2 ruby-ng ruby-fakegem
+
+DESCRIPTION="Rjb is a Ruby-Java software bridge"
+HOMEPAGE="http://rjb.rubyforge.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples hardened"
+
+DEPEND=">=virtual/jdk-1.5
+ hardened? ( sys-apps/paxctl )"
+RDEPEND="virtual/jre"
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ java-pkg-2_pkg_setup
+}
+
+all_ruby_prepare() {
+ # The console is not available for testing.
+ sed -i -e '/test_noarg_sinvoke/,/end/ s:^:#:' test/test.rb || die
+
+ # Avoid encoding tests since not all locales may be available.
+ sed -i -e '/test_kjconv/,/^ end/ s:^:#:' test/test.rb || die
+}
+
+each_ruby_prepare() {
+ #dev-lang/ruby might need the "hardened" flag to enforce the following:
+ if use hardened; then
+ paxctl -v /usr/bin/ruby 2>/dev/null | grep MPROTECT | grep disabled || ewarn '!!! rjb may only work if ruby is MPROTECT disabled, but not really sure\n please disable it if required using paxctl -m /usr/bin/ruby'
+ fi
+ # force compilation of class file for our JVM
+ rm -rf data
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake V=1 -C ext CFLAGS="${CFLAGS} -fPIC" archflags="${LDFLAGS}"
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ # currently no elegant way to do this (bug #352765)
+ ruby_fakegem_newins ext/rjbcore.so lib/rjbcore.so
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r samples
+ fi
+}
+
+each_ruby_test() {
+ ${RUBY} -C test -I../lib:.:../ext test.rb || die
+}